Sign-in / Sign-up
Your question

Belkin n150 f9k1001V4

Tags:
  • Configuration
  • Routers
  • Belkin
  • Wireless Networking
Last response: in Wireless Networking
July 12, 2012 2:58:05 AM

I have just bought a Belkin n150 router. Connected it to my modem and PC and I'm recieving internet. Connected my phone and laptop and getting wireless.

The issue, however, is that I cannot login to the router page. The login says to leave blank for default, but it gives me an incorrect password error. I have tried resetting using the button located above the power cable to go back to defaults, but I continue to recieve the error.

I have tried a all the other usual default passwords, password, administrator, admin, etc.

I'm at a loss. I've gone through pages of google search results and found nothing. Have I missed something obvious or did Walmart sell me a defective router?

More about : belkin n150 f9k1001v4

July 12, 2012 2:07:20 PM

sometimes you need to press the reset button before you plug in the power and then keep it pressed for about 30 sec for the router to be reset to default.
m
0
l