Sign in with
Sign up | Sign in
Your question
Closed

ISP only allows one login at a time, using Belkin N150 access point.

Last response: in Wireless Networking
Share
July 12, 2012 3:37:26 AM

I have a problem with an ISP (SniperHill, http://www.sniperhill.net/) and using an access point that I have solved...but have a new problem. I put the link for this original problem.

***

http://www.tomshardware.com/forum/forum2.php?config=tom...

***
So from the post above, I now have my Belkin N150 configured and life is good, but I have new problem. The ISP only allows ONE username and password per paid subscription to be logged in at time (and it can detect if more than one device is attempting to log in even when logged in through the access point) . I am ok with that, everyone needs to make a living. But what I don’t like is that I can’t be logged on at the same time with my netbook, iPod, Kindle, and laptop for a service I am paying good money for, and I am not sharing my signal with anyone else. The ISP won't help...and I don't have any other provider choice. Typical customer service from a monopoly.

So, this is what happens. I start my Dell laptop, open the browser, it connects to the Belkin N150, and the page will open up to SniperHill’s login screen. I log in, and am able to begin surfing. Now, at this point, if I fire up, say, my Asus netbook, it will connect to the Belkin N150 without problems. I open my browser, and SniperHill’s login screen appears. It will “ignore” my login. However, if I log out of the Dell laptop, then try again with the Asus netbook, then the netbook will work.

My question is how the ISP knows there is more than one device logged in? Once I have logged in successfully with one router with one device, would that not open the gateway, and the Belkin N150 could farm out it signal to all my devices?

How can I get this to work? It seems that because the Belkin N150 is used as an access point, it only allows the one connection? How do I share it?

By the way, a router does not work with this ISP. Not sure why, but I had no luck with my Linksys Wireless 54G. It seems using access point is mandatory if I want wireless.

Thanks.
July 12, 2012 10:51:22 PM

That provider only allows one device at a time and no router use. It is just the way that they provide service in locations with such a limited Internet infrastructure.

The only thing that *might* work is to set up an adhoc network of wireless devices that use Internet sharing from the device that is connected to SniperHill, so the connected device would need two adapters -- one to Sniper Hill and the second to the adhoc group of devices that would share the connection from the first.
Score
0
July 13, 2012 2:09:50 AM

I tried doing that, where the Ethernet cable is connected to the laptop, and then created an ad-hoc network. The other devices connected, but no Internets flowing to them. The "base station" laptop still worked though.

I have never been able to get ad-hoc networks to work in other circumstances either. So I probably just don't know what I am doing!

I am convinced there has to be a way to do this. Bluetooth, maybe?
Score
0
Related resources
Can't find your answer ? Ask !
July 13, 2012 8:35:06 PM

For the adhoc network to have Internet you would have to turn Internet connection sharing on in the network adapter configuration, or bridge the adapters in the network adapter configuration (if you bridge ICS must be off).
Score
0
July 14, 2012 1:23:19 AM

if u on laptop and win 7 try connectify !!!!
connect ethernet cable to laptop , turn on wifi in laptop and download and install software called as connectify its free .
Score
0
July 14, 2012 11:29:59 AM

You don't need any software to manage connection sharing in Windows 7. It is done very simply with ICS or creating a Windows adapter bridge.
Score
0
July 16, 2012 6:18:02 AM

yeah but sometimes its even easier using a software like connectify
, virtual router , etc..
Score
0
August 15, 2012 7:21:46 PM

I am using connectify to catch the wireless signal (the only option as there are no hard lines coming in to my building) and the LAN to send it back out to the router. If i disconnect the line that is going to the router and connect a computer i get the login webpage so i know the connectify is working right. I just need to figure out how to get my Router (Netgear N750) to log in and share that connection to other computers.
Score
0
August 15, 2012 7:27:15 PM

popeyearms I am now having the same problem as you basically. I have connectify pro and it allows me to broadcast the signal to other devices but they all get the login page as well even if the main computer is already logged in.
Score
0
August 22, 2012 3:09:36 AM

I thought I was on to something with Connectify, but I could not get my iPod to work with it. When I tried this a few weeks ago, I had to type is this really tedious 40-something-characters password using the iPod keyboard (if that doesn't irk you, not much else will), and it still would not work. It would "connect' and show it as connected on both the laptop and the iPod, but still no Internet.

Bluetooth connection? No dice either. Ad-hoc network with Internet sharing turned on? I must have done something wrong.

I've just given up. At $90 per month, this service is a ripoff, but I don't have a choice. It's a monopoly ISP on many Afghanistan bases.

If anyone has a rubber-ducky easy set of instructions to follow, I'll be glad to try them. If they work, you will truly be a hero. Many of my colleagues are equally frustrated with this same problem.
Score
0
August 22, 2012 7:42:25 AM

popeyearms76 said:
I tried doing that, where the Ethernet cable is connected to the laptop, and then created an ad-hoc network. The other devices connected, but no Internets flowing to them. The "base station" laptop still worked though.

I have never been able to get ad-hoc networks to work in other circumstances either. So I probably just don't know what I am doing!

I am convinced there has to be a way to do this. Bluetooth, maybe?
Have you tried creating the adhoc network and then with Ethernet to a hub (not a router) and then in the laptop that gets the wireless from SniperHill go to the network control panel/change adapter settings > first make sure that ICS is OFF in both the wireless and wired (ad hoc) or bluetooth adapters, then highlight both adapters, right click and select bridge adapters?

One other possibility if you have a router handy, from your laptop that gets wireless sniper hill can you connect your Ethernet port to a router and bridge the adapters as above. While they don't allow routers, if you hide it behind the laptop wireless it might work.

Likely they have thought of this and blocked it, but worth a try if you haven't.

Just a quick final idea would be to connect an ad hoc network and then modify your Laptop Windows 7 router table to the same gateway as Sniper Hill, this might effectively disguise the other device. You would only use a default gateway for Sniper Hill, something along the lines of case one here ( http://www.ni.com/white-paper/12558/en ) OR this example ( http://www.topwebhosts.org/articles/setup-multihomed-ho... ) where perhaps the proxy ARP would be your laptop MAC to disguise the internal devices.
Score
0

Best solution

August 22, 2012 2:45:00 PM

Let’s be clear. It doesn’t matter if you use hardware (e.g., Linksys, Belkin) or software (e.g., ICS, Connectify), they’re all routers and functionally equivalent. I only mention it in case it does result in some policy violation w/ the ISP and perhaps something you wish to avoid.

The solution is indeed a router. But while the router is necessary, it’s not sufficient.

Every time you access the ISP’s network, you’re being redirected to his captive portal (proxy), which tracks you just like any other website that requires a login; w/ a session cookie. The router is no defense since the session is managed at the application protocol level (http/https), not at the network protocol level (TCP/IP or ethernet).

In a nutshell, the ISP is tracking your sessions and associating them w/ your MAC address to limit to your access.

The only way to defeat a proxy is with another proxy. You need to HIDE your traffic from the prying eyes of the ISP so he can’t impose these restrictions. And assuming he doesn’t go so far as to block all proxies, you could probably use a VPN service. Or perhaps tunneling back home to your own or a friend’s VPN server.

Now what’s the most practical way to approach the VPN is harder to say. It might be easiest to use a laptop to login to the ISP, establish the VPN connection, and finally share the VPN connection w/ your other devices using ICS. Or perhaps a dd-wrt router w/ a PPTP configured WAN.

As far as I can see, that’s the only way you’re going to defeat this ISP.
Share
August 23, 2012 9:26:45 AM

Success! I am not sure what the trick was, but last night, I connected laptop with Ethernet, connected to VPN, turned on Internet Connection Sharing, and then used Connectify with an unencrypted "open" connection. The iPod worked, and laptop could still surf. They were both slow as hell, but they worked. I tried several new things this time so, I am not sure what did the trick. I think the VPN is what did it. Thanks to all for your replies, especially to eibgrad (nice dog, btw).

The only drawback with this setup is that the laptop must remain tethered with the Ethernet cable, but at least I got the iPod connected.
Score
0
August 23, 2012 9:27:24 AM

Best answer selected by popeyearms76.
Score
0
August 23, 2012 1:26:11 PM

This topic has been closed by Area51reopened
Score
0
!