Sign in with
Sign up | Sign in
Your question
Closed

C&C generals 32bit game on 64 bit W7 system

Last response: in Windows 7
Share
April 23, 2012 9:47:41 AM

hi ,
i have a C&C Generals game that plays great on Win XP 32bit but not on my new Win7 64bit system?
Is there any way to get it going on my 64bit system?
please help..

thanks a lot

Best solution

a b $ Windows 7
April 23, 2012 10:02:24 AM

Hi,
Try using compatibility mode.
Uninstall the game first. Then using compatibility mode, run the setup.exe or the autorun.exe or whatever it maybe in WinXP SP2 and in administrator mode. After you are done, right click on the C&C game icon and under compatibility tab, check 'WinXP SP2' and 'Run this program as an administrator'.

Also, if this doesn't help, try using Virtual XP.
http://www.sevenforums.com/tutorials/8247-windows-xp-mo...
Share
Related resources
April 23, 2012 11:38:49 PM

al_visser said:
hi ,
i have a C&C Generals game that plays great on Win XP 32bit but not on my new Win7 64bit system?
Is there any way to get it going on my 64bit system?
please help..

thanks a lot




hi ,I tried with compatibilty mode as you guys said ....looks promising at first but when it starts up get a message "sorry error occured "(technical difficulty) and shuts the start up down
Score
0
April 24, 2012 12:09:17 AM

I found this ages ago to fix this same issue **FIXED**

Ok guys, found a fix. If anyone is having the same problems too, this will work for both XP and Vista, x32 and x64 if you're missing an options.ini file in My Documents for XP or User Name\Documents\ for Vista. If you're missing the options.ini file, do this and it will work!

Open your My Documents folder and add "options.ini" file (plain text file with renamed extension), then add the following and save the file:

AntiAliasing =
DrawScrollAnchor =
GameSpyIPAddress = 0.0.0.0
Gamma = 50
IPAddress = 0.0.0.0
IdealStaticGameLOD = High
LanguageFilter = false
MoveScrollAnchor =
MusicVolume = 55
Resolution = 800 600
Retaliation = yes
SFX3DVolume = 79
SFXVolume = 71
ScrollFactor = 50
SendDelay = no
StaticGameLOD = Low
UseAlternateMouse = no
UseDoubleClickAttackMove = no
VoiceVolume = 70


After that, re-enter the game and set options to your liking.


Hope it helps you
Score
0
May 1, 2012 1:13:10 AM

Best answer selected by al_visser.
Score
0
a b $ Windows 7
May 1, 2012 7:01:29 AM

This topic has been closed by Nikorr
Score
0
!