Sign-in / Sign-up
Your question

Using LAN to LAN router bridge (Westell 9100em & WD n900) config issue

Tags:
  • Configuration
  • Routers
  • LAN
  • Western Digital
  • Wireless Networking
Last response: in Wireless Networking
July 20, 2012 2:54:11 AM

Hello all,

I'll start by explaining my network and what I am trying to accomplish. I'll include sidenotes in parenthesis to help keep what I am saying clear.

Currently, my ONT feeds to my verizon-issued Westell 9100 EM router via coax. It is not possible for me to run CAT5/6 from the ONT. I have had terrible experiences with this router, and I purchased the Western Digital Mynet N900 to take some of the responsibilities and increase wireless reliability in my home. I am trying to get the Westell to handle all DHCP and have it issue the IPs, and LAN to LAN this router to the N900 (The WAN on the secondary Western Digital Mynet N900 router will not be used). The Western Digital Mynet N900 will act as a switch for my entire wired home network as well as broadcoast a wireless network (The wireless on the Westell is disabled).


I did a factory reset on both routers and went through these steps I found (posted below), which at first, seemed to work great. However, after only a minute or two pages would fail to load at the DNS level, and I wouldn't be able to access either of my router's configuration pages (I was able to access both during the brief window of success).

I have a feeling it's a certain setting one of the routers or something I'm missing, but I can't for the life of me figure out how to make this work.


Here are the instructions I have been following, to show you exactly how this configuration was set up: (Please note, this guide is specifically for an Actiontec that is very similar to my Westell 9100)



--------------
First, set up the primary router:

1. To start with a simple configuration, disconnect or power off all devices connected to the Actiontec except the computer used to configure it. Reset the Actiontec to its default configuration by pressing the reset button for 10 seconds. Note that this will delete all port forwards and filter rules you may have already established. You may want to make notes of your existing config before resetting to default. The default Actiontec router address is 192.168.1.1. Point your browser to the login page.

2. When reset, the Actiontec will boot up and ask you to set a password. It is suggested it be something different than password or password1. I use 8 characters in an alpha/number mix. Make sure you can connect to the internet. This verifies primary router connectivity.

3. Click on My Network icon, click Network Connections, then Network (Home/Office), then click Settings button. Change the DHCP address range by scrolling down to locate IP Address Distribution. Verify DHCP Server is selected in the dropdown box. Set the Start IP Address to 192.168.1.11, and leave the Ending IP Address at 192.168.1.254. You can use a different start or end address. I selected .11 because I want to have several, but not too many addresses I can use as static addresses. The secondary router will be one of them.

Click Apply, wait for the Actiontec to reconfig, then click Apply again to make it stick.

4. If you intend your secondary router to handle all the wireless connections, you may choose to disable the Actiontec Wireless. This might be the case if, for instance, your secondary router is Wireless-N. Disable Actiontec Wireless by clicking Wireless Settings icon, then click Basic Security Settings. Click item 1. Wireless Radio to Off. Then click Apply, wait for the Actiontec to reconfig, then click Apply.

5. Verify Internet connectivity, then shut off your PC.

Next, set up your router as secondary
6. Unplug your PC's wired connection from the Actiontec LAN port, then plug it into a LAN port on your secondary router. Make sure the secondary router WAN port is not connected to anything. Boot up your PC and the router and log into your secondary router's interface.

7. You should be able to login with a login and a password. If you are unable to, you may have to resort to a hard reset on the secondary router and use the operator's manual to determine the default login and password.

Please note that routers from different manufacturers will vary in their default settings and interface. If your PC is set to get a LAN address automatically, you can determine your IP address by typing "ipconfig /all" (without the quotes) at a command prompt, then press Enter.

You should be able to log in to your secondary router at "http://192.168.1.1" or by using your LAN IP address with .1 as the last octet.

8. Once logged in, ignore the router's Internet settings because the WAN port is not used. You need to change its Network Settings to set the Router IP address to 192.168.1.2 with Subnet mask 255.255.255.0.

9. Also, it's very important to Disable DHCP Server. On my secondary router after I made those changes, I needed to Save Settings.

Finally, connect secondary router to Actiontec
10. Then I connected a patch cable from a LAN port on the Actiontec to a LAN port on the secondary router, and clicked Reboot Now. Instructions for your router may vary.

After the secondary router reboot, reboot your PC. You should be connected to your secondary router and pick up a LAN IP from the Actiontec. Verify internet connectivity.

11. At this point, verify you can log in to the Actiontec at 192.168.1.1, and log in to your secondary router at 192.168.1.2. It will make no difference what router you are physically connected to for administration of both.

12. Any additional changes to primary or secondary routers can be made at this time. Here is where you may set wireless on the secondary router. Any port forwards will be done on the Actiontec. The secondary router WAN port is not connected.

To summarize:
Actiontec is set to serve DHCP addresses from 192.168.1.11 to 192.168.1.254, and your
secondary router has a static network address of 192.168.1.2 and DHCP is disabled.
Both are connected with a patch cable from LAN to LAN.
Straight or crossover cable doesn't matter because the Actiontec is self-sensing.

--------------

Does anyone have any thoughts on why the Western Digital Mynet N900 router would have a problem handling this kind of configuration? Or about how my Westell 9100 EM may be configured wrong? I greatly appreciate your time if you have read this and I appreciate any constructive feedback if you think you may actually know what's going on here. Thanks guys.

Jonathan

More about : lan lan router bridge westell 9100em n900 config issue

a b X LAN
July 20, 2012 3:25:20 AM

This is actually a very common configuration, and rarely presents a problem. The most common mistake it to not disable the DHCP server of the secondary router (N900 in your case).

Is this only a problem when using wireless, or does it not matter, wired or wireless users have similar problems on the N900?

What about wired users on the Westell, any abnormalities? IOW, is this only an issue on the N900, or do you have problems everywhere; wired, wireless, regardless of router?

m
0
l
July 20, 2012 3:53:31 AM

DHCP Server is disabled on the secondary router, N900.

All connections are lost, wired or wireless.

I have no wired connections to the Westell besides the LAN Cat5e to the N900. (The switch on the Westell is not 1000mbps, one of my main reasons for making this bridge.)
m
0
l
Related resources
a b X LAN
July 20, 2012 6:00:39 AM

Even a wired connection on the Westel doesn't work when configured this way?!

What if you pull the N900 ethernet cable from the Westel, leaving the Westel configured just as you have it now, can you now get a wired connection working on the Westel? If not, reboot it and try again.

What I'm trying to determine is what effect, if any, the N900 is really have on this configuration. IOW, if you pull the N900 from the Westel, and the Westel still doesn’t work, even after rebooting the Westel, then somehow you've messed up the Westel, and the fact the N900 is connected is irrelevant. OTOH, if you can connect via the Westel when the N900 is not connected, and the problem only occurs once the N900 is connected, then that suggests the N900 *is* the cause, and is somehow leading to a change that breaks the entire configuration.

IOW, you've reconfigured two devices, and are now testing them as a whole. And therefore we don't really know whether one, the other, or even both, are misconfigured. So you need to be creative in finding ways to test them in isolation.
m
0
l
July 20, 2012 6:27:29 AM

That's exactly how I'm talking to you right now.

Okay, here's where it gets interesting. I plugged in all of my wired connections into my N900 while it was still connected to the Westell. Everything worked perfectly. I was doing my rounds of testing, and I seemed to have full internet access with my desired results. I checked my Westell router config page to see if I could access it at 192.168.1.1 and it worked fine. I moved to check if I could see the N900 config at 192.168.1.2, it froze and failed, then completely killed my internet. No pages would load again. I then proceeded to plug my PC ethernet into the Westell, still no connectivity. I then proceed to disconnect the N900 from my network, leaving only the Westwell router with my PC alone on it, full connectivity and good to go.

So it would appear that the N900 is exactly what is causing the problem. How can I be of more assistance to help diagnose this further?

I greatly appreciate your time.
m
0
l
a b X LAN
July 20, 2012 6:47:03 AM

Is it possible to downgrade the N900 to 100Mbps rather than 1000Mbps (gigabit)? I know that’s an option for most PC ethernet adapters, not sure about the router. If not, try configuring the PC’s adapter w/ 100Mbps (I’m assuming its gigabit by default).

I'm just wondering if there's some sort of funky behavior related to the fact that one router is 100Mbps, the other Gigabit. Should work, but you never know.
m
0
l
a b X LAN
July 20, 2012 7:06:27 AM

P.S. Or maybe the gigabit router is using some other optimizations, say jumbo frames? Something you could disable? Anything you can do to make it more compatible w/ the 100Mbps switch of the Westel.
m
0
l
July 26, 2012 12:27:08 AM

It turns out that the problem was that on the secondary router there is a setting to change the device mode and I had to move it and make it a switch instead of a router. This allowed me to set my LAN IP address for the secondary router as well as my subnet mask and default gateway. Thanks for all the help guys.
m
0
l
July 26, 2012 12:46:32 AM

Scratch that. I lost connectivity again after a few minutes. Note: once the connectivity is lost, i must plug in my computer to the main Westell router and then I noticed that a webpage will only load once I disconnect the N900 from the network. I'll say that again, if I leave a page to load while everything is connected it will just sit and load and load and eventually time out, however if I unplug the N900 it IMMEDIATELY loads the page successfully. The N900 is doing something after x seconds or minutes that is throwing my network haywire. Following those instructions above gives me instant access until the N900 does something janky.

Thoughts?
m
0
l
a b X LAN
July 26, 2012 1:54:26 AM

None of this makes any sense. So let's take an entirely different approach. Perhaps even a better one in the long run.

Let's connect the N900 to the Westell, WAN to LAN respectively, making the N900 your private network. That's will create some isolation between the devices and perhaps change the behavior. So reset the N900 (let’s have a clean slate), give it a different IP network (e.g., 192.168.2.x), and see what happens.

[westell – 192.168.1.x](lan)<-- wire -->(wan)[n900 – 192.168.2.x]

If this works, and the Westell supports "bridge mode", then you could pass the public IP to the N900 and that pretty much reduces the Westel to only a modem. You could even reconfigure the Westell w/ a different network, say 10.0.0.x, and give yourself the 192.168.1.x network (if that’s what you prefer).

Because there's obviously something "funky" going on here and it's nearly impossible to diagnose it remotely. So let's change the thinking entirely regarding this architecture, if only to see if we can get some behavior closer to what we want.

If that doesn’t work, then maybe there’s something wrong w/ the N900’s hardware (rare, but it happens, these are cheap consumer grade devices, the QA control is minimal).
m
0
l
a b X LAN
July 26, 2012 2:11:30 AM

P.S. Wouldn't hurt to clear the various network caches on your computer(s) also. From the command line, issue the following commands and then reboot.

arp -d *
nbtstat -R
ipconfig /flushdns
ipconfig /registerdns
m
0
l