Sign in with
Sign up | Sign in
Your question

Cant install windows 7 Premium to Homebuilt Computer

Last response: in Windows 7
Share
April 25, 2012 7:44:21 PM

I have built my own pc and i know it works and all that but when i insert the disk for windows 7 Prem i get as far as to select drivers to be installed. It says no drivers were found and i dont know what to do at this point. thanks all

More about : install windows premium homebuilt computer

a b $ Windows 7
a b \ Driver
a b B Homebuilt system
April 25, 2012 8:46:04 PM

what kind of hard driver?

can you see the hard drive being detected in the BIOS?
m
0
l
a b $ Windows 7
April 25, 2012 8:51:59 PM

What kind of motherboard?

Did you plug in all the SATA drive cables: 1 power, 1 data?

To what port on the mobo: Intel?
m
0
l
Related resources
a c 113 B Homebuilt system
April 25, 2012 9:01:41 PM

In a modern machine you should not be prompted for drivers during installation, unless you are trying to install to a RAID array.
m
0
l
April 25, 2012 9:19:09 PM

Might be trying with AHCI set on also so if you got a disk with your MB you should have the drivers for AHCI or RAID on it and can go ahead and install the driver during OS install or go to the vendor site for the MB and download the correct driver. Its either that or you got hardware issues.
m
0
l
April 25, 2012 9:41:35 PM

I have a ASRock mobo and i know everything is plugged in right, the hardrives are not coming up at all, it wont let me install my mobo driver at OS install, unless im doing it wrong
m
0
l
April 25, 2012 10:38:14 PM

What kind of driver am i looking for? if i uncheck the hide drivers that are not compatible with my hardware a bunch of them come up
m
0
l
April 25, 2012 10:56:51 PM

Does it already have an operating system on it?
m
0
l
a b $ Windows 7
a b \ Driver
a b B Homebuilt system
April 25, 2012 11:14:04 PM

1) just use a single hard drive for now. unplug all other hard drives

2) make sure the SATA connection being used is set to AHCI (in BIOS). If in doubt, probably use the Intel one (seem motherboard manual)

3) Windows installation should not require any drivers now.

*Motherboards can have several different SATA chipsets (Intel, Gigabyte, Marvell). It sounds like you either have things set to RAID or Windows does not contain the drivers.

If you're still having issues:
- read the motherboard manual
- try the hard drive in EACH of the SATA chipsets, start with Intel's first
m
0
l
April 26, 2012 12:35:21 AM

I have a similar issue, I had Windows 7 Ultimate 32 bit installed, I up'd my memory from 2Gb to 8Gb, formatted and started over, decided to use my legal copy of Windows 7 Home Premium 64 Bit and it said press any key to boot from cd, did and during the first process of installation it said could not find driver and would not continue with installation. (Bios was also updated but all settings restored to previous state). Thought this weird and rechecked settings, retried, same error. I then inserted my legal copy of Windows 7 Ultimate 64 Bit and pressed key to continue and it went through the process with no issues and installed. (nothing changed in Bios). This could be and issue where home premium does not have the driver for the SATA port drivers for this motherboard but I didn't really care, just used ultimate any way. I have an Asus M4A77TD, nothing fancy..., so when it looks for drivers, make sure you have the drivers from the cd on a USB key and try accessing them when it first starts up and says press F2 for drivers, F6 for ....., find the drivers on the USB key and see if that works.
m
0
l
April 26, 2012 12:44:14 AM

do i need to install the stuff from my mobo disk first or do the OS first? there is currently no OS on this device
m
0
l
April 26, 2012 12:45:13 AM

Have you tried actually hitting F2 for drivers and pointing to your ICH driver for your particular motherboard? I have seen certain mobo / harddrive combos just not like each other unless you tell it to load the native ICH.
m
0
l
April 26, 2012 12:45:20 AM

whenever I put the ASRock disk in it says generate serial ATA Driver Diskette? [Y/N]
no matter what I press it reboots and starts all over
m
0
l
April 26, 2012 12:53:38 AM

F2 is not for drivers on mine. when i start my computer i get an ASRock Screen with F2 or DEL as run UEFI Setup, F11 for boot menu, F6 for instant flash, and TAB to switch screen. But it disappears after 3 seconds and tells me to insert boot media. I am just really stuck and dont understand what to do
m
0
l
April 26, 2012 12:59:11 AM

cadams - You need to install the OS first, drivers mean nothing unless they are giving an OS instructions. When you put the Windows DVD in you need to let go until it says boot media, or boot off DVD or whatever and go into the Windows setup and let it make a primary partition and a quick format and install.
m
0
l
April 26, 2012 1:22:47 AM

Ok, I think the problem is with my hard drive itself. I think I'm going to have to replace it. Does anyone have a recommendation for a good hard drive?


*** I have the thermaltake level 10 gt case which has 5 hard drive bays with built in ports, so any hard drive with a good amount of space that is compatible would work fine. Also, I will be using this computer to play video games a lot, like skyrim, SW:TOR, WoW, and others of those types.

Thanks everyone.
m
0
l
April 26, 2012 1:30:23 AM

Are you getting the Windows Installation part, and no drives are available to install them on?
m
0
l
April 26, 2012 1:40:57 AM

Are your drives visible on your Bios?
Are the drives NEW? Are they formatted?
m
0
l
April 26, 2012 2:50:23 AM

No to all. I know the problem is my hard drive. I need a new one, any suggestions
m
0
l
a b $ Windows 7
April 26, 2012 2:54:53 AM

Samsung SpinPoint F3 500GB-1TB, or F4 2TB.

Else Seagate Barracuda 7200.12 500GB - 2TB.
m
0
l
April 26, 2012 3:58:23 AM

go with at least a 120 gig SSD Crucial has the best reviewd and perfermance but ive had issues in using for others ive got a vertex in mine with no issues but the Crucial M4 or a samsung or intel are really great options. Ive used crucial for upgrades for others
m
0
l
!