Sign in with
Sign up | Sign in
Your question

Mapping Network Drive on Netgear Switch

Last response: in Networking
Share
August 24, 2012 11:44:58 AM

I am having great difficulty mapping to a Western Digital 'mybook live' (2TB), and have been through literally every relevent post on a range of forums.

I am running XP Professional 32 bit SP3 on a Dell workstation.

I am in a serviced office with internet connection via single ethernet port. This is set up as a VLAN for which I have 4 assigned IP addresses.

I am using a Netgear GS605v4 switch to create a small network on my side of the port. Hooked to this is the workstation, the mybook live, and a laptop.

All 3 connected components are assigned their IP addresses by DHCP. Both the workstation and the laptop can see the internet without difficulty. The networking of the components is another matter. Focusing on the workstation for the moment:

On the workstation, I can ping the mybook. I have always been able to see its upnp logo in My Network Places, and double clicking always takes me to the web browser based dashboard where I can set up the device. I was initially able to see the public folder in My Network Places too, and could map a drive to this in an Explorer window. Typically after some time, the mapping would be lost (even without re-booting the machine), but I would be able to delete the connection and re-map it. After several attempts at this I could no longer map the drive or see the public folder in My Network Places anymore.

After much internet searching and playing with lots of the suggested fixes (checking all required services available, matching user names between XP and the drive, playing with 'net view' etc) I was finally able to see and map the public folder yesterday by playing with the 'enable netbios' function in network connections (currently set to 'enable' from 'default' though this had not made any difference previously). I could see the drive in 'net view' though no master browser was listed, and once again map to the public folder, and access files on it.

On turning on the workstation this morning I find that the mapping has again been lost. This time net view is back to reporting a system 53 error. I can ping the drive and use the dashboard, and I can see the public folder in My Network Places, but clicking it or mapping to it results in the usual 'network path not found' errors.

The laptop is running Windows 7 and has not lost its mapping overnight, and can still access the public files.

Can anyone help? I am fairly clueless about networks. Is there perhaps some sort of issue with device naming being caused by the fact that I apparently have a VLAN and a peer-to-peer network? (I think....)

(The laptop and workstation cannot also access each other, but lets leave that for another day.....)

More about : mapping network drive netgear switch

August 24, 2012 11:18:19 PM

A lot of this is just due to the fact you're trying to use an antiquated naming service in a peer to peer network, where no one device (unlike a domain) takes responsibility for managing the naming service. There's supposed to be a master browser "elected" (to use MS's terminology), but I'm not sure that ever worked correctly.

IMO, the way to fix this is to use DNS, not WINS (Windows naming service). I run a DNS server off my dd-wrt router (DNSMasq) and have none of these problems, and haven't for years. Of course, running your own DNS server may not be practical. But a quick-n-dirty solution is to create a local DNS using the hosts file. You’d be amazed how a few lines in that file could greatly simplify things.

http://technet.microsoft.com/en-us/library/cc751132.asp...

Of course, this is only going to work if you use static IPs for all your devices. You can still rely on DHCP as long as the DHCP server supports the binding of MAC addresses to specific IPs.

Now use only those names in all your network mappings and other references.

August 26, 2012 11:52:56 AM

Wow, great response and link, thanks eibgrad.

I finally had some success last night following the advice on another online article to eliminate both

'NodeType'
and
'DhcpNodeType'

from the registry. Not sure what that has done but I now see the network drive as the master browser, and can map it in explorer.

I'm not sure if this is a fix given the unpredictable nature of the problem so far. Your alternative sounds very plausible to me and if I have any further issues I will give it a shot.

Appreciate your input.
!