Sign in with
Sign up | Sign in
Your question

Router Problem - Losing Connection

Last response: in Networking
Share
August 25, 2012 11:40:34 PM

Hi all,

So, I have Time Warner Cable internet and a Netgear WNDR3300 Router to run internet throughout the house and supply wireless to all my devices.

I play a lot of Team Fortress 2 and, in game, I refresh the server list to see what servers are available. Well, recently a problem started where, if I do that, it kills the internet to both the game and internet explorer, BUT I can still use TF2 chat. So, I bypassed the router and went directly from my cable modem to the computer and the problem goes away. Before trying that, I would have reboot both the modem and router to get it to work again.

I need that router working for the wireless and a couple other hard lines that go to it. Is there a setting I can change? It must have to do with pinging all those servers. I don't know much about networking and how it all works. Could the router just have gone bad? It isn't that old and it was relatively pricey (I think around $100 or so) so I woud hate to have to buy a new one.

Any and all help would be greatly appreciated.

Thanks!
August 27, 2012 2:16:44 AM

I'm not a gamer, so I'm not familiar to what extent it affects networking. I assume it has something to do w/ the number of concurrent connections its generating, perhaps overloading the router. That's why they make gaming routers, which have more resources available (mostly memory) to prevent these kinds of problems. But I'm guessing a bit here since I can't really "see" what's happening.

One “quick and dirty” solution does come to mind. Since the problem seems to go away when you’re connected directly to the modem, then perhaps keep it that way! And to keep others happy, install a second ethernet adapter on the PC, connect it to the WAN of the router, enable ICS on your PC’s internet connection, and share it w/ the router.

IOW, turn your PC into a router so it remains directly behind the modem. It will not only solve this problem, but probably improve your ping times!

Now there is a downside (isn’t there always?). Your PC is now on a different network from the rest of the devices in your home, which means it’s going to be difficult to share resources. But nothing says you can’t use a THIRD network connection, one that runs back to the router’s wired LAN or wireless AP so you’re now on BOTH networks! The only remaining issue is that you don’t want that network’s router to be your default gateway. To prevent it, configure the third network’s TCP/IP configuration manually using a static IP and simply not specify a gateway IP.

Granted, a bit convoluted, perhaps even confusing, but it would work, and unless you can determine exactly where things are going wrong w/ your current setup, at least it’s an option to keep in your back pocket.

September 6, 2012 1:39:58 AM

Thanks for the response. I finally decided to tae your advice and put in an ethernet card and connect my wireless router to it in order to use the wirless function. I did that and then went to my main network and enabled ICS.

The problem is that it isn't recognizing/allowing the router to access the internet. I don't know what else I need to do and I am completely incompetent when it comes to this stuff.

Can someone offer some suggestions to what I might be doing wrong?
Related resources
September 6, 2012 4:32:07 AM

Let's make sure you have this configured properly, since as I said, it is a bit convoluted.

[modem]<-- wire -->[your pc - ics enabled]<-- wire -->(wan)[router]<-- wire/wireless -->

So both ethernet adapters on your PC are configured for DHCP (automatic TCP/IP configuration) and you enable ICS on the network connection leading to the modem and share it w/ the network connection leading to the router. MAKE SURE IT’S THE ROUTER WAN PORT!

If done correctly, it will work because we know ICS works, and ICS doesn't care one wit what type of wired device is connected to the other end of that wire, be it a PC or a router. Anyone behind the router should have internet access.
September 6, 2012 11:33:14 PM

I don't know what I am doing wrong. I have it exactly like you specified ( I think anyway). I have the internet coming from the modem to the computer's motherboard ethernet port. Then I installed an ethernet card in to one of the slots on the motherboard and connected the router to that. I went into Network connections and enabled ICS on my main internet connection. Then checked to make sure that all the TCP/IP v6/v4 were all set to automatically get ip address on both networks. Now, on my router it has 5 ports: LAN 1-4 and one marked "internet". I hooked the cable to the one marked "internet" assuming that is the WAN port. The computer shows the ethernet card installed and it shows it in the network connections window but it says "no internet access".

Any and all help is greatly appreciated. I tried going through all the win7 help files to make sure everything is set right, but they explain it the same way you do and make it sound so easy.

ethernet card is a D-LINK DFE-530TX+ PCI Adaptor
Router is a Netgear WNDR3300 Wireless router

Computer is newly built with win 7.



September 7, 2012 12:08:48 AM

When I said both ethernet network connections should be using DHCP, I meant *before* ICS is enabled. Once ICS is enabled, it will *change* the network connection leading to the router to a static IP address (iirc, 192.168.137.1) and the router should pull an IP address from the ICS DHCP server in the same network (e.g., 192.168.137.2) to its WAN port. So check the router WAN and make sure it's something in the 192.168.137.x network, has a gateway IP of 192.168.137.1, etc.
September 7, 2012 3:37:49 PM

I don't understand why it isn't working. I feel like I followed your instructions exactly and I am seeing what you are telling me I should see.

I set it to ICS on the main network. ThenI went into TCP/Pv4 settings on the other connection and it shows the IP of 192.168.137.1, subnet 255.255.255.0 but doesn't show a gateway and whenver I try to enter one it doesn't stay there. It goes away everytime I go back into settings. It still says "no internet access".

September 7, 2012 3:52:09 PM

OK I have gotten somewhere. I changed the gateway to 192.168.137.0 and it now shows that I have internet access to the router. I was able to login to my router from my ipad, but it won't allow me to access the internet with the ipad or PS3 using wireless.


I noticed now that in the TCP/IPv4 properties that it won't let me click "obtain DNS automatically". It is looking for specific numbers and when I tried to access using the PS3 it gave me an error saying something about a DNS error. What should I put in for those two numbers? Do you think that is the problem?
September 8, 2012 4:09:45 AM

You shouldn't be messing w/ the TCP/IP settings at all. ICS is supposed to setup automatically. If it’s not, then something else is wrong. In fact, you're more likely to make things worse (e.g., 192.168.137.0 is NOT a valid IP address, for anything, that's a special broadcast address).

Are you using any third party firewalls, like McAfee, Norton? If so, disable them for now.
September 8, 2012 4:44:34 AM

just using ESET security. will disable, set everything back to normal and report back
September 9, 2012 1:01:37 AM

OK. You are right on your assumption. My firewall is the culprit. When I disable it, the wireless network works!!

Now, how do I fix it? :) 

I use ESET Smart Security. I tried looking through the settings, but can't figure out where to change/add what I need to in order for it to allow my network.

BTW, thank you so much for the help so far. It really is greatly appreciated, from both my wife and I.
September 9, 2012 4:01:37 AM

There are a lot of third party security suites out there, and unfortunately, it's hard for me to provide advice since they're all different and have their own idiosyncrasies. I assume by default it's blocking access to the new ethernet connection. It might have something similar to the Windows firewall where it defines "public" vs. "private" networks, w/ the former consider more of a threat and therefore more likely to block access inbound.
!