Sign in with
Sign up | Sign in
Your question
Solved

Forwarding done, but port binding not happening...

Last response: in Networking
Share
August 30, 2012 2:53:58 AM

On my old server which I've run Minecraft on for two years now, I've finally shut that down, and am now starting three FPS servers (or trying to) - CoD4, Four Delta One MW2, and Urban Terror... CoD4 is meant to be running though 28960, MW2 through 28961, and UrT through 27960... Although the Four Delta One server seems to be binding to ports and connecting properly, the other two don't. I've tried running the CoD4 server through 28961 as well, but it doesn't seem to show through there either, even though MW2 does. The error is
'WARNING: UDP_OpenSocket: bind: WSAEADDRNOTAVAIL'
on both servers.... The ports are definitely forwarded... Any ideas as to why that is?

If you want to see the shortcut configs, here...
CoD4:
"C:\Program Files (x86)\Activision\Call of Duty 4 - Modern Warfare\iw3mp.exe" +set dedicated 2 +set net_port 28960 +set sv_punkbuster 1 +exec mp-server.cfg +map_rotate +set net_ip 202.126.198.6
Urban Terror:
"C:\Program Files (x86)\UrbanTerror\ioUrTded.exe" +set fs_game q3ut4 +set dedicated 2 +set net_ip 202.126.198.6 +set com_hunkmegs 256 +set sv_maxclients 24 +exec server.cfg
FourDeltaOne:
C:\Users\Administrator\AppData\Local\IW4M\LaunchIW4M.exe +set party_maxplayers 18 +set net_port 28961 +exec server.cfg +map mp_rust +map_rotate -dedicated -console

Yet none of them work... Can't really work out what I've done wrong here.... Thanks for any help.

Best solution

August 30, 2012 3:24:43 AM

Just a guess, but I did notice that the one server that does work is not specifying an IP address, which tells me it's using its *local* IP address (e.g., 192.168.1.100). OTOH, the other servers are, and those appear to be the public IP. But the server is behind the public IP on the local network, so it can't be bound to the public IP, only its local IP, just like FourDeltaOne. So either don’t specify the IP at all, or if it asks for one, use the local IP.
Share
August 30, 2012 4:44:34 AM

eibgrad said:
Just a guess, but I did notice that the one server that does work is not specifying an IP address, which tells me it's using its *local* IP address (e.g., 192.168.1.100). OTOH, the other servers are, and those appear to be the public IP. But the server is behind the public IP on the local network, so it can't be bound to the public IP, only its local IP, just like FourDeltaOne. So either don’t specify the IP at all, or if it asks for one, use the local IP.


Well, the 4D1 server is binding to the external IP, and the other two work fine when they bind to the internal one, but surely they have to be bound to the external IP to be seen externally?
m
0
l
Related resources
August 30, 2012 4:47:37 AM

Best answer selected by FtsArTek.
m
0
l
August 30, 2012 4:49:40 AM

Scratch that, apparently not specifying an IP at all allows it to connect. Thanks!!! You're a legend!
m
0
l
!