Sign in with
Sign up | Sign in
Your question
Closed

Setting up dir615 after DD-wrt has flashed to it.

Last response: in Wireless Networking
Share
August 1, 2012 8:13:28 PM

Flashing was easy with help from eibgrad! Now want set-up router as a repeater with a netgear WPN824NA as a base. The DD-wrt control panel I have never seen before now. Not sure of what changes need to made in the netgear control panel either.
August 1, 2012 9:47:13 PM

Thank You
Score
0
Related resources
August 1, 2012 9:58:06 PM

Yes, that link at dd-wrt is certainly one way. However, I find it often confuses newbs. Many end up stomping the wireless client configuration in their clumsy attempts to configure the wireless AP. I find it much easier (and much more obvious what’s actually happening) if you break it into two steps. Also, there’s a lot of extraneous stuff in there you don’t need, like refs to AP Isolation, DNSMasq, SPI, Advance Routing, holy crap, no wonder ppl routinely mess it up, it should be rewritten imo.

Here’s the “simple” way, fwiw.

First configure the router for "client bridge", and ONLY once that's working, update that same configuration to "repeater bridge".

Assign the router a static IP in the same network as the primary router (and not in use by its DHCP server). So say the primary is 192.168.1.1, perhaps make the repeater 192.168.1.2. Save and reboot. Update the wireless mode to "client bridge". Save and reboot. Update the wireless security to match your primary router (SSID, wireless key, etc.). Save and reboot.

If done correctly, you should be able to support WIRED clients at the repeater.

DO NOT PROCEED FURTHER UNTIL THIS WORKS!

Leaving the client bridges settings alone, change the wireless mode from "client bridge" to "repeater bridge". Save and reboot. At the bottom of the wireless setup add and configure the virtual SSID. Save and reboot. Go to wireless security and you'll see a second section for the new SSID where you can add wireless security. Save and reboot.

At that point you should have support for both WIRED and WIRELESS clients at the repeater.

Simple, right?

NOTE: If you use the same SSID and wireless security for both routers, you'll also have a form of wireless roaming. Wireless clients will automatically select the AP w/ the strongest signal. Not a big advantage for fixed devices, but perhaps useful for portables.

Trust me, it’s MUCH easier and less prone to errors if you take it in STEPS!
Score
0
August 2, 2012 6:50:42 PM

Still have problems:
First it ask for name and password no problem I assign it.
Second go to Wireless then to Basis setup:
Set Wireless mode to-- Client
Wireless Network Mode to-- Mixed
Channel width to-- Full
Put my Network name in
Save and Apply
Third go to Setup then to Basic Setup then to WAN setup:
Connection Type to-- Static IP
WAN IP address 192.168.1.2
Subnet mask 255.255.255.0
Gateway 192.168.1.1
Then Save then Apply.
I go to Status then to Wireless scroll to bottom hit site survey then join my network successfully, but no internet. Is it to soon?
Score
0
August 2, 2012 10:17:23 PM

The wireless mode should be "client bridge", not "client". Once that's changed, there won't be any WAN to configure anymore since it's only "client" that needs a WAN.

Reset and start over!
Score
0
August 2, 2012 11:11:25 PM

Ok I reset started completely over made the change, was able to join my network, still no internet. I am missing a step or over stepping. I will check my steps and get back to you.
Score
0
August 3, 2012 2:16:47 AM

Ok I took 4 screen shots maybe you can see something wrong.
I very sorry for the trouble and Thank You Very Much for you help.





Score
0
August 3, 2012 2:20:35 AM

If different shots are need no problem.
Is there some setting in my base router I need to change?
Score
0

Best solution

August 3, 2012 1:03:44 PM

As often happens, seeing it provides clues. The biggest clues for me were the wireless mode being “Client Bridge (Routed)” (it should just say “Client Bridge”), followed by Default GW Mode (which I’ve never seen before). So I did a little research on these and found the following:

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=143215

Seems other ppl are also having problems w/ client bridge and this specific router (DIR-615, v E3). Of course, that will lead to problems w/ “repeater bridge” too.

See why I say you need to approach this in steps! Or why a small detail like the E3 release (not even mentioned in this thread until now) can make all the difference.

This sometimes happens w/ dd-wrt. Regressions or just some sort of change from release to release causes things to stop working. And frankly, since we (as users) don't control the code, we rarely find out why. We're just left to find other releases that do work.

Fortunately, bridging is so basic (it’s even available in the micro builds), that any release that works should be sufficient.
Share
August 3, 2012 4:17:22 PM

Ok so I have a bad build, how do I get " build 14896", I did a search at dd-wrt for it.
Score
0
August 3, 2012 4:31:28 PM

Go to the dd-wrt database, enter DIR-615, and in the dropdown box, select the 14896 build.

http://www.dd-wrt.com/site/support/router-database

NOTE: You probably only need the webflash image, not the special image, since you're already past the factory firmware.
Score
0
August 3, 2012 4:54:24 PM

After reading further reading on that thread you directed me to, maybe build 14256 is the one I need.
Which do you think? Please
Score
0
August 3, 2012 5:00:29 PM

I assume you mean 14265 (not 14256). Sure, does seem to have solved the DHCP problem specifically according the more recent posts. You'll find out soon enough.
Score
0
August 3, 2012 5:01:43 PM

ok thanks, we'll see.
Score
0
August 3, 2012 5:38:32 PM

I downloaded the webflash image, opened it in my hex editor, it does not have the script at the end like the other. I do have to edit this one?



I can add the code :091105-01
by replacing a bunch of dots :.......................
That is all that is at the end of the program.
I am not sure to add or not.
Score
0
August 3, 2012 6:58:54 PM

You don't need to alter it. That procedure is only when moving from the stock firmware to the initial dd-wrt image. You already have a dd-wrt installed. Just update dd-wrt w/ the webimage.
Score
0
August 3, 2012 11:29:58 PM

eibgrad Thank you once again for your patience,I know I bugged a lot!! But, I did finally get it. I did try the 14265 build first, would get so far and before finishing set-up would loose connection to the router ( bottom of screen in the taskbar would get the little yellow flag on my network connection icon.) And several attempts
gave up and move the 14896 build, even it took few attempts same problem, at this time not sure what I differently. But I did get it. I will tinker a bit more I don't believe I got it 100% yet. I did watch you tube videos and many different webpages all help some but none really it dead on for me. Again many thanks.
And if there is any website or webpage you can direct me to that would be helpful, another link so something your friend froggy!! :na: 
Score
0
August 3, 2012 11:33:01 PM

Best answer selected by frogman.
Score
0
August 4, 2012 12:30:22 AM

The only other thing I would have suggested is youtube had you not mentioned it already. The best chipset for bridging has always been Broadcom, but the DIR-615 uses Atheros. Atheros and Ralink chipsets can be troublesome at times. Seems to vary by router make & model (perhaps version, as in this case).

Score
0
August 4, 2012 2:03:27 AM

This topic has been closed by Area51reopened
Score
0
!