Sign in with
Sign up | Sign in
Your question

ASUS PCE-N13 Wireless Adapter Not Reading

Tags:
  • Asus
  • Wireless Adapter
  • Wireless Networking
Last response: in Wireless Networking
Share
August 4, 2012 9:17:45 PM

I have recently purchased an ASUS PCE-N13 wireless adapter, and I cannot get it to work for the life of me! I have tried installing the driver from the disk, however, when I try and look it up under device manager, I go to the "Other Devices" section as instructed and it just says "Unknown Device" instead of what it is supposed to say according to the manual. I have tried installing the Ralink driver, however I don't know if that was done correctly or not. I have gone through my BIOS and enabled the PCI slots power, so it isn't that. I am completely stumped! Thanks for any help, specs below.


ASRock Z68 Extreme3 Gen3
Intel i7-3770k
Nvidia GeForce GTX 670
16GB GSkill 1600 Memory
120GB Corsair SSD
2TB 7200RPM WD HDD
Windows 7 Home Premium

Thanks again!!!

More about : asus pce n13 wireless adapter reading

August 9, 2012 3:15:41 AM

Start from the start.
uninstall any applications you have installed with that asus pce n13 . then go in device manager check under network if it shows uninstall it .
Shutdown.
Then remove the hardware from the pci-e slot.
Reboot
First install the drivers for the card from the net (site has the latest drivers)
Then shutdown and connect ur card. Start.
the pc should recognize ur card. If not try changing the slot.
m
0
l
!