Sign in with
Sign up | Sign in
Your question

Plextor 16/10/40A DMA!?

Last response: in Storage
Share
August 19, 2002 7:18:28 AM

I have a plextor 16/10/40 IDE cdrw which I love, it's fast and flawless never a coaster. I know you should always have it in DMA mode to make it work properly. I use Nero and the main buffer is always up in the 90's but the CDRW's buffer keeps going from 100% down to like 10% then burnproof kicks in the it refills back to 100%... At the end of the burn it always says buffer underun was avoid like 30 or 40 times!! The cds all still work fine but the drive never used to do this bfor. I thought maybe I didn't have DMA enabled so I went to the IDE controller under the device manager (WinXP Pro) and on my 2 HDDs on the Pri IDE it's UDMA 5 and 4 with the DMA If Available selected, but on my Sec IDE it's also set as DMA If Available but the current trans. mode is set to PIO Mode. Could this be the problem? If so how can I force it to use DMA? My computer is plently fast enough, so that's not the problem... I used this burner on a P3 500 w/o this problem (both buffers always in the 90's) and now i'm on a p4 1.7 w/ a WD 7200 120GB hdd!! Please help, even though my cds turn out ok I want to fix this problem!!

More about : plextor 40a dma

August 19, 2002 10:24:00 AM

I would say you are on track but since I hate xp I can only tell you how to enable DMA on a 98 or me machine. Control Panel, system, device manager,cd rom, (the cd in question), settings, dma check box.

Can't you set xp up to look exactly like 98?

Give me fuel, give me fire, give me that which I desire.
August 19, 2002 10:32:25 AM

<font color=red>To enable DMA mode using the Device Manager

Open Device Manager.
Double-click IDE ATA/ATAPI Controllers to display the list of controllers and channels.
Right-click the icon for the channel to which the device is connected, select Properties, and then click the Advanced Settings tab.
In the Current Transfer Mode drop-down box, select DMA if Available if the current setting is "PIO Only."
If the drop-down box already shows "DMA if Available" but the current transfer mode is PIO, then the user must toggle the settings. That is:
Change the selection from "DMA if available" to PIO only, and click OK.
Then repeat the steps above to change the selection to DMA if Available.</font color=red>

DMA Mode for ATA/ATAPI Devices in Windows XP
The Microsoft® Windows® XP operating system enables DMA by default on most of the ATA or ATAPI (IDE) devices. To ensure system stability, however, PIO mode will be selected for DMA-capable devices under some circumstances. This article explains the reasons for an ATA or ATAPI device to be in PIO mode on systems running Windows XP.

PIO mode is enabled by default in the following situations:

For ATAPI devices, except DVD and CD-R/RWW drives.
Windows XP enables PIO by default on ATAPI tape drives, CD-ROM drives, and ATAPI removable drives such as magneto-optical (MO) drives. The user can, however, enable DMA on an ATAPI device through Device Manager, as described at the end of this article.
Windows XP enables DMA by default on ATAPI DVD and CD-RW/CD-R drives.
For ATA or ATAPI devices that do not work properly in DMA mode.
Compatibility testing at Microsoft has shown that enabling DMA on certain drives could cause data corruption or reduced system stability. There is no way for the user to enable DMA on these devices.
For certain IDE chipsets that cause data corruption.
For ATA or ATAPI devices using chipsets that are known to cause problems running in the DMA mode, Windows will enable PIO by default.
System manufacturers can override this default behavior by implementing the _GTM and _STM methods in the ACPI BIOS. Also, the user can enable DMA using the Device Manager.
For repeated DMA errors.
Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.
In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.
Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).
If the mini-IDE driver for the device does not support stepping down transfer modes, or if the device is running UDMA mode 0, Windows XP will step down to PIO mode after encountering six or more CRC errors. In this case, a system reboot should restore the original DMA mode settings.
All CRC and timeout errors are logged in the system event log. These types of errors could be caused by improper mounting or improper cabling (for example, 40-pin instead of 80-pin cable). Or such errors could indicate imminent hardware failure, for example, in a hard drive or chipset.






Give me fuel, give me fire, give me that which I desire.
Related resources
Can't find your answer ? Ask !
August 19, 2002 11:10:38 AM

Still didn't work... PIO Mode... Anyway the writer being in PIO mode is just an idea of what the problem might be... I don't care if it's in PIO mode so long as it stops have buffer underruns!

Peter
August 20, 2002 2:53:29 AM

Let's see...

I have the 161040 plex too. I think it comez with DMA mode1 capable. Which is 16meg/sec.

There a little jumper on the back of the drive, on the far left if you are looking at the ide pinz.

Close that jumper. It enables DMA mode2 (33meg/sec), but doesn't work with every computer. Which means, they had one setup it didn't work with that Dell was shipping, and they didn't want to provide tech support for all those Dell people, so they nixxed it.

It's been working wonderfully for me this past year or so. That's on a asusav7133a. Only Gawd knows how many disks I've burned with that thing, too. Probably upwards of 700, not including cdrw's...

C@lling it like I c it...
!