Issues with AHCI after Win 7 Pro 64 installation on SSD....

Having some trouble after migrating to an SSD - after installing Windows 7 Pro 64, I get stuck at "Loading operating system....", just sits there; once it hit "Loading" and then promptly re-booted (hard reboot) but this stopped when I ran System Repair from the DVD; it left me with the old problem, though. Most importantly, if I leave it in AHCI mode it hangs,but if I switch to IDE mode it boots just fine - but then I don't think I'll get TRIM support, and the drive is 20-30% slower.

The MB posts without errors, and it's got the latest BIOS updated a week ago. It doesn't happen the first time I reboot after installing, but rather the second or third, after I've installed a virus program (AVG Free) and then moved the C:\User and C:\ProgramData directories to the HDD using the Symbolic link method. Windows Update is grinding away, applying 111 (!) fixes.... I have no knowledge of what's in all those updates; there's at least 4 cumulative packages along with SP1 in there, so there's probably tens of thousands of things going on. Problem is, I can't really do without applying these basic things - my \User diectory is around 500GB, and I don't have the chops to go without applying Windows updates.

I switched to AHCI mode before installing the OS, and each time I've deleted the old partitions on the SSD so it's a fresh format/install from the Microsoft OEM DVD. I haven't done anything special while installing, as I understand it the windows installer is supposed to recognize AHCI mode and install the appropriate drivers at install time when it's enabled in BIOS. When I check in the registry, TRIM is on, suggesting that it initially installed them correctly. When I check during the initial boot, device manager shows the AHCI drivers present. BCDEDIT shows appropriate boot manager and boot loader settings. I've tried re-installing from scratch a couple times, both with the old HDD installed (as drive D:) and without; no difference.

My hardware:
Gigabyte GA-H55M-UD2H (rev. 1.0) (socket 1156)
Intel i5 650 2-core
OCZ DDR-3 RAM, 1333 rated running at 1066 dual channel; 12 GB (4+4 and 2+2)
Mushkin 120GB Chronos Deluxe MX SSD on SATA-II, master on channel 0
WD Green 1.5 TB HDD, master on channel 1
Decent-quality 550W PS (CoolerMaster IIRC).
Pioneer DVD-RW drive master on EIDE bus, channel 4

So, any thoughts? I must be missing something, or there's something being installed with the Windows updates, or I'm doing it by moving my /User directory - but what? Moving the directory back doesn't help. Any insight would be appreciated.....
1 answer Last reply
More about issues ahci installation
  1. I would do a secure erase on the SSD, disconnect all HDDs, and then do a clean install of Windows 7 with AHCI sata mode enabled just before doing the install. Then run the motherboard drivers and Intel chipset driver.

    I would download the SP1 package from MS: http://download.microsoft.com/download/0/A/F/0AFB5316-3062-494A-AB78-7FB0D4461357/windows6.1-KB976932-X64.exe

    Then do all the other updates.

    Consider giving MS Security Essentials a try, it too is free and a very good anti-virus program.
Ask a new question

Read More

Configuration SSD Windows 7