Sign in with
Sign up | Sign in
Your question
Solved

Problem with File Sharing

Last response: in Networking
Share
September 14, 2012 7:06:31 PM

Hello all,

I've been having some issues with file sharing. I run backups with Syncback of all the machines on the network for one of our customers (they have around 18-19 machines sharing the network). It's a P2P network managed by a server. Most of the machines run XP Pro, but there are several Win 7 Pro and a few Win 7 Home Premium :sarcastic:  and one Win 7 Home Basic :fou:  So as you can tell it can make it difficult to manage them all how we would like. The backups are managed by the server and routed to an external HDD. They run daily.

Now, the problem I've been having with failed backups comes from a couple of things...network and scan failures, which usually means that the folders being backed up can't be found, access is denied, or improper credentials. Some of this has been intermittent, so a backup that has succeeded will suddenly fail. One machine suddenly failed despite the folder(s) being shared with full permissions for everyone due to accessibility problems...Here's the error reported by Syncback:

"Failed to prepare source: Directory \\machine\folder\ does not exist and cannot be created"

And the error from the machine the folder is from:

'Failed to prepare source: Directory \\shipping\Documents and Settings\ does not exist and cannot be created"

These directories are shared with full permissions. I turned off simple file sharing in XP to get to the advanced features and modified the security settings to give everyone permission to access and modify the folders. It had worked before, but when I re checked them yesterday, it was throwing those errors.

There were a couple of other problems for a few Win. 7 machines as well, all had to do with accessibility...

"Lab3-PC\lab3\ Usernmame cannot be found"

and for 3 other machines network failure and access denied. One is a Win 7 basic machine.

For those I cannot access the shared folders, again, the simple file sharing is disabled and everyone has access. I can see them from the server, but can't access them. I am the network admin. Nothing has changed on the source directory...the machine and user credentials for login haven't been changed.

For the record, I am using RDP to manage the remote machines from the server, and this works fine for the rest of the machines.

Any suggestions as to why this is happening? On one of the Win 7 Pro machines we have done everything to make it as accessible as possible, turned off Windows firewall, turned off the firewall for the AV software. I am thinking of doing the same for the other two having this problem as well and see f that helps.

Thanks for the help!

More about : problem file sharing

Best solution

September 14, 2012 7:59:12 PM

You (or your customer) may not want to hear this but that P2P network really needs to be a domain. It would eliminate a whole host of problems. If this does happen just don't make the mistake of only setting up one domain controller. Use no less than 2 at all times.
Share
September 21, 2012 12:31:32 AM

Thanks for the response. We are trying to get them in that direction. Hopefully that will happen here pretty soon because you are right that would make those issues disappear, as we don't have the other problems with our other domain customers. We do have one DC, and that's all we really need for this type of network.

To update, this problem is intermittent. It happens sometimes, but other times it doesn't. Not sure what the problem is with that. Other times it's because logins or machines get renamed, get turned off, or have other problems associated with windows specific problems like file sharing or permissions, but for the most part it works just fine as a P2P for now.

It would be nice if all the machines ran the same OS, but this customer likes to manage their own IT sometimes.

Thanks!
m
0
l
September 21, 2012 12:31:42 AM

Best answer selected by sirstinky.
m
0
l
!