Sign in with
Sign up | Sign in
Your question

RealTek RTL8168/811D Configuration

Last response: in Networking
Share
September 19, 2012 9:32:42 PM

Speed tests have shown that it's at least 1.5Mbps down and 1.5 or so up, as well, but I can't reach over 120kB/s.

The router is a WNDR3800SW (SureWest)...

Now, my thing is maybe my settings on my network adapter are not optimized? Have used TCP/IP Optimizer for registry settings.

So here is the manual IPv4 Configuration I have set:
IP: 192.168.1.2 (first IP possible)
Subnet: 255.255.255.0
Gateway: 192.168.1.1
Preferred DNS: 192.168.1.1
Alternate DNS: 64.126.4.212

Connection uses following items:
[x] Client for MS Networks
[ ] VirtualBox Bridged Networking Driver
[x] QoS Scheduler
[x] File/Printer Sharing for MSNet
[x] Reliable Multicast Protocol
[x] IPv6 (I was using 6to4 Tunnel, but turned this off so pretty sure this can be disabled)
[x] IPv4
[x] Link-Layer Top. Disc. Mapper & Responder

Configuration of Adapter:
* Power Management: Do not allow the computer to turn this off.
* Advanced:
** Auto Disable Gigabit: Disabled
** Flow Control: Rx & Tx Enabled (R/T En)
** Green Ethernet: Enabled
** Interrupt Moderation: Enabled
** IPv4 Checksum Offload: R/T En
** Jumbo Frame: Disabled
** Large Send Offload(LSO) v2 (IPv4): Enabled
** LSOv2 (IPv6): Enabled
** Network Address: Not Present
** Priority & VLAN: Both Enabled
** Rcv Buffers: 512 (Highest)
** Rcv Side Scaling: Enabled
** Shutdown Wake-On-Lan: Enabled
** Speed & Duplex: Auto Negotiate
** TCP Checksum Offload (TCO) IP4: R/T En
** TCO IP6: R/T En
** Transmit Buffers: 128 (Highest)
** UDP Checksum Offload (UCO) IP4: R/T En
** UCO: R/T En
** Wake on Magic: Enabled
** Wake on Pattern Match: Enabled
** WOL & Shutdown Link Speed: 10 Mbps First

Man, that was a lot of typing, haha. So, I have messed with these a little bit and I assumed that Checksum offloading slows connections? But it was getting to the point where, I didn't know what was doing what after the driver upgrade. So, I went back to one I had on my back up drive and left them defaulted...

I would like all the WOL / Waking disabled... I'm really just seeing if someone who knows a bit more about this stuff can point me to what looks like it could be wrong... or why I may be capped?
September 19, 2012 10:28:04 PM

turn off IP6
m
0
l
September 19, 2012 10:40:29 PM

Emerald said:
turn off IP6


I have read before that this is a mythical recommendation that's been floating on the Internet and that by disabling IPv6 you're not actually going to get performance gains. I mean Microsoft can't be trusted always, but I think I read it there and believe they said something like: "disabling IPv6 just disables features that are not present with just IPv4"
m
0
l
!