Sign in with
Sign up | Sign in
Your question

Problem with 5.1 speakers and Windows 8

Last response: in Windows 8
Share
February 17, 2013 11:29:02 AM

Heya all,

I can't seem to get my 5.1 speakers (Logitech x506) to play in full 5.1 mode under windows 8 - I go through the control panel to get to my sound settings, where I can run a test and they all work fine, but when I try to play music via Media-player (or VLC), or in any games, they only work in 2.1 "stereo" mode (2 'front' L/R speakers and the amp/woofer)...

My soundcard is an 'onboard' device by Realtek, and worked perfectly fine in full 5.1 with these speakers under my old WinXP install.

Thanks in advance for your time,

~JD
March 2, 2013 12:59:41 AM

JD-
Did you solve this problem yet? I have the same issue (including the logitech speakers) when I install Win 8.
-Rick
m
0
l
March 4, 2013 1:05:37 AM

@Rickroberts22:

Not yet unfortunately... Although I have noticed something odd - Full 5.1 *does* work on (some) games! I'm still only just starting to re-install my games collection, so I am unsure if this was a lucky fluke or if I will get full 5.1 in all games... If the latter is the case, it clearly comes down to being an issue with Media Player itself (and VLC)... *shrugs*

~JD
m
0
l
Related resources
March 21, 2013 4:51:56 AM

Realtek has some speaker fill option to do that
m
0
l
September 3, 2013 6:24:31 PM

Instuctions for configuring 5.1 in windows 7.
I hope some of it is applicable to windows 8.

Logitec 5.1 surround systems have satalite speakers that connect to the powered subwoofer via RCA connectors.

In the dialouge under Sound>Playback> click configure.

Choose your configuration:

choose5.1 Surround.
dont worry about testing right now. click next.

Custimize your configuation:

check the first 3 boxes. click next.
(rear speaker box is greyed out. that is for 7.1 sound).

Select full-range speakers:

This dialouges wording is where normally smart or even basic tech savy people trip up as i did for a while.
basically all you need to know is that for the purposes of setting up 5.1 surround you do not have full range speakers because sound is purposely bronken up into 5 different speakers, that surround you.
uncheck the 2 boxes.
after which surround speaker check box will be greyed out. which is flabbergasting because dont i want that box to be checked? the awnser is no you dont. leave both boxes empty and click next.

Configuration Complete:

click finish.

now when you go back and test your speakers using the test button that plays through all of them one at a time, you should hear sound out of all of them, but it will be slightly louder out of the one that is flashing.

in VLC or media player or your game be sure to set the application to 5.1 surround sound.

im no tech god, this may not work for everyone but i hope it helps some. cheers. eyeden.


m
1
l
October 18, 2013 9:34:23 PM

eyeden said:
Instuctions for configuring 5.1 in windows 7.
I hope some of it is applicable to windows 8.

Logitec 5.1 surround systems have satalite speakers that connect to the powered subwoofer via RCA connectors.

In the dialouge under Sound>Playback> click configure.

Choose your configuration:

choose5.1 Surround.
dont worry about testing right now. click next.

Custimize your configuation:

check the first 3 boxes. click next.
(rear speaker box is greyed out. that is for 7.1 sound).

Select full-range speakers:

This dialouges wording is where normally smart or even basic tech savy people trip up as i did for a while.
basically all you need to know is that for the purposes of setting up 5.1 surround you do not have full range speakers because sound is purposely bronken up into 5 different speakers, that surround you.
uncheck the 2 boxes.
after which surround speaker check box will be greyed out. which is flabbergasting because dont i want that box to be checked? the awnser is no you dont. leave both boxes empty and click next.

Configuration Complete:

click finish.

now when you go back and test your speakers using the test button that plays through all of them one at a time, you should hear sound out of all of them, but it will be slightly louder out of the one that is flashing.

in VLC or media player or your game be sure to set the application to 5.1 surround sound.

im no tech god, this may not work for everyone but i hope it helps some. cheers. eyeden.




the problem solved when I made windows update !
m
0
l
!