Sign in with
Sign up | Sign in
Your question
Solved

Please help me get a Triple Router Y-configuration working!

Last response: in Networking
Share
September 28, 2012 8:14:15 AM

I am seriously reduced to tears trying to get this set up... I'm starting a Work From Home customer service job next week that requires I have a wired internet connection separate from the wireless one in my home. In response to another post where I asked for help, 'ebigrad' suggested the easiest way for me to accomplish this was to use three routers, with one being the primary and the other two connected to it via LAN to WAN. He didn't offer details (& now seems to MIA), but I read the sticky 'axxeon' wrote on setting up a Y-configuration and it all seemed simple enough, so I thought I could do this. I guess I'm in over my head because I've spent the last week reading/researching everything I could to understand what I'm doing wrong and I'm still just completely lost!! :o 

I wish I could pay someone to come and do this for me, but I've been unemployed for the last two years and I literally spent my last few bucks buying the equipment.... soooo... I'm hoping someone here will be kind enough to work with me before I jump off the bridge ??

Here's the hardware I have:

Motorola Surfboard SB1641 Cable modem
(Master Router): TP-Link TL-R470T+
(Router 2): TP-Link TL-R470+
(Router 3): Linksys E2500 wireless N router

I'm using Win 7 on one computer; the others are all XP Pro. I believe I have a Dynamic IP through my ISP; they did not give my any kind of setup info, I just provided them with the MAC address of the modem.


I'm pretty sure I have the connections set up correctly:

Both Routers 2 & 3 are connected via their WAN ports to LAN ports in the Master Router.
Eventually 3 computers will be hardwired to Router 2; Router 3's wireless network will have 2 computers & a Blu-Ray box accessing it. For now though, I have temporarily connected a computer to a LAN port of each router to make it easier to access for setup.

I do have a working internet connection through the Master router and can access the TP-Link router using IP address 192.168.0.1. I can also access Router 2 (via the computer connected to it) using the same 192.168.0.1 address. I haven't tried to access Router 3 yet... I'm stuck trying to get Router 2 working & hoping if I can get that figured out the other will be easier.

According to axxeon's sticky (http://www.tomshardware.com/forum/41797-42-need-separat...), I need to assign a static IP address to both Slave Routers, but this is where I've gotten lost... I don't know where to go in the setup configuration of the router to do that. After all I've read, I only have a vague understanding of IP address separation and I don't know if I should be changing the LAN IP or the WAN IP or what?

I tried creating two static IPs on the Master router through the Advanced/Routing menu... there it asks for Destination; Subnet Mask; Next Hop.... I entered 192.168.1.0; 255.255.255.0 and I'm not sure what to put under Next Hop... it insisted I put something... I tried 192.168.1.2.

Then I went to Router 2 in the Network/LAN menu and set the IP... regardless of what address I enter here, I get locked out of the router... I can't access it by using the new IP (or the original one) and I have to reset the router.

I can build my own computer and I've been pretty good at troubleshooting over the years, but It's obvious I have no idea what I'm doing when it comes to networking, and I'm getting nowhere by playing around. With this job starting so soon, I'm beginning to panic... at this point I really just need someone to say 'First go here enter this number, then go there and enter that, etc.'... can anyone help me??? PLEASE????

~Diane

PS. I noticed that on the Master Router under the Network/LAN/DHCP Client menu, it shows two Hosts... one is the name of the computer ( with IP 192.168.0.3) that is connected to the Master Router, and the other is Cisco15708 (IP 192.168.0.2) which I assume is the Wireless Router that is also connected to the Master Router... but the TP-Link (which is also connected) does not show up... even when it is at it's default settings. Why would the Master see one router but not the other? Makes me wonder if I should have bought all Cisco routers... maybe they are easier to set up? :::sigh:::
September 28, 2012 8:51:20 AM

The WAN port on your master router will have an IP address assigned by the ISP, you should not change that at all
You then have the 2 LAN ports connecting to 2 other routers. By the sounds of it you have 192.168.0.2 and 192.168.0.3. That is 1 network. Now, each router has it's own LAN, which will need it's own IP addressing scheme. The simplest way to do this is to increment the 3rd number, for example you should have...
192.168.2.1
192.168.3.1
I would make your IP addresses match your router numbers, just to make everything consistant. Below I've written out a quick diagram of what you are looking for. As I am not familiar with the management screens for those, I can't tell you exactly what to do, but essentially, if you use the IP addressing I have entered there, you shouldn't have any problems. One thing I did forget to do was give you the next hop addresses.

R2 + R3 port next hop / default gateway = 192.168.0.1
R2 LAN default gateway for DHCP = 192.168.2.1
R3 LAN default gateway for DHCP = 192.168.3.1
All subnet masks must be 255.255.255.0, apart from the ISP connection.

I hope this helps, let me know your findings.

Luke





m
0
l
September 29, 2012 6:43:46 AM

Thank you so much Luke!! I hope you're still with me... I started working on this earlier and then we lost power (arrgh!!), so I'm just getting back to entering everything in now.

I tried following your instructions & drawing... which again, looks easy enough. Questions I have:

Do I need to turn off DHCP in the Master Router? In the DHCP Client list it is only showing the computer (Main) that is attached to the router with the IP of 192.168.0.2. So how can I set Router 2 to that IP if it has assigned it to my computer? This list does not show the two Slave routers as part of the Master network, even though they are attached... shouldn't I see them also? At one point I did see the Cisco router in this list as 192.168.0.3 (mentioned in my OP); but it has not shown up again.

Where do I set up each routers IP address? Do I create a static IP in the Master Router or in each slave router (or both)? When I tried entering a Destination IP in the Master (using the TPLink Advanced/Static Route menu), it does not accept 192.168.2.1, but changes it to 192.168.2.0.

How do I change the WAN IP for R2? If I change the default (in the TPLink Network/WAN menu) from Dynamic IP to Static IP, entering IP 192.168.0.2; Subnet 255.255.255.0; D.Gateway 192.168.0.1 it tells me that "the subnet of WAN1 conflicts with the others". I thought the subnet should always stay 255.255.255.0? I tried to set a 'rule' under the Advanced/Static Route menu in R2; changing the interface to WAN... but then I get an error that says "Destination Network conflicts with the subnet of the Interface".

I'm beginning to question my sanity here... evidently my logic is failing me and I must not be putting the addresses in the right place, because I just can't seem to get things to work. I know it's hard for you to help when you can't see the management screens, so I'm going to attach some screen shots of the menus that I think are relevant... maybe then you can better spell things out for me.

I've reset the TPLink routers to their defaults so I'm starting with a clean slate... I haven't tried the settings on the Cisco router (3) yet, but I've included those menu's here too.

TPLink Network WAN: http://x.co/oMdx
TPLink Network LAN: http://x.co/oMe6
TPLink Network-LAN-DHCP Client: http://x.co/oMfi
TPLink Network-LAN-DHCP Reservation: http://x.co/oMeD
TPLink Network-LAN-DHCP: http://x.co/oMeK
TPLink Advanced-Routing-Static Route: http://x.co/oMeS

Cisco Basic Setup Auto DHCP Config: http://x.co/oMeX
Cisco Advanced Routing: http://x.co/oMec
Cisco Basic Setup Static IP: http://x.co/oMek

Thanks in advance for your help and patience with me!!

~Diane



lukeconft said:
The WAN port on your master router will have an IP address assigned by the ISP, you should not change that at all
You then have the 2 LAN ports connecting to 2 other routers. By the sounds of it you have 192.168.0.2 and 192.168.0.3. That is 1 network. Now, each router has it's own LAN, which will need it's own IP addressing scheme. The simplest way to do this is to increment the 3rd number, for example you should have...
192.168.2.1
192.168.3.1
I would make your IP addresses match your router numbers, just to make everything consistant. Below I've written out a quick diagram of what you are looking for. As I am not familiar with the management screens for those, I can't tell you exactly what to do, but essentially, if you use the IP addressing I have entered there, you shouldn't have any problems. One thing I did forget to do was give you the next hop addresses.

R2 + R3 port next hop / default gateway = 192.168.0.1
R2 LAN default gateway for DHCP = 192.168.2.1
R3 LAN default gateway for DHCP = 192.168.3.1
All subnet masks must be 255.255.255.0, apart from the ISP connection.

I hope this helps, let me know your findings.

Luke

http://i49.tinypic.com/2wgc1eh.png

m
0
l
Related resources

Best solution

September 29, 2012 1:18:28 PM

I would go for static configuration on all the routers in this case.
If the address is occupied by your machine then maybe try configuring them with 192.168.20.0 and 192.168.30.0. With Subnet addresses, it doesn't always have to be 255.255.255.0, but for what you require, it makes little difference.

Do the following steps

1. R1 > WAN
connection type 'dynamic IP'
Hostname : R1
(it appears the configuration you already have is fine there, I assume the computer connected directly to it is having no problem connecting to the internet?)

2. R1 > LAN
IP address 192.168.0.1 / subnet 255.255.255.0
Your configuration is already correct here to

3. R1 > LAN > DHCP
Disable
Save

Static Routes should not be required at this point, as the router by default will forward traffic that it doesn't know the location to, straight out of your WAN interface.

4. R2 > WAN
connection type ' Static'
IP address : 192.168.0.20
Subnet : 255.255.255.0
Default Gateway : 192.168.0.1
Primary DNS : 192.168.0.1
Secondary DNS : 4.2.2.2
Hostname : R2
Save

5. R2 > LAN
IP address : 192.168.20.1
subnet : 255.255.255.0
Save

6. R2 > LAN > DHCP
Enable
Start IP address range : 192.168.20.10
End IP address range : 192.168.20.254
Lease Time : 1024
Default Gateway : 192.168.20.1
Primary DNS : 192.168.20.1
Secondary DNS : 192.168.0.1
Save

7. R3 > Basic Setup > Internet Setup
Hostname R3
Static IP Configuration
IP add : 192.168.0.30
subnet : 255.255.255.0
Default Gateway : 192.168.0.1
Primary DNS : 192.168.0.1
Secondary DNS : 4.2.2.2

8. R3 > Basic Setup > Network Setup
IP address : 192.168.30.1
subnet : 255.255.255.0
Router Name : R3
DHCP Server : Enabled
Start IP address : 192.168.30.10
Default Gateway : 192.168.30.1
Primary DNS : 192.168.30.1
Secondary DNS : 192.168.0.1
Number of users : 50 (as many as you like really, up to 244, this will limit the number of IP addresses it will lease out)

I've left IP addresses 192.168.x.2 - 9 empty and will not be assigned to anyone on DHCP. If you have a device, like a NAS box that you want to connect, you will want a static IP address, so you will just assign it an IP in the appropriate range.

The above configurations should get everything working for you. I will explain it a little bit so you can hopefully understand what and why we've done it.
At the moment, you will not have access between subnets. so devices connected to R2, will not be able to connect to devices connected to R3. If you do need this, let me know and I will walk you through it. Everything should be able to connect to the internet though!

R1 has a dynamic WAN address assigned by the ISP. This is mandatory.
It's LAN address is the Default Gateway for the 192.168.0.X network. Anything with an IP address that needs to send data that isn't local to it, (i.e doesn't have an address 192.168.0.X) is sent to the Default gateway, which then automatically forwards it through the WAN interface).

R2, has a static IP address on it's WAN interface, as we have configured R1 to not give out automatic IP addresses. The WAN interface on R2 has to be in the same subnet range as the LAN address of R1, so that it can forward traffic in the same way as R1. So, anything that is being sent with an IP address that doesn't look like this 192.168.20.X, is sent to R1 as the default gateway, at which point, R1 forwards it to the internet.
The LAN interface has been configured with the IP add 192.168.20.1, and DHCP has been configured to give out IP addresses in that range, with R2's LAN interface as the default gateway. The operation is essentially the same on R3 as well.

Hopefully, that makes a little more sense, that is a very brief description, i recommend looking up some of the Wiki pages on Defualt gateways, and hopefully it will make a little more sense.

Remember to save your configurations and backup them up if there is anyway to!

Luke
Share
September 29, 2012 7:50:32 PM

Hi Luke... thanks for sticking with me on this and taking the time to write all those steps out for me... I no longer feel bridge jumping is an option... lol! Right off the bat I can see where I was doing things wrong... I was making most of the changes in R1 and it looks as though there wasn't much to do there.. :ange: 

However, I've hit an error on Step 4... it doesn't like the subnet (see link below). I tried changing it to 255.255.255.255; then 255.255.255.254; then 255.255.255.252 (just guessing) but that didn't work... same error. After clicking OK to the error message it highlights the IP address (192.168.0.20) if that helps.

I didn't go any further on R2, I assume it's pointless if these steps need to be done in a certain order.

R2 WAN Error: http://x.co/oNKq


Next I tried setting up R3, but I could only get as far as "DHCP Enabled" in the Step 8- it seems it won't allow editing of the third octet of the Start IP address; only the last is editable. I also see no place to add the default gateway (in the Network section) and the fields for the DNS's are greyed out. It also won't allow me to save the settings put in to that point... it doesn't give an error message, it just does nothing. Am I in the right screen for Step 8?

R3 Setup screen: http://x.co/oNLY

To answer a few of your questions... yes, I do currently have internet through the R1 router; and no, I don't need to have access between the subnets... it would be convenient for me, but I think the company is concerned about customer information being accessible to anyone on the wireless network, so I probably should keep R2 (Office) separate & secure from R3 (House).

I appreciate your explaining what and why... I love when anyone does that, because I'm naturally inquisitive and my brain wants to (over) analyze everything... but it freezes up when numbers are involved (especially lots of them) and couple that with unfamiliar terminology and a short timeframe to learn it, well panic just takes over! But I will definitely take a look at those Wiki pages you mentioned, because it will help me in the future when problems arise (and I know they will!).


::::I await patiently for your next instruction, oh wise one:::: ;) 

~Diane
m
0
l
September 30, 2012 9:24:54 PM

Hi Diane,

Sorry it's taken a little while to get back to you. I think the problem on R2 can be resolved by changing the LAN IP addresses before changing the WAN. Basically, the router won't allow both WAN and LAN to be configured with the same IP address range. So, just do the LAN IP address configuration then go back and do the WAN. The points are written in no particular order, so don't worry about that.
I think the problem on R3 can be solved if you save the configuration with the LAN IP address configured. Then refresh the screen, it should automatically update the Start IP Address to have the correct subnet in the 3rd Octet. If that doesn't work, maybe try rebooting the router after the changes have been made and saved. As for the rest of it, the router will provide the DHCP configuration with it's own IP address for DNS and Default Gateway, so you won't need to do that.

Let me know how you get that on with that :) 

Luke
m
0
l
October 1, 2012 12:34:35 AM

Hi Luke!! No problem, you have a life outside of TomsHardware.com I'm sure... lol.. I AM relieved to see you back however... :) 

I've been reading, reading, reading and have tried different things which gave me a couple little victories...

I've removed the routers from everything except the computers they are connected to, disabled Windows firewalls (which didn't seem to matter, but just in case) and made sure the browser history/temp files, etc. were deleted.

On R3 I was able to change/save the Network IP Address by keeping it on Automatic DHCP Configuration. So now it says 192.168.30.100 for the start IP address, but I can't seem to get it to save any other settings. OK, one step out of the way... I'll come back to this.

After reading your last post, I tried setting the LAN IP first and got locked out of the router again... usually when I did that I had to reset the router but this time I decided to go to the cmd window and typed <ipconfig /release> (which set everything to 0's) and then <ipconfig /renew> and it worked! I saw the new IP address and was able to log back into the router.

Next I set the DHCP LAN settings in Step 6 and then the WAN settings in Step 4... all good! WooHoo!!!! I'm feelin' great!! I don't see anywhere to set the Host Name though... but I don't know how important that is?

Checked ipconfig once more and it's showing:
192.168.20.100
255.255.255.0
192.168.20.1

Time reconnect R2 to R1 and see what happens... ::: dancing around the room::: SUCCESS!!!!! :bounce: 

OK, back to R3... I think I figured out why it wouldn't save for me.. in the Router Name I was putting in <R3 House> just to give it a little more of an identity... I found that it didn't like the space and it worked after changing it to <R3House>... would have been nice if an error message would let me know why it wouldn't save instead of doing nothing, but oh well. That's what I get for not following instructions to the letter... lol!. That out of the way, it now accepted the start IP address and the DNS settings in Step 8.

Now to try Step 7 again... changed the setting to Static IP and input all the addresses, clicked Save and YES... pure JOY!!! Time to reconnect to R1... OH YES!!!! I have INTERNET!!!! :pt1cable: 

Now... I still don't know if I have wireless, I have to put in the wireless adapter and fool with that, but OH MY, MY... I'm so excited... I wish I could KISS You!!!! :love:  I can finally sleep tonight knowing I'll be able to function tomorrow... what a RELIEF!! No more tears... no more thoughts of jumping off the bridge... and no more researching all over the internet (I can close all these windows now!).... THANK YOU THANK YOU THANK YOU for taking the time to help me out!!! Luke, YOU are my new HERO... :sol: 

~Diane
:hello: 
m
0
l
October 1, 2012 2:34:05 AM

Luke, just a couple of last questions... if I want to share a device (like my printer) to R1, will that work? I'll need a static ID for it within the reserved range, correct? Would this be a setting in the printer or the router?

You mentioned you could walk me through the steps needed if I need access between the subnets... I don't think I will need this, but if I discover that I do, could you point me to somewhere where I can learn to do that? I'm sure it's not just a few steps and I don't want to tie you up any more than I already have!

Finally, since the address is so different, I'm curious as to what the function is for the secondary DNS 4.2.2.2?

Thanks again... I've really learned a lot through all this!

~Diane

m
0
l
October 1, 2012 4:02:46 AM

Hi Diane,

Glad it all worked in the end! I can see how much you've learnt just from how much you've managed to work out, so well done to you!

The configuration for routing between 2 different subnets. Essentially, you would need to create static route between the devices.
So for R2 your configuration might go like this...
destination - 192.168.30.0
subnet - 255.255.255.0
Next hop - 192.168.0.30
Interface - WAN1
Description - Route-to-Home-Net (anything will do to identify it quickly and easily)

The configuration for R3 would be the opposite.
However, if the company you are working for has had you do this to prevent access to sensitive information, I wouldn't implement this, as anyone connecting to the wireless could gain access to your other network.
If you need to connect to a printer connected to R1, you shouldn't get any problems with the current setup. Like you rightly pointed out, you will need to give it an IP address in the 192.168.0.x range which would need to be done in the printers setup menus.

The 4.2.2.2 address is a public free DNS, so even if you aren't sure of which DNS address you can use, that one should always work. Also, it is a good way to test if your internet is working, as losing access to a DNS server will mean you won't be able to view webpages, which to a lot of people is the same as the internet being down. In your case though, it probably isn't used as everything will be forwarding the DNS requests to R1, which will then forward them to your ISP's DNS servers.

Looks like you've got it all figured out just in time then! Good luck with your work tomorrow! I can't help with that bit :) 

Let me know if you get any more problems

Luke
m
0
l
October 1, 2012 6:13:38 AM

Best answer selected by ShyDi.
m
0
l
!