Sign in with
Sign up | Sign in
Your question

Z77 Chipset: How to Enable & Confirm AHCI? Drives Aren't Hot Swappable

Last response: in Windows 7
Share
May 4, 2012 7:12:52 AM

New i5-8570k with Z77X-D3H build. SSD's & HD's. 1 backup HD is in a caddy (simple SATA connection, its not a raid device) with on/off switch.

BIOS is AHCI by default. Installed Win7 Pro x64 then after chipset drivers with mobo DVD. IRST is installed but notes say it should be installed during o/s install.
How to confirm AHCI is on? The drives aren't listed in safely remove/eject hardware icon in systray. HD Caddy is useless because hot swap isn't working or on.

Does the new Z77 chipset require the drivers to be installed during O/S install? I tried that with files on USB flash drive but Win7 prevented it because the drivers were unsigned. These are Intel's latest drivers for the Series 7 chipsets. I've tried to confirm whether i have AHCI on or not, 'AS SSD benchmark' detects 'iaStor'.

I guess if the chipset drivers must be installed before o/s install then the question becomes "How to install Intel drivers that aren't signed during O/S install". There is no 'ignore & continue' option.
Thanks for the help!
May 4, 2012 7:25:52 AM

benn said:
New i5-8570k with Z77X-D3H build. SSD's & HD's. 1 backup HD is in a caddy (simple SATA connection, its not a raid device) with on/off switch.

BIOS is AHCI by default. Installed Win7 Pro x64 then after chipset drivers with mobo DVD.
How to confirm AHCI is on? The drives aren't listed in safely remove/eject hardware icon in systray. HD Caddy is useless because hot swap isn't working or on.

Does the new Z77 chipset require the drivers to be installed during O/S install? I tried that with files on USB flash drive but Win7 prevented it because the drivers were unsigned. These are Intel's latest drivers for the Series 7 chipsets. I've tried to confirm whether i have AHCI on or not, 'AS SSD benchmark' detects 'iaStor'.

I guess if the chipset drivers must be installed before o/s install then the question becomes "How to install Intel drivers that aren't signed during O/S install". There is no 'ignore & continue' option.
Thanks for the help!



www.intel.com - look under support, drivers, chipsets, chipset software, intel rapid storage technology
shortcut link below

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...

download the language you need and install.

m
0
l
May 4, 2012 7:47:39 AM

weilin said:
www.intel.com - look under support, drivers, chipsets, chipset software, intel rapid storage technology
shortcut link below

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&...

download the language you need and install.


It's already installed, turn on caddy and go into IRST and refresh, drive doesn't appear. Also theres no way to eject the other disks. Seemingly the only way to detect the drive is like the old IDE way, turn on/plug in drives & reboot.


In the notes of IRST - its the same drivers i was trying to intall during O/S install. It says it must be installed during O/S.
Catch 22 because the drivers are unsigned. There is no ignore option. Surely i'm not the only one to come across this??
m
0
l
Related resources
Can't find your answer ? Ask !
a b $ Windows 7
May 4, 2012 8:23:43 AM

i know with asus boards you have to enable hot-swap in the bios per-port

install the latest intel chipset drivers and raid/ahci drivers just in case.
m
0
l
a b $ Windows 7
May 4, 2012 8:33:15 AM

oh and perhaps look at Intel "F6" drivers or similar for AHCI/chipset i use them just forget how i got them, i dont see why you have you do it during install just update after and you can get 3 sets and let windows pick the best/latest etc
m
0
l
May 4, 2012 8:56:05 AM

apache_lives said:
i know with asus boards you have to enable hot-swap in the bios per-port



BINGO! It shows i'm not used to this fancy new BIOS interface.

Now how do i eject the drive?? (the caddy, all the others i've left as non-swappable)

It dosn'tt appear in "safely remove" like a usb key would. The drive is listed in IRST program as an internal drive. But there doesn't seem to be any options/setting for it or any drive for that matter. Just looks like an app to tell you what drives are installed.

Thanks again for the help.
m
0
l
!