Sign in with
Sign up | Sign in
Your question

USB and LAN issues with Windows 7

Tags:
Last response: in Windows 7
Share
February 11, 2010 9:16:20 PM

I have a AsRock K8NF4G-SATA 2 motherboard with 1.44GB of RAM and an AMD Sempron (tm) Processoer 3000+ 1.81 GHz. I have tried to install Windows 7, noting that its spec in terms of RAM, processor and graphics card suggest the 32 bit version of Windows 7 should work fine.

After many attempts, I finally got Windows 7 installed (custom install on to blank hard disk), noting that I had to disable onboard SATA and onboard audio in the BIOS to get it to install since with either of these enable the install failed (not a major problem though I could clearly do with sound at some stage!). However, once installed none of the USB sockets (4 on the back or 2 on the front) on LAN connection work at all. Connecting my LAN cable from my wireless router does not get me on the internet, noting that this does work on my netbook so clearly the problem lies with the desktop LAN connection. (Also note that both the USB and LAN sockets worked fine under XP previously.)

When I enter device manager, there are 3 exclamation marks as follows:

1) Under Universal Serial Bus controllers, the Standard OpenHCD USB Host Controller has an error - "This device cannot start. (Code 10)"

2) Under Network adaptors, the NVIDIA nForce Networking Controller has an error - "This device cannot start. (Code 10)"

3) Under Display adaptors, the NVIDIA GeForce 6100 (Microsoft Corporation-WDDM) has an error - "Windows has stopped thisdevice because it has reported problems. (Code 43)"

Errors 1) and 2) certainly seems to tie in with the problems I am having, not sure whether error 3) is also related?

Any suggestions on how to solve this problem would be gratefully received, as the computer is pretty useless at the moment.

Many thanks

Chris

More about : usb lan issues windows

a b $ Windows 7
February 11, 2010 10:03:08 PM

it would appear that ASRock doesn't have any drivers for your motherboard...
http://www.asrock.com/mb/download.asp?Model=K8NF4G-SATA...
but i would try updating the BIOS to the latest version

you can also try updating the nforce chipset
go to the Nvidia website to look for yours
you have a NVIDIA® GeForce 6100 northbridge
!