Sign in with
Sign up | Sign in
Your question

[SOLVED] Dell Inspiron N5110 & Win 7 64bit - slow wireless Internet

Last response: in Wireless Networking
Share
August 29, 2012 6:29:28 AM

Hi,

Have been trying to find a fix for my wireless troubles, but none found on the WWW helped so far.

Couple of days ago I replaced my old b/g D-Link router for a shining new Cisco / Linksys EA3500 Gigabit b/g/n router. All wireless notebooks/netbooks/iPhones & Macbook work perfect, except one Windows 7 Home 64bit Dell Inspiron N5110 notebook.

At first all seemed to be fine. After a couple of hours browsing and Youtube the wireless Internet became really slow. It was impossible to watch any Youtube video. Another Win 7 netbook works fine.

I did the following on the Dell notebook:

Disabled ip6
Disabled network mapping services
ipconfig /flushdns
and one or two other suggestions I found and can't remember.

At first it worked - Internet speed was back to normal. But a day or two later it happened again - slow Internet.

Again cleared the DNS, checked that all settings were OK (DHCP, all on auto like the other PCs). Checked the router and even disabled UPnP - no go. Now I can't get decent speed anymore.

To test the hardware, I booted the Dell notebook with a Linux Mint 13 live USB stick and wireless Internet works perfect!!!

The Dell comes with an Intel Wireless 1030 module and I suspect that the Dell/Intel Wireless utilities may interfere with the Windows drivers. Lately I get this window popping up (and disappearing after a few seconds) that the Intel Wireless blah blah is ready.

I believe I used Windows utilities to set up / change the wireless network, but I'm not sure anymore.

Any suggestions on how to fix it? Unfortunately my kids need Windows on this notebook, else I would have wiped it off in an instance.
August 29, 2012 2:03:27 PM

Let's get some hard numbers, both for a good working PC/laptop, and this troublesome one.

http://speedtest.net
August 29, 2012 7:15:52 PM

Hi eibgrad, thanks for the reply!

Since all my PCs (around 4 or 5 simultaneously) are connected to the Internet, and all others work just fine with Youtube etc., it must be a problem with the specific computer, not the Internet. I will run the speedtest later when I get back, and I will also check to see if there are any applications on the trouble PC that use excessive bandwidth. It's my kids PC so there might be something they installed or ran that causes the troubles.
Related resources
August 29, 2012 9:45:36 PM

I checked my wireless configuration and changed some settings:

1. Went into wireless setup, and changed the settings of the Intel(R) Centrino(R) Wireless-N 1030 module

2. Selected Advanced

3. Selected RTS/CTS in the first option

4. 4th option: WWM enabled

5. 7th option: Ad hoc channel - entered the channel that I chose in the router

6. 8th option: Selected Automatic for the bandwidth

Seems to work now. Wireless speed to the router is at 130Mbps (Linux gave me 150Mbps, but with Linux there weren't any problems :)  ).

Checked with speednet and results are 10Mbps download and 1Mbps upload. Just as it should be.
September 27, 2012 10:24:19 AM

I was celebrating too early !!!

The problem is back, or still there. Every once in a while the Internet on the Dell N5110 gets real slow until going into troubleshooting and let Win 7 reset the Wifi adapter. Then it seems OK for an hour, or perhaps more, until the next time.

I found some complains on the Internet about the Intel N1030 Wifi adapter this Dell is using. I installed the latest driver for this adapter but it didn't help much. Some say I should replace the N1030 for a N6230 adapter?

Has anyone had problems with this specific Intel N1030 Wifi adapter in a Dell laptop?
December 15, 2012 1:14:41 AM

Go to the Intel website and download the drivers for your wireless card. The model number can be found in your hardware section of the control panel.

My wireless card was like dialup and now I have a 45MPS connection.
December 15, 2012 7:42:23 PM

AlEinstein said:
Go to the Intel website and download the drivers for your wireless card. The model number can be found in your hardware section of the control panel.

My wireless card was like dialup and now I have a 45MPS connection.


Thanks for your help. I had already installed the latest driver, but it didn't help. The Intel N1030 wireless adapter doesn't play well with the Cisco EA3500 router (or perhaps with any type N network).

I managed to convince Dell to replace the N1030 wireless module for the Intel N6230 module. They replaced it and all is perfect now!
Anonymous
February 23, 2013 11:10:26 PM

So i find one solution for dell n5110 wireless adapter intel 1030. so this crap adapter have a lot of problems using b/g band and the problem are in b band. so what we need to do is only use g band.

advanced settings of wirless card and put 802.11g on Mode

and internet will never be slow again :bounce: 
February 24, 2013 4:49:45 PM

Quote:
So i find one solution for dell n5110 wireless adapter intel 1030. so this crap adapter have a lot of problems using b/g band and the problem are in b band. so what we need to do is only use g band.

advanced settings of wirless card and put 802.11g on Mode

and internet will never be slow again :bounce: 


Thanks for your reply! I forgot to mark this thread as solved.

I got Dell to replace the troubled Intel N1030 wireless module for the Intel N6230 module which works perfect! For those who aren't under warranty or have difficulties to convince Dell to replace the module (I don't see why Dell shouldn't replace it), I'm sure your advice will be most welcome.

Again thanks!
March 28, 2013 1:19:16 PM

In my case changing the wireless settings to g was not enough, but after setting the router Network Mode to "G only" everything works fine.
Thank you for your help, this helped me a lot :) 

Anonymous said:
So i find one solution for dell n5110 wireless adapter intel 1030. so this crap adapter have a lot of problems using b/g band and the problem are in b band. so what we need to do is only use g band.

advanced settings of wirless card and put 802.11g on Mode

and internet will never be slow again :bounce: 


December 18, 2013 2:22:07 PM

Anonymous said:
So i find one solution for dell n5110 wireless adapter intel 1030. so this crap adapter have a lot of problems using b/g band and the problem are in b band. so what we need to do is only use g band.

advanced settings of wirless card and put 802.11g on Mode

and internet will never be slow again :bounce: 


Thank you so much for this post. I've read and tried a bunch of suggestions that did not work. This one solved it :) 
March 30, 2014 8:43:18 AM

I had issue where laptop #1 was at 54Mps and Dell was at 2 ... !~
Turns out the Dell wireless adapter was setup for channel 11 and in my house with my other devices.. switching the dell to channel 5 brought its speed to 54 ! wow... and do play with the channels as where channel 5 worked well at my home, channel 11 and 6 did not..
I hope this helps!

June 10, 2014 6:51:36 PM

Anonymous said:
So i find one solution for dell n5110 wireless adapter intel 1030. so this crap adapter have a lot of problems using b/g band and the problem are in b band. so what we need to do is only use g band.

advanced settings of wirless card and put 802.11g on Mode

and internet will never be slow again :bounce: 



I was having the same issue with my dell inspiron N7110 n1030 network card , internet speed was very slow only with my pc. I must say my I fixed it by changing the wireless mode to from g/b to
1.802.11b
Thanks!

August 10, 2014 4:57:46 PM

I have been so upset, because I bought this laptop for my online degree program which starts TOMORROW! Things have been so laggy and slow it is unreal! Then I saw this post, changed my settings as suggested from g/b to b..and I'm OFF and FLYING!

Thank you so much!
!