Sign in with
Sign up | Sign in
Your question

I change xp to standard pc..now it won't shutdown.

Last response: in Windows XP
Share
March 14, 2002 11:19:07 PM

I am running windows xp. This is my fourth time I have formated and reinstalled. Every time I changed the computer in the device manager to standard pc so everything can be assigned a different IRQ then what default is, acpi. WEll I never had a problem the last three times of changing this setting and being able to hit shutdown and it woudl automatically shutdown.

NOw this time. (I have changed the mobo..if that has anything to do with it) It will not shutdown. It comes a screen like windows 95. IT is now save to shutdown your computer? I know it is no big deal but why can I not make this work like before.

I went from a asus k7v mobo to a soltek 75drv4.

Weird I say...

Thanks for all your replies.
March 15, 2002 3:38:33 AM

Which version of WinXP are you running? Home Edition does not support APM.

May I ask why you are turning off ACPI? Does your system have a device conflict that cannot be remedied by any other method?

If you do not have a irresolvable conflict, and your BIOS/hardware is ACPI-compliant, then there is no valid reason to assign individual IRQ's for your devices in Win2K or WinXP.

As for your current problem, in the Control Panel, double-click Power Options. On the APM tab, click "Enable Advanced Power Management Support".

If this does not work for you, APM support may be turned off in the Device Manager.

In the Device Manager, select View, show hidden devices. Under NT APM/legacy support, check NT APM/legacy interface node. Enable node if disabled.

(Hopefully, this will correct the problem, but APM features in WinXP are not well documented at this point. This is what I would suggest for Win2K.)

APM must be enabled in the BIOS before WinXP Pro is installed. If APM is disabled in the BIOS before the installation, the operating system will not install power management support. For APM to be selected, all ACPI features in the BIOS must be disabled.

Make sure you set "PnP OS" to "Yes" when using APM.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
March 15, 2002 5:34:55 AM

I have windows xp pro.

Gaming seemed to stutter with so much going on such as lots of explosions on screen with lots of sound. Anytime I would just stand there agaisnt' the wall and an airstrike would go by my FPS would fall. So i wanted to put different IRQ's for each.

So now I have nic on one irq, sound on one, and vid on one. Playing games is better now.

I believe my bios is acpi comp. SHould I have done something else to get this to work without doing this?

Thank you very much for the reply! I am giong to try that now.

Thanks
Related resources
March 15, 2002 5:39:31 AM

hmm I have no apm tab..or other option to enable..uh oh
March 15, 2002 7:50:32 AM

Quote:
I change xp to standard pc..now it won't shutdown

it wont do, and I doublt that you will get it back to normal without a clean install, same as when you dont have acpi/apm enabled in bios when you first install win xp - dunno why, but its bloody stupid.


If they squeeze olives to get olive oil, how do they get baby oil?
March 15, 2002 12:16:38 PM

I was afraid the workarounds I posted wouldn't apply to WinXP, but I couldn't be sure, as I have not yet seen a WinXP system setup with APM.

I have heard of frame rates in games dropping when several devices are sharing one IRQ, but I don't know how much truth there is to this statement. I've got eight devices sharing an IRQ in Win2K, and seven in WinXP. I haven't yet noticed any games stuttering in either machine, and I have more than a few games installed in both systems.

I would suggest that you install the operating system with a bare minimum of devices, and then add the sound card and NIC separately. Keep PCI 1 clear, install the sound card in PCI 3, and the NIC card in PCI 5 or 6. After the devices are installed, upgrade the drivers to the latest versions available from the manufacturer.

I would also suggest, during the sound card and NIC card installation, that you use the default Windows drivers for the video card. Update the drivers for this component last. Afterwards, disable Vsync with the drivers in the Display Properties Advanced Settings, or with a third-part utility.

You might also check to see if the refresh rate for your monitor in the games is stuck at 60Hz. If necessary, apply the <A HREF="http://www.planetquake.com/ztn/nvreffix/index.html" target="_new">Windows XP Refresh Rate Fix</A>, assuming that you have a nVidia video card.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
March 15, 2002 12:44:38 PM

While I'm thinking about it, here are a few more ideas:


If you have a Creative Labs sound card (SoundBlaster), I would suggest that you do not install the software that accompanies the card. I have had better results in WinXP by doing nothing more than upgrading the drivers for the card to the latest version available on the website. The software is bloatware, IMHO, and not necessary to achieve decent sound quality.

You might also lower the hardware acceleration for the sound card, which can interfere with frame rates. Under Sounds and Multimedia, select Audio\Sound Playback\Advanced\Performance, and lower the hardware acceleration one notch.

Make sure that Video BIOS shadowing is disabled in the BIOS. Change the AGP aperture to half the size of your physically installed RAM, or as close as possible.

Try setting the connection type in the Network Control Panel from the automatic sensing option to the type of network that you use (10BaseT / 100BaseT, full / half duplex).

Be sure that DMA is enabled for the optical device that you are using to play the games. This setting is found under the IDE controller channel's properties in the Device Manager.

You could also try reducing the desktop color depth when playing the games.

Turn off all unnecessary applications that may be running in the background when playing the game, such as an anti-virus program.

If your monitor supports this refresh rate, at your preferred desktop resolution, run DXDIAG at the Start\Run line. Under the More Help tab, click the Override button, and set the Override value to a higher rate, such as 85 or 100. Be careful with this setting, and be sure that your monitor will have no difficulty with a manual setting like this.

After installing the operating system, install the chipset drivers <i>first</i>, before anything else. Patch and update the OS. Then start adding additional components.

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
March 15, 2002 3:53:38 PM

uh oh.
March 15, 2002 3:58:36 PM

I think I may try that. Reinstalling xp without the nic and sound.

I have done the refresh rate fix.

I have disabled v-synce. That is always the first to go. hehe

RTCW is the game I am playing. Pretty intense game. SO much going on at once.

My RIg:

Athlon XP 1800 1.53GHz
512 DDR ram
Soltek 75drv4
g3ti500
Turtle Beach Santa Cruz sound card

And again thank you very much for your time ToeJam31

Very much appreciated. IM going to print this off and try this when I get some more time.

U might be hearing from me soon. hehhe

THank you
March 15, 2002 4:06:41 PM

NOpe no creative card. Thank god for that.

If you lower hardware acceleration for sound don't you get a lagg type feel. Sound after the fact?

I will check video bios shadowing in BIOS. I have changed the AGP aperture size to half the ram. 256.

Unsure on setting connection type. I have cable and during the night I can hit 1.7 down.

I will check on the optical device setting. I have an optical mouse.

I always kill everything when I play a game except norton. I will have to do that too.

My monitor is at 85hz. I heard making your monitor work harder could shorten its life substanially.

Yep right after I installed xp I installed the latest 4in1's.

However I always left everything in the box and let xp deal with it all at one time. Well since it usually understoood what I had in it I thought it was no big deal. I was likign this instead of the usual 98 load of put vid in. Install. Install drivers. Shutdown. Install Sound...install drivers..and so on and so forth.

Thanks again for the great information ToeJam!

LIke I said in my otherpost. Print this and try it when I get some more time.

A lot of great tips!
March 15, 2002 4:38:03 PM

<font color=green>"If you lower hardware acceleration for sound don't you get a lagg type feel. Sound after the fact?"</font color=green>

Not at the level I suggested, which is actually the default for most systems, and tends to improve performance.

<font color=green>"My monitor is at 85hz. I heard making your monitor work harder could shorten its life substanially."</font color=green>

Yes, it can.

I don't know the size of your monitor, but if it is 17 or 19 inches, a refresh rate of 85Hz is generally just fine. I run mine at 100Hz, but my monitor is 22 inches, and this is well within tolerances.

You can also shorten the life of a monitor by running it regularly <i>below</i> the recommended resolution and refresh rate, interestingly enough. Which is why there is a recommendation from the manufacturer in the first place.

Third-party mouse drivers are notorious with interfering with the video card. Make sure that you have the latest drivers, and that they are installed <i>before</i> the video card drivers are updated.

If this is a USB mouse, I also recommend disabling error correction. This can be found in the Device Manager, under the Properties\Advanced tab of the USB controller.

Be sure that you install the video card drivers manually. <b>Don't</b> use the Installation Setup in the nVidia Driver Set. Right-click, drag and drop, and extract the drivers into a new folder. You'll see the option to extract the drivers in the right-click menu.

If not ... install WinZip.

When you are ready to update the video card drivers, browse to the folder.

Let me know how it goes!

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
!