Sign in with
Sign up | Sign in
Your question

XP problem - pro's please read

Last response: in Windows XP
Share
March 15, 2002 5:19:18 PM

In the windows XP helpfiles when you perform a search it breaks the results down into 3 groups: "Suggested topics", "Full-text Search Matches" and "Microsoft knowledge base".

Whelp my "ms knowledge base" portion isn't working. Help thinks it's not connected to the internet and only shows an internet connection wizard in place of the search results.

The real question here: What frickin port do I need to open on the firewall to allow this kbase search to take place when I look something up in help?

If you come up with this answer I'll be much impressed (toejam..talking to you here :) 

More about : problem pro read

March 16, 2002 3:18:25 AM

I don't know if I'll impress you, but I'll tell you what happened on my system when I attempted to do the same thing.

First, I must mention that I am not using the Internet Connection Firewall. The main reason is because it does not stop traffic from <i>inside</i> the firewall from accessing the Internet. And so, in other words, you shouldn't need to open a specific port in the firewall to allow this portion of the search to connect to the Internet.

I am using ZoneAlarmPro 3.0, which blocks both incoming and outgoing traffic.

With that in mind ... this is what I did.

I was not connected to the Internet.

Start/Search/For File or Folders. Then I clicked the link listed as Information in Help and Support Center.

I searched for the Internet Connection Firewall. I ended up with Suggested Topics (12 results) and Full-text Search Matches (15 results). Nothing was listed under Microsoft Knowledge Base.

When I clicked this, I saw a warning message within the Window that stated, "To access content from the search provider, you must be connected to the Internet." And there was a clickable link, "Tell me more about connecting to the Internet", which when clicked brought up the New Connection Wizard.

I think that's where you stopped, right? Me, too.

The next thing I did was go to Start/Settings/Control Panel/Network Connections. Then I right-clicked on one of my network connection, which in this case was a dial-up called BellSouth, and went to Properties. Under the Advanced tab is a Network Setup Wizard, with a greyed-out Settings button.

I clicked the wizard. I followed the instructions, and choose the second option, "This computer connects directly to the Internet. I do not have a network yet." Then I selected the BellSouth connection and filled out the information for the computer description, name, and workgroup.

When I clicked the "Next" button, ZoneAlarm popped up and asked for permission to allow Explorer.exe to connect to the Internet, and for the Application Layer Gateway Service to act as a Server (alg.exe). I allowed this for both applications, but the Wizard popped up with an error, saying that it could not complete, and I shut it down.

So I did it again. This time, this wizard completed successfully, and the Network Wizard Settings button was enabled. There are many options in this area, which you should explore, especially under the ICMP tab.

I promptly killed the Internet Connection Firewall, as I did not want a conflict with ZoneAlarm.

But ... while connected to the Internet, I went through the search process again. This time, when I searched for the Internet Connection Firewall, I picked up another fifteen results for the Microsoft Knowledge Database.

On my system, the Application Layer Gateway Service is set to manual, and under Dependancies, it shows that both the firewall and Internet Connection Sharing are dependent on this service. The service does not start unless the firewall is enabled for a connection.

Now ... I don't know if anything I've written here will make any difference in your case. But when you reach the place in the search results where you can only access the Internet Connection Wizard, you could go ahead, make a new connection (with the same settings as your old connection, just with a different name). Then use it to get online, and then run the Network Setup Wizard on that connection. When that is finished, all the search features may be accessible.

**********************************************************

Two more things you might find helpful, that I found while looking for extra information on the firewall:

Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection.

This option can be controlled using this tweak.

Start/Run/Regedit
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
Value Name: EnableAutodial
Data Type: REG_BINARY (Binary Value)
Value Data: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Create a new binary value named "EnableAutodial", and set the new value to equal "01 00 00 00" to enable autodial or "00 00 00 00" to disable it.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE

And the next:

To enable Internet Control Message Protocols
Open Network Connections
Click the connection for which Internet Connection Firewall is enabled, and then, under Network Tasks, click Change settings of this connection.
On the Advanced tab, click Settings.
On the ICMP tab, select the check boxes beside the type of request for information to which you would like your computer to respond.

Note: To open Network Connections, click Start, click Control Panel, click Network and Internet Connections, and then click Network Connections.
You must be logged on as a computer administrator to complete this procedure.
All Internet Control Message Protocols (ICMP) options are disabled by default. If you enable ICMP options, your network can become visible to the Internet and vulnerable to intrusions.

See ya ...

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
March 16, 2002 3:29:49 AM

Another thing, three links:

<A HREF="http://www2.cajun.net/~theriots/blk/xp_search.htm" target="_new">Search Error for Windows XP</A>

<A HREF="http://www2.cajun.net/~theriots/blk/xp_tweaks.htm" target="_new">Tweaks for Windows XP</A>

<A HREF="http://www.annoyances.org/exec/software/xppowertoys" target="_new">Tweakui XP</A>

Toejam31

<font color=red>My Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new"><font color=green>Toejam31's Tantalizing Tantric Toy</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
____________________________________________________________

<font color=purple>"Procrastination on your part does not constitute an emergency on my part."</font color=purple>
!