Sign in with
Sign up | Sign in
Your question
Solved

WIFI router not communicating when connected to LAN Ports

Last response: in Networking
Share
October 29, 2012 4:00:03 PM

Hello,
have the following set up: cable modem>wifirouter>gigabit ethernet switch>to 16 ports throughout house. When I connect a second wifi router to any port around the house, the internet does not work when connecting to that specific router, however, if I use a lan cable and connect direct with my mac or cpu, internet works fine. wifi routers are not communicating with LAN ports
a b X LAN
October 29, 2012 10:43:46 PM

What are you trying to accomplish with the second router?

Are you connecting to the WAN port of the second router? Are you trying to make a second subnet to isolate it from the other hosts on the main router? Or are you just trying to add an access point with a few LAN ports, in which case you need to assign it an IP address in the main router and turn off DHCP in the second router.
October 29, 2012 10:49:51 PM

have a home with concrete walls so I have to connect wifi routers (3) through out my house so I can access the internet wirelessly. I connect the routers into the ethernet ports in the walls (den, room, kitchen). the main wifi router blew out, replaced it with a new one and now the ports are not communicating with the routers. I can only access the internet with a laptop connected via cable to the same lan ports.

Not sure why the port works with a cable to the laptop but does not work with the same cable to the wireless routers
Related resources
October 29, 2012 10:51:47 PM

Pardon. When i refer to the main router. It is the one connected to the cable model, not the ethernet switch. Connection is as follows cable modem>wifi router>switch (via ethernet cable on one of the channels of the router)

Best solution

a b X LAN
October 29, 2012 10:58:53 PM
Share

Sure. So the three wifi routers are just access points. Did you assign them each an IP address in the main router that is in the network range but outside the DHCP assignable range (or give them a reserved dynamic address in the main router)? And yes, the correct connection is LAN port to LAN port for that use.

Also the DHCP should be off in each of the secondary wireless routers.

The cable connection works because the DHCP of the main router assigns the computer an address upon connection. However, the secondary routers need to be configured as APs and have their own addresses to work.
November 6, 2012 12:37:41 PM

Thank you. Still cant get it to work. Changed the router to 192.168.1.225, turned off the DHCP. Nothing happens, after that I cant even access the TPlink site at with the IP above.

What's strange about all this is that, before it went haywire, my first install was very simple, plugged in routers all over house and everything worked fine. Didnt have to fix any IP addresses.
a b X LAN
November 6, 2012 2:05:03 PM

In addition to setting the address in the router used as an AP, you must also set that address in the main router that has the DHCP, just make sure the address is outside the DHCP range to prevent conflicts.

You usually have to directly connect via cable to the router configured as an AP to make other changes.
November 6, 2012 6:13:52 PM

Solved the issue. Did not know that I had to connect from router port to lan port. Not from WAN to LAN port.

Thanks for all your help.
a b X LAN
November 6, 2012 6:26:01 PM

Sure, just remember that the only time you ever need the WAN port is from the ISP, or if you want to create an isolated subnet.
November 16, 2012 7:48:15 PM

Best answer selected by rocketballz.
!