Sign in with
Sign up | Sign in
Your question

Make wifi range greater

  • Connectivity
  • WiFi
  • Linksys
  • Wireless Networking
Last response: in Wireless Networking
September 19, 2012 2:13:35 AM

I have a new technicolor TG582n modem and the wifi signal doesn't reach to all the house. It's a big house, lots of concrete walls. I also have a Linksys WRT54G router and I'm wondering if it's possible to put the Linksys in the other area of the house and capture the signal from the Tompson. Then connect to that signal with my laptop. Maybe this will work to give me wifi in all areas.
If this is possible, can someone help walk me through it?



More about : make wifi range greater

September 19, 2012 10:28:18 PM

thanks so much for the help.

my linksys is a version 6 so i guess this will work.

The trouble is i'm as green as grass and don't even have a clue about any of this.

I copied where I ended up, can you tell me what to download and how to do this step by step?

maybe you could do a remote help with me.

sorry, I need to learn.


Linksys WRT54G v6.0 Router details Additional information
Chipset BCM5352 DD-WRT Wiki: Linksys WRT54G v5.0 & 5.1 & 6.0


Supported by v24 preSP2 [Beta] Build 14896 v24 preSP2 [Beta] Build 14311 v24 preSP2 [Beta] Build 13064 (recommended) v24 preSP2 [Beta] Build 12533 v24 preSP2 [Beta] Build 12188 v24 SP1 [Stable] Build 10020
Description Filename Date Size
VXWorks-killer : WRT54G v5,v5.1,v6 2009-01-23 92,50 kB
VXWorks-prep : WRT54G v5,v5.1,v6 2009-01-23 1,54 kB
Micro Generic dd-wrt.v24_micro_generic.bin 2009-10-10 1,68 MB
Micro Generic dd-wrt.v24_micro_olsrd_generic.bin 2009-10-10 1,66 MB
TFTP-Client for Windows tftp.exe 2009-01-23 44,39 kB

Related resources
September 20, 2012 5:06:24 PM

Thanks again....

i'm reading this slowly and carefully... never done anything like this before

i got to part;

"3.Click on the three dots next to "output image" and save the file as My54gImage.bin in the same folder as everything else is located. "

i'm trying to click create on the software but i get the error;

error creating VxWorks killer firmware image: MAC address invalid format

i've double and triple checked what it says on the bottom on my router so i'm not sure my mistake.

when i try to get into the router with my browser... i type the ip address

I get "management mode firmware upgrade"... and it wants me to browse for firmware

oops, think i screwed up

any suggestions?


September 22, 2012 12:27:10 AM

Hi... please help, i've been on this for hours and hours..

I've managed to get the new firmware on my modem and i'm in the process of setting it up but i'm stuck in one place... i'm following step by step but when i try to save changes I end up at a blank browser page. I'm able to go back and try again but no matter what, I can't get the settings to save.

I can't find DHCP to see if it's enabled
and for Wireless Network Mode : Must Match Primary Router I don't have the option to set it for "N" my primary router is N

These are the instructions;

To enable bridge mode between two routers, the primary router must be in AP mode (default) with DHCP Server enabled. The secondary router running DD-WRT v24 will be configured as the Repeater Bridge.

Restore Factory Defaults on Secondary (DD-WRT) Router
Do a proper HARD 30-30-30 Reset on the router.
Set your computer to a static IP of if you know how to set static addresses. Otherwise leave your computer's network adaptor(s) programmed with the factory default setting of DHCP and the router will assign a valid address to your computer.
Connect your computer to the secondary router via wired LAN port or as a wireless client. The dd-wrt default wireless SSID is "dd-wrt"
Open the address in your web browser. Newer versions of DD-WRT will require you to set a password before you can continue.
Open the Wireless -> Basic Settings tab
Physical Interface Section
Wireless Mode : Repeater Bridge
Wireless Network Mode : Must Match Primary Router
Wireless Network Name(SSID) : Must Match Primary Router exactly including exact case- Make sure you spell this correctly
Wireless Channel : Must Match Primary Router (This will disappear once you put it in RB mode, and isn't needed)
Wireless SSID Broadcast : Enable
Network Configuration : Bridged

Please help....
September 23, 2012 12:30:52 AM

i think i got it...