Sign in with
Sign up | Sign in
Your question

How to enable atheros ar9285 promiscuous mode?

Last response: in Wireless Networking
Share
September 23, 2012 3:48:38 PM

hello all,

My question is very simple: i wonder how i can enable promiscuous mode on my Atheros AR9285 Wireless Network Adapter?
I'm using windows 7 starter.driver version of my Atheros AR9285 Wireless Network Adapter:9.2.0.427.
September 24, 2012 6:56:14 PM

Don't use windows is the only answer. There is only 1 older card that works because they have written a custom device driver.

Microsoft has made it so the device drivers do not recognize the command to put a device in promiscuous mode. Your only option would be to write a custom device driver for your card.

You best option is to get a copy of the backtrack dvd and boot from it. You can then run without impacting or changing your windows installation. Other option is to load backtrack into a virtual machine but it gets much more tricky to map the wireless devices to the VM so it can put it in promiscuous mode
m
0
l
September 25, 2012 12:53:58 AM

bill001g said:
Don't use windows is the only answer. There is only 1 older card that works because they have written a custom device driver.

Microsoft has made it so the device drivers do not recognize the command to put a device in promiscuous mode. Your only option would be to write a custom device driver for your card.

You best option is to get a copy of the backtrack dvd and boot from it. You can then run without impacting or changing your windows installation. Other option is to load backtrack into a virtual machine but it gets much more tricky to map the wireless devices to the VM so it can put it in promiscuous mode




hello bill001g,

thanks for the reply,i am trying the backtrack now,but i have many problems with it.For example:i can't install it from usb (cannot find free space on hdd) and the virtualbox option has also some hdd problems.
but i don't give up,for now...
m
0
l
Related resources
September 25, 2012 12:54:58 AM

bill001g said:
Don't use windows is the only answer. There is only 1 older card that works because they have written a custom device driver.

Microsoft has made it so the device drivers do not recognize the command to put a device in promiscuous mode. Your only option would be to write a custom device driver for your card.

You best option is to get a copy of the backtrack dvd and boot from it. You can then run without impacting or changing your windows installation. Other option is to load backtrack into a virtual machine but it gets much more tricky to map the wireless devices to the VM so it can put it in promiscuous mode




hello bill001g,

thanks for the reply,i am trying the backtrack now,but i have many problems with it.For example:i can't install it from usb (cannot find free space on hdd) and the virtualbox option has also some hdd problems.
but i don't give up,for now... (maybe you will recieve this twice,sorry for that.)
m
0
l
September 25, 2012 11:37:11 AM

Try to boot directly from the DVD. Choose to run it in forensics mode until you get used to it that way it will not even touch your hard drive. You should be able to issue the airmon-ng and airodump-ng command directly but you can lauch the desktop and run wireshark and some of the other gui based tools.
m
0
l
April 6, 2014 4:03:31 AM

TO THE MODS: SOLVED AND CLOSED;

PLEASE REMOVE THIS THREAD
!i don't have delete button,or i can't find it.

cedricr.
m
0
l
!