/ Sign-up
Your question

Slow hard drive on Win2k (not what you think)

  • Hard Drives
  • Maxtor
  • Storage
Last response: in Storage
October 18, 2002 4:11:49 AM

Okeedokee... I have a maxtor 60GB hard drive as a slave to a 10gb Quantum. They were working fine in this configuration until about a week ago, when the maxtor suddenly started behaving really strangely. It accesses slow, but in addition, my entire system gets really really slow while it uses it. My mouse jerks around, and basically I can't do anything else at the same time I use the drive. All drive checks show the drive to be good, and when I took it over to a friend's house it seemed to work fine. I'm suspecting that it's an OS problem (I'm on Win2k pro) and I was wondering if anyone here has encountered similar issues before... is the OS problem prompted by something wrong with the drive, or should I just break down and reinstall windows?


More about : slow hard drive win2k

October 18, 2002 5:42:41 AM

Check that you have DMA enabled. Also I suggest you check you drive with the tool from maxtors website. (Sorry currently cant remember the name of it).
One more thing, I suspect the Quantum is rather old (cosidering the size). If this drive only runs UDMA33, and you have a 'stupid' IDE controller, this will cause the Maxtor to run UDMA33 as well. Try unplugging the Quantum or put it as master on the secondary controller channel (If you have one)
October 18, 2002 5:52:22 AM

Well, I did consider the "stupid" controller card issue, but I didn't think it was serious until I checked the DMA. My second drive is set to DMA if available, but it's using PIO. So...that's probably it. However, it was working fine before. Is there any other way to force it into DMA? Thx.

Related resources
October 18, 2002 6:05:59 AM

So your second drive (The quantum) uses PIO? You cant force the drive to use DMA, if it doesnt support it. What about the DMA setting for the Maxtor?
October 18, 2002 3:00:34 PM

Well, it WAS using UDMA once upon a time, I'm not really sure what changed. I will try the test tool, thanks a bunch.