Sign in with
Sign up | Sign in
Your question
Solved

100Mbit/s Router vs 1 Gbit/s Switch

Last response: in Networking
Share
November 10, 2012 3:02:58 AM

Hi Guys,

At home I have a small LAN with two connected PCs. The problem I have is that the transfer speed between the two is slow and not gigabit at all.

Setup:
ADSL line into Wireless Router (100Mbit), from Wireless router ethernet to gigabit switch. Connected via ethernet to gigabit switch are the two machines. They both have gigabit network cards. Both PC's have static IPs.



Question: Do I not get the gigabit speed because of the router speed?

Thanks for you help
November 10, 2012 3:10:14 AM

No the traffic will not pass through the router. Machines in the same subnet use mac addresses to talk directly to each other. The switch is smart enough to know where the machines are and send the data directly.

It depends how far below 1g you are getting. If it is hundreds of mbit/sec then that is all you can expect without some special settings. Be careful you are not reading mega BYTE/sec
m
0
l
November 10, 2012 3:13:07 AM

john-b691 said:
No the traffic will not pass through the router. Machines in the same subnet use mac addresses to talk directly to each other. The switch is smart enough to know where the machines are and send the data directly.

It depends how far below 1g you are getting. If it is hundreds of mbit/sec then that is all you can expect without some special settings. Be careful you are not reading mega BYTE/sec


Hi John,

No I believe I'm getting Mbit speed, around 11MegaBYTE per second. Any idea on how I can test each of the interfaces for speed?
m
0
l
Related resources
November 10, 2012 3:30:37 AM

Just read somewhere else that this could be related to my network cables. Damn. They mentioned cat 5e.
m
0
l

Best solution

November 10, 2012 10:02:24 AM

Pretty much you will have trouble finding anything that is less than cat5e. Both cat5e and cat6 can run gig.

Be sure you cable has all 8 wires. Gig uses all of them where 100m only needs 4. Some of the really cheap cables (ie like $1) do not have all the wires but they are very uncommon.

A different cable is very cheap thing to try most likely less than $5 for a 10ft cat5e cable with all the wires

If the cable has all the wires then you need to check the setting in the driver for the nic. It is possible to force them to run only 100m, you want it all to run auto and it should run at gig. Hard to say it is not common for people to mess with these settings.
Share
November 10, 2012 4:55:15 PM

unplug all cables to your switch except the one that goes to your ethernet card on one machine.

Go to control panel, device manager, find your network adapter, find the advanced tab
look for the speed and duplex setting and change it from auto to the max speed you think all of your equipment should support. Reboot and if it works you have a auto negotiation issue between your card and switch.

If the connection to the switch is ok, add your second connection and check the negotiation on that machine. If it is ok, then connect your switch to the router and see if your switch tries to back off your speed settings on your first two machines.

-on Win8 the negotiated speed does show up in the adapter status properties.
In my case I have 6 network adapters listed, all show 1.0 Gbps speed
as I exepect.
m
0
l
November 19, 2012 4:54:24 PM

Best answer selected by faniedry.
m
0
l
November 19, 2012 4:56:58 PM

Hi Everyone,

Thanks for your answers and suggestions.

Turns out, the network cable that I used on one of the pc's was the cause. Changed it to a different one, and Bam!, gigabit ethernet!

Thread now considered as solved! :bounce: 
m
0
l
!