Sign in with
Sign up | Sign in
Your question

Ethernet slow to gain network connection.

Last response: in Networking
Share
November 11, 2012 10:41:08 PM

Just finished my new build... first time in a long time for a PC from scratch. My system boots in 20 seconds or less to a ready desktop (got to love SSD)... but my NIC takes another 30+ extra seconds for it to gain connection. It's really annoying... everything is ready to go, but anything that requires internet (basically everything I use this computer for) has to wait until the network is active.

Any suggestions would be appreciated. Here's the technical details...

ASUS Z77 Sabertooth Motherboard (using Intel 82579V Gigabit On-Board NIC)

Windows 7 SP1 64-bit... Just the Windows Firewall... No Antivirus (trust me, it's fine.)

Apple Airport Extreme router (older generation, Ethernet is only 10/100... has the latest firmware from Apple)

I prefer to use a Static IP... but testing with both Static and DHCP options hasn't helped the issue. So yes, even with a Static IP (which has been set aside by the router for exclusive use by this computer) Windows still takes 30-60 seconds after boot has finished to complete the network connection.

I've tried multiple drivers for the NIC... first the latest one provided by Microsoft Updates (don't remeber exact version, but it was a 2011 driver)... and now the latest one available for download from ASUS' support page for my Motherboard (12.2.45.0 - 8/10/2012).

My MacBook Air (on wireless) connects very quickly (2-5 seconds) after it's start-up. So I don't know if it's anything to do with my router... but it is something I am considering upgrading (as I would like gigabit ethernet, I commonly do transfers thru my network). I do have another Windows 7 (32-bit SP1) Shuttle K47, but don't see it having the same issue (not that I pay attention to it much... it's just a home server box that runs almost 24/7).
November 13, 2012 3:07:45 PM

I've also just tried going direct to my cable modem (with two different network cables)... same result. Still takes a long time to gain it's connection.

Any suggestions at all?
m
0
l
November 15, 2012 5:14:06 AM

Before even noticing this issue, I had previously uninstalled the Network iControl component of the ASUS AI Suite software. But I'm guessing that it never completely uninstalled (or was a bad build). Reading more threads about the issue, including some on ASUS on forums, I decided to uninstall all remaining components of the AI Suite. Rebooted the system... still was having the same issue. Noticed on the ASUS website that there was an updated version, so thought I'd give it a try and see if it would remedy the issue. Now that I've installed the latest version of the ASUS AI Suite (including leaving the Network Control component installed and enabled) it connects immediately as my desktop loads.

I will keep an eye on the situation... a bad version, or install, or whatever of the ASUS AI Suite and most likely it's Network Control was the culprit.
m
0
l
Related resources
!