Sign in with
Sign up | Sign in
Your question

Mouse lag in Win7 x64

Last response: in Windows 7
Share
May 14, 2012 11:02:46 PM

I have looked all over the internet for an answer and tried many different troubleshooting solutions and haven't been able to nail it down... (When I say lag - just to clarify, I mean I will move the mouse and there's a slight, to moderate, delay until the pointer responds - very effing annoying!)

I have a Win 7 Home Premium 64 bit OS, 16 GB RAM, Intel Core i7 processor, and Logitech MX1000 mouse

My mouse is experiencing a lag issue that is very annoying and it doesn't seem to be tied to any one program. I've checked my performance monitors and nothing appears to be out of the ordinary, I've checked my system for viruses (Comodo Antivirus), I've updated all my drivers - I've run out of ideas for what this could be!

A little history: a few months ago I bought a new motherboard (ASUS P8Z68 V PRO Gen3) and Core i7, and reinstalled windows and didn't have a problem until about a month ago... but nothing in my PC had changed, no new software, no new hardware... I'm not sure why, but the mouse just started experiencing a lag...

Can anyone help me troubleshoot this issue?

Thanks all!

More about : mouse lag win7 x64

May 15, 2012 5:38:08 PM

If you have the logiteck software you can adjust the mouse the way you want it to work. If you donn't have the software you may be able to down load it from Logiteck,com/support.
m
0
l
May 15, 2012 8:00:22 PM

I guess I should have added that this problem happens intermittently, it's not constant... My mouse will work fine for a while then after my computer's been on for a bit, it'll start to lag... so it's not an adjustment issue
m
0
l
!