Sign in with
Sign up | Sign in
Your question
Solved

Web page opens automatically when shortcut is droped on desktop

Last response: in Windows 7
Share
May 19, 2012 1:04:49 AM

Strange problem...
When I drag a shortcut of the current web page from the top address bar of IE9 onto the desktop a new IE9 window opens with the web page in it. This is rather annoying. All I am intersted in is to have a shortcut icon to be saved on the desktop.

I set a registry setting to disable active desktop but didnt change this action.
May 19, 2012 1:12:15 AM

Sorry, one point of clarification... the orignal web page closes and a new one opens up with the address of the original shortcut placed in it... this is very odd behavior. This is a new HP laptop running Windows 7 ultimate.
-- Dan

dantx32914 said:
Strange problem...
When I drag a shortcut of the current web page from th top address bar of IE9 onto the desktop a new IE9 window opens with the web page in it. This is rather annoying. All I am intersted in is to have a shortcut icon to be saved on the desktop.

I set a registry setting to disable active desktop but didnt change this action.

Best solution

August 21, 2012 12:00:20 AM
Share

The only solution seems to be hold down the shift key as you drag the URL onto your desktop. This creates a standard link instead of a "Pinned Website".
Related resources
August 21, 2012 12:00:55 AM

dantx32914 said:
Sorry, one point of clarification... the orignal web page closes and a new one opens up with the address of the original shortcut placed in it... this is very odd behavior. This is a new HP laptop running Windows 7 ultimate.
-- Dan


Getting same problem on my desktop PC, Win7+IE9. Dragging and dropping onto the desktop works fine from other browsers, just not from IE9. Never had the problem on IE8. However, friends running Win7+IE9 are not having the problem so there's something amiss with my settings somewhere.
September 4, 2012 3:15:42 AM

HA! Good feedback... thanks for the lead GwanFather.

This problem is directly related to the Win7 ability to create Pinned sites. A feature I never liked and realized disabling the Pinned Site feature takes care of the problem listed in this thread.

As suggested in the last post, holding the shift key down when the internet shortcut link is dropped on the desktop provided the desired result - it creates a shortcut on the desktop and does not close the original window in IE9 followed by opening a new IE9 window of the same website.

However the logic behind this action is well beyond my understanding. Actually disabling the Pinned site feature altogether puts this back the way I would expect.

To disable Pinned sites I did the following:

Running Group Policy Editor (GPEDIT.MSC) from the Start menu
User Configuration, Administrative Templates, Windows Components, and Internet Explorer
Enable the following "Turn off ability to pin sites"

Close all IE9 windows and restart.

Thanks again GwanFather... I was scratching my head on this on for a while! I appreciate the lead to getting this annoying feature removed!!!

-- Dan
September 4, 2012 3:16:33 AM

Best answer selected by dantx32914.
September 4, 2012 9:48:00 PM

Nice one re the gpedit :)  Shame we have to go to such lengths though!
!