Sign in with
Sign up | Sign in
Your question

Acer aspire 3620 wifi not working

Last response: in Wireless Networking
Share
October 25, 2012 5:27:40 AM

I have an acer aspire 3630 and i recently got it, so i decided to update all drivers and i stupidly didn't do a back up now the wifi isnt working, i tried uninstalling the cards, and tried doing what this thread said (http://www.justanswer.com/computer-networking/5jxrm-hav...) and here(http://www.tomshardware.com/forum/22058-43-problem-acer...) i even tried installing all the drivers i could find (broodcom, foxconn, the drivers from the acer site) and nothing is working, my wifi light next to the switch keeps flashing on and off.

as stated before i have acer aspire 3620 notebook.
atheros ar5005g wireless network adapter
realtek rtl8139/810x family fast ethernet NIC.

Please help!
a b \ Driver
October 25, 2012 6:41:39 AM


Hello and welcome to Tom's Hardware Forums.

You will find the Atheros wifi adapter in Device Manager, then right click it to go to the Properties pages. Click on the Detalis tab and scroll to HardwareIDs and take a note of the four characters which follow VEN for Vendor and also the four following DEV for Device.

Go to http://www.pcidatabase.com and input those characters in the two relevant boxes and follow the trail to the right driver. When you find the list of the Vendor's drivers, they aren't in order so use your browser's Find facility to track the Device details. With luck you'll have an executable file but some will be a zipped folder..


m
0
l
October 25, 2012 6:58:10 AM

I installed it, came in a .zip file so i just extracted and run the .exe, still doesn't work. :( 

when i run the atheros troubleshooting i get..

Atheros Troubleshooting Utility
Troubleshooter report...
Report date: Thursday, October 25, 2012

Name: Driver installation test
Description: This test is to check the radio driver installation.
The radio's registry keys are OK.
Nic name. . . . . . . . . : Atheros AR5005G Wireless Network Adapter
Driver name . . . . . . . : Atheros AR5005G Wireless Network Adapter (Microsoft's Packet Scheduler)
Driver path . . . . . . . : C:\WINDOWS\system32\DRIVERS\athw.sys
Driver version. . . . . . : 9.2.0.480
Active Profile Name . . : home
Test Done: The radio driver has been installed.

Name: Card insertion test
Description: This test is to check the radio insertion.
Test Done: The radio has been inserted.

Name: Card enable test
Description: This test is to check if the radio/driver is enabled.
Test Done: The radio has been enabled.

Name: Radio test
Description: This test is to check if the radio is turned on.
Test Done: Your radio is turned on.

Name: Association test
Description: This test is to check your client adapter's association to an access point.
Link Status . . . . . . . : Not Associated
Test Failure: Your client adapter is not associated to an access point.
Solution: Configure the radio card and set SSID and other properties.

Test not completed.


I uninstalled all drivers that i had previous installed and restarted my laptop and now im just sitting here like derp, i only have the file you told me to get installed, it says the card is working but i can't see any modems and im right next to mine, and my wifi switch light keeps flashing -.-
m
0
l
Related resources
a b \ Driver
October 25, 2012 6:12:38 PM



Where is says "configure" I assume it means check that the Channel its set to receive no is the same as your router is broadcasting on.

The other day, I installed a Belkin and it failed from the start so I had to configure it. I found it was set to Costa Rica or similar and I had to change it to the UK, then check the channel and the power settings. See what yours says.



m
0
l
October 26, 2012 1:30:45 AM

How do i configure? i know how to go on configure the card but there's no setting for a certain place, do i have to go into the modem?
My wifi for my phone/ipad etc works fine
m
0
l
a b \ Driver
October 26, 2012 6:29:07 AM


If the phone and Apple device work, it means the Atheros card is failing find the network so it must be configuration which is out of synch. In the settings for the Atheros 5007 in my netbook, I also don't have a country and the only two I can see which might be wrong in your settings is the power and the radio.


m
0
l
October 26, 2012 7:34:32 AM

Power as in, battery/ac supply? what can stop the card getting the power it needs?

and it says the radio is on.. and when i click search for nearby networks it looks like it's searching but then comes up with no results.
m
0
l
a b \ Driver
October 26, 2012 6:00:33 PM

and it says the radio is on.. and when i click search for nearby networks it looks like it's searching but then comes up with no results.




Aha - a clue. It might be that it only "sees" networks secured at lower levels so if yours is WPA or higher, it can't be identified by the Atheros. Lower the router's security to WEP just for ten minutes to experiment. Details are here in our Sticky Post http://www.tomshardware.co.uk/forum/38111-18-find-chang...

If it works, post back for advice on whether it's safe to leave security at WEP.


m
0
l
!