Sign in with
Sign up | Sign in
Your question

Network Adapter showing up as ethernet controller

Last response: in Wireless Networking
Share
October 25, 2012 6:19:51 PM

hey guys i have a slightly problem here and ive racked my brain trying things to no avail, the problem is that with my new build i installed a TP-link 300mbps wireless card, it will only however be recognised as ethernet controller and not the normal network adapter. So i put an old wireless card from another PC into mine and it works without a hitch comes up with network adapter in device manager and installs fine, and the problem card was put into an older PC and worked fine just like expected. Im really unsure on what could cause this and im not to sure about buying another card just get incase i have a similar problem, any advice is welcome thanks guys
my system info is(not sure if it matters)
ASUS M5A99X evo R2
Phenom 965 BE
8GB kingston Hyper X 1600mhz ram
OCZ 650W bronze edition
Radeon 7770 OC
a b F Wireless
October 25, 2012 9:38:30 PM

Have you checked with TP Link support? I don't think I have ever seen a network card be recognized as the wrong type. Try using different drivers, if you are using the ones off the disk with the card, see if there are newer ones online.
October 25, 2012 10:42:58 PM

im unable to install any actual drivers as it doesn't recognize the card :(  well it recognizes it but as an ethernet controller in device manager for some reason, another wireless card that works will register as network adapter the only puzzle is the card works on another PC so its just plain weird
Related resources
October 25, 2012 10:43:02 PM

i will try with TP link though see if they can make sense of this
a b F Wireless
October 26, 2012 1:24:05 PM

michaelc87 said:
im unable to install any actual drivers as it doesn't recognize the card :(  well it recognizes it but as an ethernet controller in device manager for some reason, another wireless card that works will register as network adapter the only puzzle is the card works on another PC so its just plain weird


After it detects the card, you can try to change the drivers then, just point it to the correct driver files. That may fix this.
!