Sign in with
Sign up | Sign in
Your question

Getting only 100 Mbit/s from gigabit ethernet card

Last response: in Networking
Share
December 17, 2012 7:32:03 PM

Hi,

I have the following problem. I bought two TP-LINK TG-3269 gigabit cards, placed them in two computers and connected them directly. On my Ubuntu system I used iperf tool and measured only 95 Mbit/s. It wont go any faster, I tried many times with different settings.

What is the problem? The indicator lamp shows 1000 Mbit/s.
December 17, 2012 9:35:23 PM

Many Gigabit cards will only negotiate a 100Mbps connection with a crossover cable or in crossover mode. You must connect a Gigabit switch in between to get full speed.
December 18, 2012 8:15:54 PM

1. check the cable. It needs to be a cat5 with all 8 wires working. Basic cable testers are very cheap by the way. A crossover or switch is not needed for gigabit.
2. you can set the speed manually somewhere in the driver, but i'm not an expert for linux. Research yourself.
Related resources
December 18, 2012 9:44:41 PM

it is not the cable, i am pretty sure, nor is it auto negotiated 100Mbit/s speed...

this is what I get on both computers with ethtool :

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes


everything is ok here...

and mii-tool says: eth0: negotiated 1000baseT-HD flow-control, link ok
December 18, 2012 9:44:46 PM

it is not the cable, i am pretty sure, nor is it auto negotiated 100Mbit/s speed...

this is what I get on both computers with ethtool :

Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes


everything is ok here...

and mii-tool says: eth0: negotiated 1000baseT-HD flow-control, link ok
December 18, 2012 10:04:22 PM

Quote:
and mii-tool says: eth0: negotiated 1000baseT-HD flow-control, link ok


There's your issue. The connection is only half-duplex (HD)
!