Sign in with
Sign up | Sign in
Your question

Telnet Port Forward

Last response: in Networking
Share
December 17, 2012 9:20:33 PM

This appears to be the closest to 'correct' forum to ask this in, I've been tasked with configuring our work network to allow another company to telnet one of our devices, I've forwarded port 23 to the device (which was already statically configured on the network), tested that the port is in fact open on the device (it's not a PC so I had to do this by scanning from within the network and seeing that in fact port 23 is responding), and yet none of the online port checking utilities I know of see port 23 as open.

Additionally I've tried bypassing the router entirely and plugging the device directly into the modem, with the same result. I've contacted the ISP and they claim to only block port 25 for the usual reasons (either to reduce spam, or upsell an unblocked service). also the router does successfully forward other ports with no difficulty.

Has anybody had any experience with a situation like this? or perhaps some theoretical knowledge?

N.B. There is no 'double router' issue in effect here.

More about : telnet port forward

December 18, 2012 10:40:34 AM

what kind of router is it?
December 18, 2012 1:09:29 PM

You may want to try to forward a different external port to port 23 internally. You could then telnet to that port number and it should be mapped to 23 on the real device. This would show you pretty quick if the ISP is up to no good. Not all routers have this ability.
Related resources
December 18, 2012 2:30:26 PM

As for router type it's a WRT160Nv3, I've since tried mapping from port 88 outside to 23 inside on the same device to no avail.

Strangely I was able to map port 23 outside to 23 inside on a computer on the same network, so it seems likely that there's in fact a problem with the initial device I was working with, which seems odd since I am able to connect to it via port 23 from within the network.
December 27, 2012 5:04:43 PM

turns out there was a configuration issue with the 'gateway' setting on the device I was trying to connect to, thanks for your input.
!