Sign in with
Sign up | Sign in
Your question
Closed

Windows 7 "Unidentified Network"

Last response: in Networking
Share
December 20, 2012 10:39:19 AM

Hi,

My problem is that my Local Area Network adaptor is showing Unidentified Network.

I am running a Win7 computer with the latest updates (20/12/2012) on a Dell Optiplex 740 with onboard LAN. It is Ethernetted to my Wireless ADSL router.

I have several other computers using wireless off the same Wireless Router with no problems.

I have tried:

1. Uninstalling the LAN adaptor and its drivers, and also updated the drivers.
2. Adding and removing protocols associated with the adaptor, of which all have been re-added as before.
3. Restarting the Bonjour service.


I have just installed a USB wireless dongle and it says this is also an unidentified network!

Any help?

Tom.

a c 203 F Wireless
a b $ Windows 7
December 20, 2012 12:57:52 PM

Most likely it is still the Bonjour service, you can't kill the responder even in the task manager. I would delete the Bonjour service for now (you can reinstall it later if needed). In the run box window type: %PROGRAMFILES%\Bonjour\mDNSResponder.exe -remove and then regsvr32 /u %PROGRAMFILES%\Bonjour\mdnsNSP.dll

You can then delete the Bonjour folder.
Score
0
December 20, 2012 4:20:04 PM

Thanks for the quick response.

The first command works but the next command gives:
The Module "C:\Program" failed to load
Makes ure the binary is stored at the specified path or debug it to check for problems...." etc.

I have check to see if the dll is in the path and it is. But of course I can't delete it.

T
Score
0
Related resources
December 20, 2012 4:30:03 PM

Update:

I have successfully input both command and deleted the bonjour folder with contents.

The issue is still not resolved. Anyone?

Score
0
December 20, 2012 5:12:01 PM

I have discovered some bonjour tripe in my ProgramFiles(x86) folder as well as the normal Programs Files. How to do I send a command for the x86 one?
Score
0
a c 203 F Wireless
a b $ Windows 7
December 20, 2012 5:27:41 PM

Yeah, sorry my answer was for a 32 bit install; the 64 bit has two program files with slightly different names. Just alter the path to %PROGRAMFILES(x86)%\Bonjour\mDNSResponder.exe -remove

Also, take a look in your network control panel change adapter settings for any adapters other than your Ethernet and/or wireless cards, and if unidentified disable them.
Score
0
December 20, 2012 6:21:01 PM

Thanks for your help so far.
I've uninstalled Bonjour successfully. I'm now sure its not Bonjour.

I've also tried:
1. Route Delete 0.0.0.0
2. Uninstalling the LAN device and reinstalling
3. Updating the drivers to the LAN device and firmware to the Netgear ADSL router.
4. Resetting TCP Stack
5. I can't release or renew IP because its not getting an IP in the first place, just autoconfiguration IP's and loopbacks.
6. Typed Unidentified Network into google and tried the first 15 results and all the attempts at a fix in each one and ALL failed.

Beast?

T
Score
0
a c 203 F Wireless
a b $ Windows 7
December 20, 2012 7:54:14 PM

When you did the TCP reset did you follow the MS how to: http://support.microsoft.com/kb/299357#letmefixit

And I assume that you have no services running that can block access, like McAfee.

Also, just for completeness, try going into your network control panel and change your network type from Home to one of the others and then change it back. For some odd reason that sometimes can fix the network. This assumes that you have an icon under active networks that you can click, even if it is unidentified. Is there only one icon or multiple, such as Home and Unidentified Network?
Score
0
January 31, 2013 9:11:12 PM

I had this issue "Unidentified Network" but it was setting up a new router, a TP-LINK TL-WR702N. I was trying to log into the new router and setup a name and password for it by going to 192.168.0.254 in IE running Windows 7. IE would say there was no connection and in the Network and Sharing center the wireless network had "Unidentified Network" and I could not change it.

I found out that this TP-LINK router has DHCP turned off by default.

To fix this you need to:

1. Go into the Properties of the wireless card.

2. Double click on Internet Protocol Version 4 (TCP/IP4), and manually assign the IP address to 192.168.0.120, so it is from the same segment.

3. In IE go to setup on the router by accessing to 192.168.0.254 and logging in with the Username and Password from TP-LINK.

4. Click on DHCP on the left hand menu and turn it ON.

5. Click Save and Reboot.

Once that was done the "Unidentified Network" went away and I could pick the type of network for this router. I could then go back to Internet Protocol Version 4 (TCP/IP4) and set it to Obtain an IP Automatically.
Score
0
April 11, 2013 3:52:06 AM

the DHCP server could be full - try freeing some leases.
Score
0
!