Sign in with
Sign up | Sign in
Your question

Possible XP PRO TWAIN Corruption

Last response: in Computer Peripherals
Share
February 29, 2004 3:27:33 AM

Up until this morning, I had been using my CanoScan N1220U USB scanner via TWAIN driver within Paint Shop Pro 8.10 and Photoshop 7.0.1 without problems. All of a sudden it clicking on scanner button, it cannot find a single TWAIN source. I have since reinstalled the supplied drivers, rebooted, deleted and reinstalled a few times, still the scanner cannot be seen as a source.

In Control Panel, clicking on "Scanners and Cameras" shows the scanner and it passes the "Scanner Test" diagnostic check.. all seems OK but neither PSP nor PS is able to see it.

Besides reinstalling the OS which I hesitate because it would mean I have to reinstall ALL the post-SP1 patches from the beginning. Is there another means of reinstalling XP's default support for TWAIN? FWIW, I did a "REPAIR" install of XP PRO and it did nothing to solve the problem.

More about : pro twain corruption

February 29, 2004 9:40:55 AM

You've gone through some things to Solve your problem, but there are two things I DON'T see that you tried:

1) uninstall TWAIN completely and reinstall. Make very sure that you remove the actual folder that your scanner software set up for Twain under the Windows/System32 folder (usually). You may have to contact Canon tech support to find out where they put it. Then reboot and reinstall Twain.

I don't see that you tried removing all reference to your scanner (via control panel and/or System Properties) and then reinstalling it.




Quote:
=== SHOPPINGMAN!!! Never assume ANYTHING ====

February 29, 2004 2:41:01 PM

I've identified the source of the problem to be the four files (TWAIN.DLL, TWAIN_32.DLL, TWUNK_16.EXE, TWUNK_32.EXE) that reside in C:\WINDOWS. The four files are protected and no matter how many times you delete them manually or copy over, XP automatically restores them. I suppose these files got corrupted for some reason and their file size and date stamp were smaller and older respectively. I found out that if I copied them over with a fresh set, the scanner gets recognised by all the TWAIN-aware appllications but only for a very brief moment before XP restored the corrupted versions.

Exploring this further, I rebooted in SAFE MODE, tried deleting them and this time it worked. So I copied over a new set of drivers I downloaded from Canon Australia website that included a set of 1997 TWAIN drivers (the bad ones were 2002). Rebooted normally and all's well again.

Time for bed!
!