Sign in with
Sign up | Sign in
Your question

VPN access to Windows 7 Homegroup from internet

Last response: in Networking
Share
December 23, 2012 7:18:50 PM

I have 2 computers set up on a LAN Homegroup. One of them is connected to the printer, on the other I configured a VPN server with Windows 7's VPN. The client is a third computer that connects via the internet. The problem is that although I can see that we are connected through the VPN, the client can't access the shared folder, the printer or otherwise connect to my Homegroup.

I did some research and to that end I:
- set a static IP for the VPN server and forwarded port 1723
- made sure I can ping the other computer
- set an "everyone" for the shared folder in sharing and security
- enabled everything on both firewalls that had anything remotely sounding like it had to do with it

This is my first time setting up any sort of network. Is there anything else I need to do or have done wrong?
a b $ Windows 7
December 24, 2012 12:38:10 PM

You need to forward (tunnel) some more ports like 137-139. Don't remember which ones exactly. M$ knowledge base knows. :) 
m
0
l
December 24, 2012 9:14:10 PM

I tried looking into that. I saw something about forwarding ports 135-139 and 445 and other people saying that's a bad idea.

I already have 21 and 22 forwarded for FileZilla, but I was hoping to be able to access the file through the internet through the Homegroup rather than having to download it each time.
m
0
l
Related resources
a b $ Windows 7
December 25, 2012 1:55:49 PM

Those people saying it's a bad idea are right. Running the homegroup over vpn makes it slightly secure, but you will pretty sure run in trouble anyway. Example: when you open a file from the remote pc and the internet connecting hangs only for some seconds, the file on the disk will stay with the "open" flag. If that happens while writing to the disk, you have a good chance to destroy your filesystem.
m
0
l
December 31, 2012 11:06:26 PM

I understood that they were saying that opening up all those ports was a bad idea.
m
0
l
December 31, 2012 11:27:59 PM

It is a bad idea but you must make sure they are open though the tunnel, that is different than being forwarded in the router. They may be by default it depends on your firewall settings.

More than likely you issue is with your router. PPTP users GRE which does not pass though NAT. Your router must have the ability to recognize this issue and allow the GRE traffic to pass though. This is actually quite a pain to get running sometimes.

You may want to look at OPENVPN software. It uses SSL so its a simple port 443 forward.
m
0
l
December 31, 2012 11:32:50 PM

In my router I have PPTP passthrough enabled (under VPN passthrough). Should that help?
m
0
l
December 31, 2012 11:42:13 PM

If it works it should do the job. If your remote machine is assigned a IP address and you can ping the other machines IP I would be suspect of the firewall settings someplace blocking you. If you cannot ping I would be looking to see if the tunnel really is functional. Microsoft site has a could of good troubleshooting documents.
m
0
l
!