Sign in with
Sign up | Sign in
Your question

Multiple internet connections without NAT

Last response: in Networking
Share
December 24, 2012 3:52:24 AM

Hi, i'm trying to setup multiple internet connections however the ISP i am using doesnt allow the use of NAT. DHCP and uses the registered mac address as a way to authenticate the account. To compensate for no NAT i use a web proxy feature on my router.

my router is a mikrotik routerboard 450G.
network setup:
first line: laptop )))) wireless router as bridge ------ switch ----- wall socket to ISP
second line: laptop ---- routerboard =====switch------ wall socket to ISP

I would like to load balance both the connections on the routerboard without using any NAT. I have confirmed that the router has access to internet and the web proxy doesnt support every web feature. I also have trouble trying to use both network at the same time.

I would like to setup windows 7 to be able to use both networks at the same time but for different things while also setting the router to use both gateways at the same time. I have tried testing using torrent by downloading a linux DVD image by trying to get utorrent to use a http proxy but i havent seen any results so far.

Is there a way to go about doing this? I want to simultaneously use all 3 accounts, not redundancy. However there isnt a tutorial of doing this without using NAT.

Thanks.
December 27, 2012 7:08:03 PM

First, do you actually have three separate services, or one service for up to three devices?

If you actually have just one service, then simply pick a MAC address from one of your laptops and program that into the router. You can then use NAT and your ISP should not care.

If you do have three separate services, then you are out of luck because Windows can only use one default gateway at a time, so you cannot use all three simultaneously with a load balancing router that has three WAN inputs.
December 27, 2012 7:42:40 PM

i just found that you can in windows 7. Its 3 services from the same ISP and even if the router has the registered mac address NAT doesnt work. I've also tried changing the TTLs but it seems that my ISP inspects packets. In windows 7 you just have to modify the value of each path so that their route value ends up being equal.
!