Sign in with
Sign up | Sign in
Your question

[SOLVED] MSI/Installshield Permissions Issues

Last response: in Windows 8
Share
February 22, 2013 9:01:05 PM

UPDATE: Running the SFC once more seems to have fixed this issue, however, I would be pleased if the techs here leave this open for the time being and left as [UNSOLVED] in the event the issue arises again. I'd give it 3-5 days, and if I haven't seen the issue again, I will mark as solved.

UPDATE 2: While the SFC operation fixed the problem, it also allowed me to install A/V (ESET). ESET detected 6 malicious malwares (including 2 toolbars) that according to the files creation dates, infected my system only 11 minutes after the install of Windows 8, that's ridiculous, but that's probably what made the cookie crumble. Anyways, I did a full scan with ESET, Malwarebytes and ComboFix just to be safe and all seems well now. Marking the thread as solved.

Quote:
Well, I've been spending the better part of the last six hours trying to figure it out; and to be honest. I can't.
I just installed a fresh install of Windows 8 Pro WMC this morning, ran windows update, installed my applications, those that I could, and ran into problems with:

- Diskeeper 12
- ESET Smart Security
- Games for Windows Live
- Google Drive
- iTunes
- Skype
- Steam

These following applications all received "Insufficient Privileges" errors when trying to copy data to /ProgramData/Microsoft/Windows/Start Menu or to /ProgramData/%AppName%

-------------------------------------------------------------

- I am on an account with administrative perms.
- I have disabled UAC and all AV/Firewalls and Windows Defender.
- I have clicked "Run as admin."
- I have logged into the admin account and attemped install.
- I have tried using Shift + Right-click and click "Run as different user" and use the admin account.
- I have tried Troubleshoot Compatibility.
- I have tried Taking Ownership.
- I have tried Security > Edit Permissions > Full Control on SYSTEM, Admins and Everyone.
- I have tried Safe Mode.
- I have ran CHKDISK.
- I have ran System File Checker (SFC).

None of these above options have remedied the problem. When I chose to edit the security permissions I got two different messages,

"The access control list (ACL) structure is invalid"

"Failed to enumerate objects in the container. Access is denied"

Any help at this point would be GREATLY appreciated.
February 22, 2013 10:29:04 PM

Hi,

Have you tried doing these installs before running windows updates to see if it is one of those causing the problem? I found another thread where users said that a windows update changed file permissions so they could not delete a folder on the c drive. This thread has a few ideas you can try, one user had luck with a program called unlocker to take ownership of the folders, hope it helps :

http://answers.microsoft.com/en-us/windows/forum/window...
m
0
l
!