HDMI sound issue

Hello,

I have a PC (Windows 7 x64) with a ati radion 5750 graphics card.
My computer and my cable are connected to an LG 42" flat panel hdtv through separate HDMI ports.

If I'm using my computer and decide to switch to watching cable I simply hit a button on my remote.

NOW... If I switch back to my computer (which is still on), the sound has been disabled.

I have ALL current updates both with "Microsoft" and "ATI".

If I go to "playback devices" the section HDMI does NOT offer a "default" selection but "speakers" and "Digital Audio (S/PDIF)" do.

This issue started a month or so ago and I'm hoping someone can assist me with a remedy.

I'll provide other info if needed.

Thank you

PS: speakers and Digital Audio are disabled
6 answers Last reply
More about hdmi sound issue
  1. When you installed the ATI drivers, did you do a custom install or a normal install? If you did a custom install make sure to include the HD Audio drivers. Other than that, not sure what it could be.
  2. Hawkeye22 said:
    When you installed the ATI drivers, did you do a custom install or a normal install? If you did a custom install make sure to include the HD Audio drivers. Other than that, not sure what it could be.


    I custom installed and made sure to ad the hdmi files. In fact I always custom install everything when asked. (I don't care for desktop shortcuts) lol.
    I think this thread may be mute. Seems to be (from what I could find out) a driver issue. "Handshakes" etc...

    Thanks for your response though.
  3. This seems to be a driver issue. I have a similar issue with my 7950. If I turn off my TV or switch inputs the sound gets disabled and I have to restart to get it going, or manually uninstall and re-install the drivers.

    However it doesn't seem to happen all the time.

    Currently using 12.4

    Actually there's been a few posts about this, IDK hopefully 12.5 fixes it.
  4. Heres a link:

    http://devgurus.amd.com/thread/159106

    Apparently 12.3 works better.
  5. The thread isn't mute, your audio was! Ha. Ha. Ha...
  6. Well... I Uninstalled my graphics drivers and installed "12-3_vista_win7_64_dd_ccc.exe"

    So far so good. (crossing fingers)
Ask a new question

Read More

Configuration Computers HDMI Windows 7