Sign in with
Sign up | Sign in
Your question

Trouble with Remote Desktop

Last response: in Windows 7
Share
May 23, 2012 2:06:48 PM

I'm having trouble with my remote desktop since I moved into a new house and I don't know where else to turn. I'm running CenturyLink and I first tried it with the Actiontec Q1000 modem/router combination. I set up port forwarding to both of the computers I use for RDP. One is set for port 3389 and the other for port 3390. Remote Desktop worked over the LAN, but would not work over WAN. Tried turning UPnP off, modem firewall off, even tried setting one of the computers in DMZ mode which wouldn't work either. ISP isn't blocking the port as www.canyouseeme.com was able to see both of them.

So after I couldn't get that modem router to work I went out and bought a Belkin N600 straight up router. I set the modem into bridge mode and hooked up the router to that. Confirmed local computer IP's through both DHCP and Ipconfig and forwarded the correct ports to the correct IP. Turned off router firewall. (Windows Firewall has been off this whole time as well). Restored both modem and router to factory settings and started over. Still would not work. Tried turning off UPnP again. Power cycled modem and router and restarted computers. Turned off port forwarding and set a computer in DMZ. DMZ again wouldn't take effect.


So I'm out of ideas with this one. It worked fine before I moved, but there is something stopping it now and I have no idea what. Any ideas would be appreciated.

More about : trouble remote desktop

a b $ Windows 7
May 23, 2012 2:09:42 PM

when using remote desktop make sure you have set a password. windows will not let you make the connection without it
m
0
l
May 23, 2012 2:14:20 PM

Yeah, password is set on both computers. RDP works fine over LAN.
m
0
l
Related resources
May 23, 2012 2:23:30 PM

interesting issue. I know it may be a silly question but your computers aren't going into sleep mode are they? also where are you attempting to establish a rdc connection from? I would also try to specify the port number when entering your connection ip

ex.
192.168.0.50:3389 or 3390
m
0
l
May 23, 2012 2:53:29 PM

No, I have sleep mode disabled. I've tried connecting to the 3389 computer from the 3390 computer over the WAN and vice versa. I've even remotely logged into a computer at work and then tried RDPing from that (different WAN that way). The 3390 has to have the port at the end since the RDP default is 3389: 35.535.214.234:3390 which fails or via LAN 192.168.2.2:3390 which works fine (From the 3389 computer). I've tried the 3389 both ways: 35.535.214.234:3389 and just straight 35.535.214.234. They both fail. 192.168.2.5 and 192.168.2.5:3389 works fine.

Note: I just made up numbers for the WAN IP
m
0
l
May 23, 2012 2:54:23 PM

I should note that I can ping my WAN IP and I can even remotely access the Router GUI
m
0
l
a c 229 $ Windows 7
May 23, 2012 3:01:08 PM

I'd temporarily set RDP to Allow Connections From Computers Running Any Version Of Remote Desktop and see if that helps. If it does, you may need to upgrade your RDP client.
m
0
l
May 23, 2012 3:03:40 PM

Yeah, I have it set to that. All running RDP 7.0. All users are also allowed RDP acess.
m
0
l
May 23, 2012 3:35:36 PM

One interesting thing is that if I use the correct destination I get the "Could not connect" error immediately after hitting connect. If I use a gibberish IP it times out before saying it can't connect. So it's like it can hit the router fine, but the ports aren't being forwarded.
m
0
l
!