Sign in with
Sign up | Sign in
Your question

Toshiba Satellite l875 internet connection problem

Last response: in Wireless Networking
Share
November 17, 2012 1:14:03 PM

Hello, I recently purchased the computer and I am having difficulty maintaining a good internet connection. I have unchecked the power saver boxes and installed Firefox thinking that IE was the problem but no real change. It is pretty bad using just wireless and not much better with the ethernet. I was able to hold a connection long enough to perform a download test and the results were 24mbps dowload so the provider (Comcast) does not seem to be the problem. Windows 7....Realtek RTL8188CE 802.11n...Zoom 5350 modem/router. Any help would be appreciated as I am about to throw this computer out of a window...thanks
November 18, 2012 3:34:15 AM

If you go to the support web page and enter in your model number you can find out if you have the most current driver for the network card/chip that's in the laptop.
m
0
l
November 18, 2012 4:03:27 PM

If it seems to be having issues both wired and wireless then it may just be a problem with the modem/router. Try disconnecting it from power AND the coaxial cable, wait a couple minutes then plug it all back in and wait another couple minutes for it to fully power up. Then try wireless or wired with laptop.

If that makes no difference, call Comcast and have them test your line... even though you managed to do a speed test, you may be getting an intermittent signal from Comcast and they will need to do something.
m
0
l
Related resources
November 19, 2012 12:58:11 AM

Thank you for your responses. I believe the problem has been corrected. It seems that it was spyware or a virus (bitcoinmapper). My anti-virus software was probably turned off for a few days without my knowledge (probably one of my wonderful kids). I ran 2 scans and after a little more tinkering I was up and running. Once again I do appreciate the help and I am sure I will be back here in the future.
m
0
l
November 19, 2012 1:01:40 AM

Good to hear that your issue has been solved.
m
0
l
!