Sign in with
Sign up | Sign in
Your question

Router SSID shows different name on phone and wont connect

Last response: in Wireless Networking
Share
November 18, 2012 6:12:24 PM

the router is a N Wireless Router

When I try to connect to my router through my phone the SSID appears as belkin.2lc and it won't connect but says authorizing then disconnected. The weird thing is that my laptop and all my roommates laptops and my Xbox can all see the routers real SSID and connect.just fine.

I've tried restarting the router and my phone. I've also checked my router settings and made sure their is no MAC address enabled.

idk what else to try
November 18, 2012 7:36:34 PM

If the name is not the Belkin 2lc then what is it ? Is your phone seeing someone elses router ? Have you put in the network password for your network in the phone ? The router that you have does it see the phones mac address ? I would take and enter in manualy the phones mac address into the router's list of accepted devices.
m
0
l
November 18, 2012 11:09:24 PM

The network is called KASO Network. Its possible that its seeing someone else's router but i never saw belkin 2lc until my phone stopped connecting to the router.

In order for me to enter my phones MAC address into the router's settings it says I would have to do that for all devices as well. Although thats possible it would be very inconvenient if friends come over and stuff.
m
0
l
Related resources
November 18, 2012 11:34:24 PM

Just to clear some things up,

If your network's SSID is "KASO Network" then any other SSID is most definitely not yours. Wireless devices pick up signals from anywhere within range, so its very common and likely that your phone will pick up different SSID.

You said you checked your "router settings and made sure there is no MAC address enabled." This doesn't make sense. I'm going to assume you meant to say there was no MAC filtering enabled. If that is true then you do not have to enter a MAC address into the router. If MAC filtering were enabled you would need to do so, but with it disabled this is definitely not necessary.

Enter the correct SSID manually into the phone, along with the password. It sounds like you may have SSID broadcasting turned off.
m
0
l
November 18, 2012 11:45:58 PM

Actually I might be wrong. Because even when my phone is 1 inch away from the router the signal for Belkin.2lc is only 2/5 bars. So that means my phone isnt seeing my router whatsoever...
m
0
l
November 18, 2012 11:47:02 PM

skaz said:
It sounds like you may have SSID broadcasting turned off.


m
0
l
November 18, 2012 11:47:29 PM

skaz said:
Just to clear some things up,

If your network's SSID is "KASO Network" then any other SSID is most definitely not yours. Wireless devices pick up signals from anywhere within range, so its very common and likely that your phone will pick up different SSID.

You said you checked your "router settings and made sure there is no MAC address enabled." This doesn't make sense. I'm going to assume you meant to say there was no MAC filtering enabled. If that is true then you do not have to enter a MAC address into the router. If MAC filtering were enabled you would need to do so, but with it disabled this is definitely not necessary.

Enter the correct SSID manually into the phone, along with the password. It sounds like you may have SSID broadcasting turned off.


I turned SSID Broadcasting off yesterday and it messed a bunch of stuff up so I turned in back on. Now all my devices can connect to it except my phone which doesnt even see the network
m
0
l
November 18, 2012 11:48:14 PM

skaz said:
Enter the correct SSID manually into the phone, along with the password.

m
0
l
November 18, 2012 11:58:41 PM

I have numerous times. It goes into managed networks but it says "Not Detected"
m
0
l
November 19, 2012 12:03:11 AM

When I was having a similar problem with my wifes laptop not connecting or seeing the router I went into the routers settings and there was a page that had all the devices Mac address listed that were connected to the router and the laptop for whatever reason was not there. What I did was enter it in manually and it didn't affect any thing except tha now the laptop was able to see and connect to the router. All routers are just a little different from each other and that's what worked in my situation.
Do you have the homegroup password ? Are you able to enter it into the phone ?
m
0
l
November 19, 2012 12:07:53 AM

I just checked and I do not have a Homegroup password.
m
0
l
November 19, 2012 12:19:41 AM

Go to the control panel / Network and Internet / Homegroup / Print and view Homegroup password , you don't need to print it but you do need to write it down and enter it into the phone to connect to the homegroup. The homegroup is the network that you have set up in your home with the wireless router and the various computers and devices.
m
0
l
November 19, 2012 12:20:49 AM

The option to "Print and view Homegroup password" is greyed out
m
0
l
November 19, 2012 12:28:15 AM

Ok , that's not good , what way did you set up your network ?
m
0
l
November 19, 2012 12:29:07 AM

my network as in my router? because thats what im trying to connect my phone to is my router. not the windows network
m
0
l
November 19, 2012 12:39:57 AM

I know that but when you set up a network you use the computer to do that and once the network is set up there is a password created that each device has it stored on it for it to access the network and that location is where it's stored on your computer and each device connected to the network will have that same password. I was not telling you to connect to your computer just see what the password is.
m
0
l
November 19, 2012 1:45:16 AM

When I want to see the password for my network i just right click on it and select properties. Ive never had to use a windows network password to connect to a network
m
0
l
!