Win 7 missing pagefile sys

my pagefile.sys is missing, there si no pagefile on the C drive, not a hidden file, regedit will not hold a pagefile setting, manually set the pagefile don't hold in the advance tab. would reloading window 7 correct this problem.
5 answers Last reply
More about missing pagefile
  1. Are you basing this on looking at the drive itself?

    What are the pagefile settings for the system:

    Start -> Right-Click "Computer" -> Properties
    Click "Advanced System Settings"
    Click "Advanced" tab
    In the "Performance" section, click the "Settings..." button.
    In the "Performance Options" dialogue, click the "Advanced" tab
    In the Virtual Memory section, click the "Change..." button.

    If the pagefile is really completely disabled, it should look something like this:



    To set up a pagefile, click one of the disk names to select it, then click "System Managed Size" or click "Custom Size" and enter the minimum and maximum sizes.

    Important note: You must click the "Set" button! If you just click OK the settings will not be applied. This has tripped me up several times.
  2. i have tried system Managed size and set buttom, check the regedit and manual set pagefile (pagingfile.sys 4096 4096) an i restart the computer the allocation is back at 0. i have check the administrator permission for the machine.
  3. Very strange. Does the pagefile actually get created (i.e., after you set the pagefile size, can you see it in the root directory before you reboot)?
  4. Have you tried checking to ensure that System and Administrator accounts have the proper permissions on the drive?

    Check out this KB article -> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315270&fr=1

    It's old (from December of 2007), but it might help you out. It applied to XP but you might be able to still fix your problems.

    You might also want to try running an elevated command prompt as administrator and run the following command if you have the Windows Audio File System installed:

    sc config afs start= disabled

    Read here for more info -> http://social.technet.microsoft.com/Forums/en-US/w7itproperf/thread/c5cfe9d0-e3d8-4625-85b1-3efdf04cd1a0
  5. isamuelson said:
    Have you tried checking to ensure that System and Administrator accounts have the proper permissions on the drive?

    Check out this KB article -> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315270&fr=1

    It's old (from December of 2007), but it might help you out. It applied to XP but you might be able to still fix your problems.

    You might also want to try running an elevated command prompt as administrator and run the following command if you have the Windows Audio File System installed:

    sc config afs start= disabled

    Read here for more info -> http://social.technet.microsoft.com/Forums/en-US/w7itproperf/thread/c5cfe9d0-e3d8-4625-85b1-3efdf04cd1a0



    when windows start it says the a temporary paging file was created because there was an error at windows startup.
Ask a new question

Read More

Pagefile Regedit Windows 7