Sign in with
Sign up | Sign in
Your question

Troubles booting to raid-0 array

Last response: in Storage
Share
December 23, 2002 10:44:10 PM

Per Hammerbot’s suggestion here is my new thread:

Here are the basics:

MSI k7t266 pro2-ru mobo w/Promise fastrack 100 “lite” (with all the latest drivers from the MSI site for my board).

13 gig quantum HD on IDE (ATA-100)

80gig Raid-0 array:
w/ 1- 40gig western digital and 1- 40gig IBM
The west. Dig. I had on hand and I got the IBM real cheap, other wise I would have gotten a set of matching drives.

AMD XP 2100
512 megs ram
TDK CD-RW
GeForce3 vid card.


I can’t get XP pro to boot to my raid-0 array. I have the array defined and can “see” and use it if I boot to the 13 gig quantum of regular IDE (I formatted it from there).
I boot up with the XP cd and load the drivers from the floppy and they see to load fine. I tell XP to install to the raid partition and it gets all the way to windows “installing drivers” portion of the install/setup and it gives a warning about using unsigned software, It doesn’t say the name of the software but I pretty sure it is the fastrack drivers. If I tell it to use the unnamed software another box comes up in a few minutes that asks me if want to use the unsigned fastrack drivers (this time it specifies the fastrack drivers by name). I click yes and the install seems to go fine. My system will then get into an infinite boot loop where it will get to the XP “loading” window then reboot. I compared the to boot drives and the fastrack files are on both.
If I say no to the unnamed software in the first popup then it won’t ask me if I want to use the fastrack drivers and I will, within a few seconds get errors about not being able to continue with the installation because none of the other drivers would load on the hd.

It seems like the drivers aren’t compatible with XP or I am not supposed to boot directly to the raid-0 array with my on-board raid.

Any help would be appreciated,
Ed
December 24, 2002 12:36:58 AM

Are you overclocked, like fast ram settings?

Some hardware specs of your system may help us.

Go into the Raid Bios Ctrl+H at startup and check everything is in order, I dunno about the lite but you may be able to set the drives up in there, is that where you mean it is defined?

<A HREF="http://forums.btvillarin.com/viewtopic.php?t=326" target="_new"> Scotty's Toys</A> :smile:
December 24, 2002 2:25:37 AM

Yes Scotty it is defined in the raid bios setup page (useing ctrl+F)
My clock settings are all default.

If I try to start in "safe mode" I get the following just before the automatic reboot:

system32\ntoskrnl.exe
hal.dll
bootvid.dll
config\system
c_1252.nls
c_437.nls
c_intl.nls
appatch\drvers\acpi.sys
wmilib.sys
isapnp.sys
viaide.sys
pciidex.sys
mountmgr.sys
ftdisk.sys
dmload.sys
dmi.sys
partmgr.sys
volsnap.sys
atpl.sys
fasttrack.sys
scsiport.sys
disk.sys
classpnp.sys
sr.sys
dmboot.sys
ksecdd.sys
ntfs.sys
ndis.sys
viaagp.sys
mup.sys

Then it starts all over.
Related resources
December 24, 2002 11:59:54 AM

What drive actually boots in your 'infinite boot loop'??? The CD or the RAID array?
If the RAID array boots you may have a driver conflict problem. Check for the latest drivers, or try one of the older ones.
If the CD boots. Try removing the CD. Post what happens.
Also I suggest you try run <A HREF="http://www.memtest86.com" target="_new">memtest</A> just to make sure you dont have a memory problem.

<i><b>Engineering is the fine art of making what you want from things you can get</b></i>
<A HREF="http://www.btvillarin.com/phpBB/viewtopic.php?t=655" target="_new">My systems</A>
December 24, 2002 6:41:20 PM

Thanks Hammerbot,
I got the "loop" booting from the array.
I've tried both versions of the drivers and no luck.
The array is getting worse, I can't even access it or format it when I boot to my regular IDE drive (I can still "see" it and the bios says it is still "fuctional").
I'll try the memtest and rebuild the array to see what happens.
January 16, 2003 1:14:46 AM

Finaly got the problem fixed. It turned out to be my GeForce3 Ti200 Vid card from Visiontech. I upgraded to a G4 ti4200. The card (Ti200) works fine otherwise but there is some sort of conflict between it and the raid controller.
I had tried a PCI raid controller, different; CPU, memory, and hard drive configurations with no luck. I kept getting bad information written to the hard drives even though they checked out fine.

All is fine now, I hope maybe this info will help somebody else in the future.
Ed
July 6, 2003 12:11:10 AM

[note: hardware details on the bottom of this post]

I got the same problem... But also a bit different.
While trying to install 2 drives on the onboard promise fasttrack 376, I shortly could see that the fasttrack hat listed my scsi drive in his drive list!!
After I realized that this onboard-raid-controller is a piece of sh*t, i removed it and set every configuration back.
But now windows can't boot fully anymore.
While loading the scsi-drive is too quiet... it dows nearly nothing. and after 30 seconds or so xp simply does a reset.
Even the command-line-mode does not work anymore...

I moved the scsi-controller to another computer (my old pc wich had it for more than 3 years) as secondary drive, but now the pc is incredibly slow and i can't access the drive because the explorer crashes. (hangs/works ultra-hyper-slow)
I got chkdsk to work on the drive. (params: /f /r /x).
but after 25% it stopped with a irreparable error.

Then I used the tool in the scsi-controller-bios to check the whole hd. It says the drive is error free.

I would really PAY for an answer, because I have valuable data on the disc. Many programming/music/web-projects, my whole mail-archive of the last 3 years, many irreplaceable private things and... just everything!

BTW.: Does anyone know how to set up 2 parallel ata udma133 drives on a promise fasttrack 376 controller?

=== hardware details: ===
--- problem-relevant ---
mainboard: chaintech 7njs zenith (with promise fasttrack 376 onboard)
scsi: adaptec 2940u2w (ultra 2 wide, with attached idm drvs09v 8 gb hd) [the valuable one]
ide: 2 x maxtor diamondmax 9 plus (120 gb each) (the ones that should/will go into a raid. but attention: each drive has 56mb/s tested transfer date!! So together there MUST be U6 to deliver full performance! anyone an idea how to realize that with the fasttrack-raid thing?)
+ 1x ibm dlta-307030
--- others ---
cpu: amd athlon xp 3000+
memory: corsair twinx-512 (pc333 512mb)
graphics: sapphire radeon 9800 pro
sound: soundblaster audigy platinum
tv: hauppauge wintv pci-fm
isdn: avm fritz pci
dvd: pioneer 16x dvd-rom
cd: mitsumi 4809te (24x cd-r / 8x cdrw)
usb: logitech mx-700 mouse + 7 misc devices
July 6, 2003 1:46:50 AM

Have you tried reloading Windows? It can be done without losing any of your data. Boot from the CD like normal, and then (ignoring the option to repair windows) attempt to do a new installation. XP will search for previously installed versions of windows. When it detects your current setup it will give you the option to repair it, overwrite it, or install in a different partition. By clicking repair, it will re-install Windows XP to it's basic configurations & settings without reformatting or losing any of your programs or data. You will only have to re-install updates, service packs, and current drivers. -Hope this helps.

<A HREF="http://www.rebturtle.com" target="_new">rebturtle</A>
<A HREF="http://www.rebturtle.com/turtletech.htm" target="_new">My System</A>
July 8, 2003 6:14:36 PM

The problem is worse.
I added the drive to another computer (incl. scsi-controller-card), and from then this computer was so slow, that it half an hour just to boot windows. then i logged in... another 15 minutes. nor explorer to go to the drive... well... it crashes... or just is so slow that i maybe can wait for hours just to do the next click....
i already tried to go via command-line to be quicker. (windowed command-line)
But after changing to that drive i hat to wait 10 minutes to get an error that ther is an internal i/o-error...
(as i said: chkdsk tells me after 25% it's buggy)
seems like the filesystem is damaged.
does anyone know a GOOD ntfs-repair-tool?

thank you, and everyone who can help me...
!