Sign in with
Sign up | Sign in
Your question

BSOD at boot, Catroot2 Integrity SOLVED

Last response: in Windows 7
Share
May 27, 2012 2:32:57 PM

I had my computer off for a few weeks and when I went to boot, it went to BSOD during process. Startup repair did nothing. Could not boot into safe mode. When I tried safe mode it went into the classpnp.sys loop.

In "researching" many suggested that it was corruption of the root catalog and gave instructions on how to wipe and recreate it...but I did not have a copy from another safe computer, only my WIndows 7 disk.

I have a full backup done with Paragon (not as recent as I'd like) and my documents/etc are for the most part on another drive. Using Paragon I copied my PST file and the few items on the C drive that were recent creations, so they are safe.

I reinstalled Wiindows and it booted fine. I then restored the C drive to a backup from 2/12/2012 and immediately had the same problem.

So my question: I can exclude files/directories from the restore. Should I exclude the Catroot2 directory, or System32, and see if that changes the outcome? I have reinstalled Windows and am looking how to proceed.

Thanks,
Art

i5-2405S
16gb OCZ DDR1600
OCZ Agility 3 120gb boot drive (and no problems)
GTX 550i video
Windows 7 Home Premium 64 bit
a b $ Windows 7
May 27, 2012 6:44:26 PM

Why not do a repair installation instead, which will clear out the old Windows install (and require you to do all the updates again) but will not wipe out your programs or documents? Just start from your Windows 7 disk and select repair install when you get to that option.

And as always with these things I would run Memtest86+ to insure that a memory issue was not responsible for a file corruption: http://www.memtest.org/
m
0
l
May 28, 2012 3:24:22 AM

I did...and got the message that Windows had fixed the problem, but it was still there.

The clean installation of Windows works. Now to see if restoring my backup, but skipping either c:\windows\system32\catroot2 and leaving it as installed fresh will do it.

if not I may break down and bring to a trusted repair center.

As for memtest86, did that on each stick individually and they passed/no errors in their original slots. Did not try them in the other channel.

Thanks.
m
0
l
Related resources
May 31, 2012 12:20:37 AM

Problem solved: BIOS had reset somehow so drives were in IDE mode, no longer AHCI. Resetting to AHCI cleared it up. I am still not thrilled as I do not know why I got the BSOD in IDE mode, but at least I am running again.

Thanks,
Art

i5-2405S
16gb OCZ DDR1600
OCZ Agility 3 120gb boot drive (and no problems)
GTX 550i video
Windows 7 Home Premium 64 bit[/quotemsg]
m
0
l
a b $ Windows 7
May 31, 2012 2:07:31 AM

Doh, in hindsight the answer is so obvious that I could just kick myself!

But why are you in IDE mode with an SSD. Change to AHCI, which is very easy by changing only one registry key and then restart and during the restart change your bios to AHCI sata mode:

Just open regedit by typing that in the start menu search box and then running.

Navigate to this registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

Change the "Start" key in msahci registry keys to 0 -- and then click OK, then reboot and immediately change to AHCI in the bios. All that entire change does is instruct Win7 to load the msahci.sys driver at startup, which enables AHCI.
m
0
l
May 31, 2012 2:23:40 AM

I changed to AHCI already in BIOS...is this a better solution because it forces Windows 7 to set things to AHCI each time it boots? That is what I think you are saying.

I hadn't set it to IDE; been running only in AHCI mode.

Interesting, I put a Patriot in my mom's Athlon 64 x 2...she wanted faster boot (getting impatient at 85) but did not want to go with a new machine...and that HP did not recognize the drive, at all, except in IDE mode.

I will make the registry change...please let me know if I am understanding that this is a way to fix things if the BIOS hiccoughs.

The MB is the ASRock P67 Extreme4, which I am happy enough with for the time being.
m
0
l
May 31, 2012 2:27:45 AM

I went to the Registry and it was already set as directed.

I've had a few times when this MB has "lost" the SSD, etc., so I'll chalk it up to that.
m
0
l
a b $ Windows 7
May 31, 2012 2:33:13 AM

AH, I understood you the other way -- makes sense that the bios would revert to IDE if there was some weird issue.

Not exactly what I was saying so here it is, when the bios starts in AHCI mode Windows then expects to see the msahci.sys driver -- but that only loads if Windows was installed with the bios set to AHCI or if you make the registry change that I describe. Absent that there is no driver that will work and your BSOD appears.

AMD has its own AHCI driver and I have not done any upgrades using any registry key changes although I would expect that you could do so. AFAIK, the MS AHCI driver is more stable than the AMD and I would use it as my first choice.

I always find that it is best to leave Mom's computer alone as long as she is happy. My Mom is 78 and I build her computers but fortunately my brother (an Intel engineer) lives nearby her and fixes her issues via remote desktop.
m
0
l
!