Sign in with
Sign up | Sign in
Your question

Setting up EFI - GPT based RAID 0 Setup. Stuck in windows install loop

Last response: in Windows 7
Share
May 28, 2012 10:09:42 AM

Greetings:

Motherboard: AsRock Extreme 4 : Click On Me For Asrock site
Hard disks: Three 1TB Western Digitals.

Motherboard settings for storage: Located in- Advanced --> Storage Configuration
-SATA Controller- Enabled
-SATA MODE- RAID MODE
-Onboard RAID 3Tb+ Unlocker- UEFI Mode for GPT Partition
-SATA IDE Combined Mode- Disabled
-Marvell SATA3 Operation Mode- AHCI Mode
------Marvell SATA3 Bootable
Onboard IDE & 1394 Controller- Disabled.

I'm in the progress of attempting to install windows 7 64bit with sp1 streamed in to the disk- to a RAID 0 Configuration of 3 1TB hard disks.

At this point I've already created the Logical array in the EFI bios (if you will). And confirmed that the drive is equal to the 3tb!

And I'm attempting to install Windows right now. But it seems every time I create the three partitions, after I load the RAID Driver, - explained in this guide here : Click Me! -

Type Diskpart, press Enter.
Type List Disk , press Enter.
Type Select Disk # (where # is the number your drive shows up as), press Enter.
Type Clean, press Enter.
Type Convert GPT, press Enter.
Type Create Partition EFI Size=100, press Enter.
Type Format Quick FS=FAT32, press Enter.
Type Create Partition MSR Size=128, press Enter.
Type Create Partition Primary Align=4096, press Enter.
Type Format Quick FS=NTFS, press Enter.
Type Exit, press Enter.

After I've formatted and click on the last partition to install... The system does give me a yellow flag on parition3 which is 2793.7 GB- Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu. (which it is, see above)

I can select the partition (3) and hit next to start installing. Windows installs and restarts. Goes threw copying windows file- expanding windows files - and then quickly goes threw installing features, updates, and completing install- then reboots.

It restarts back in to setup - and wants me to start all over. If I attempt to boot the Windows Boot Manager using the boot manager (F11)- Two things either happen: I get taken back to the AsRock UEFI Setup Utility (BIOS) or I get taken to a black screen with a boot:


I've tried using a different version of Windows 7- a clean version with out Sp1 - no effect.
I've completely formatted each drive using Linux. - no effect

Any help would be awesome!
Anonymous
a b $ Windows 7
May 28, 2012 10:25:26 AM

remove the installation CD and set your HD as the first boot drive(?)
m
0
l
May 28, 2012 7:22:23 PM

Thank you for your reply.

But because of the EFI BOIS you can't just select the hard disk or the RAID Array by it self.

When I go in to the boot order/options, I have two choices, Built-in EFI Shell and Windows Boot Manager.

I have Windows Boot Manger selected but it does not continue installation. It goes straight to the AsRock Uefi Setup Utility meaning it A. Can't find the boot partition. B. No data was written. C. Windows just sucks?

I have noticed that even after the expanding on Windows Files- there should be data on the drive. But when you enter setup again, there is only 1-2 Gb being filled. I'm not sure what going on or what I'm doing wrong.

Added: The drive partition has about 5-7GB used so the data is being written to the array.
m
0
l
Related resources
June 20, 2012 1:20:29 AM

I have the same mobo and it was a beast to figure out (took me weeks of working on it after school, before work and while my daughter was at the baby sitters) but I finally got it. I ran a solid state drive for my OS (windows 7 ultimate 64bit) and RAID 10 for my storage. Currently changing to RAID 0 with a third for backup only. Plus second backup on an external drive.

First: Asrock customer service sucks (don't bother, trust me; they told me that,
Quote:
It is impossible to run any RAID for storage only. You always must have your Operating System on your RAID drive.
). That is BS and I finally figured it out. They also said,
Quote:
Just open every folder, sub folder and click every driver you come across till you find the right driver for RAID.
They couldn't even point me to the folder that held the driver I needed....WTF!!!

But I digress......

Second: For what I was doing I had to put my blu-ray burner and ssd on sata ports 7 & 8, for it to work. Turns out the RAID drives must be on sata ports 1-6 seperate from everything else.

Next: Enter bios---->Advanced ----> Storage Configuration
-SATA Controller- Enabled
-SATA MODE- RAID MODE
-Onboard RAID 3Tb+ Unlocker-set to MBR (because from what I read that is only if your drive will see 3TB+ after you set up
RAID, which what you are doing shouldn't see that much)
-SATA IDE Combined Mode- Enabled
-Marvell SATA3 Operation Mode- IDE Mode
---Marvell SATA3 Bootable
-Onboard IDE & 1394 Controller- Disabled
-Save and exit

Then: Load drivers from motherboard disk
-All in One

Now: Load Windows

Once in windows I had to right click my computer---->manage----->disk managment
It should see your RAID set. Set it as a new simple drive----->basic drive

That should be it.......if not you can message me back and I'll double check all my settings.

If that doesn't work open the asrock cd and look for

-AMD64 folder----->Win7_Vista64_AMD_3.2.1540.35------->ahcix64s.msi

You may need to first locate and run one or more of three different .exe files

-Drivers--->ALL in 1--->AMD--->Win7-64_Win7_Vista64_Vista(8.70a_WHQL)--->Bin64--->ATISetup.exe and/or
InstallManagerApp.exe and/or Setup.exe

I hope this helps since no one was able to help me when I did it. :D 
m
0
l
June 20, 2012 3:36:12 AM

Thank you for your post!!!!!

I will give this a try... I've actually after all this time still waiting for Asrock Cust. Service to send me an email or call me.. Still nothing... Plus I'm been working 80 hrs or something a week. So you can figure that I'm dead tired all the time.

Thank you,
Kyle
m
0
l
!