Sign in with
Sign up | Sign in
Your question

"Local Area Connection" doesn't have a valid IP configuration

Last response: in Networking
Share
January 13, 2013 12:53:18 PM

I lIke many other have had a problem similar to others . I has occured when i was adding a storage device to my network. I use a cisco Network Magic . It had stated that my PC was not coonected to network and when ihit repair it lost me my interent connection entirely.

Upon looking at Config i get the following

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Gawaine2>IPconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::c40e:ef1b:25e3:214e%10
Autoconfiguration IPv4 Address. . : 169.254.33.78
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Tunnel adapter isatap.{D89C332B-5F8B-4006-97A5-EE5501D5C27F}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix


In addtion I have tried manually setting my IP address in ipV4 and have since restored to Automatic setting of IP address. I have tried a host of forum fixes with no joy.
January 13, 2013 1:36:16 PM

In your network control panel do you have an unidentified public network or a home network or nothing?
January 13, 2013 2:56:29 PM

Hello ,
i have an unidentified public network. All other devices ( 3 pc's and an Xbox and wireless all working fine by the way)
Related resources
January 13, 2013 3:07:04 PM

You need to change that to a home or work network to match the others. If the unidentified is the only one, change it to a home network rather than public. If you cannot do that just by clicking on the network icon and change it then you have to change the Windows setting for network security, like this:

In the start button search box type: local security policy and then open the one that shows at the top of the start box, click on network list manager policies, double click unidentified network and change it to Location type: private and User permissions: user can change location, apply, then okay. Reboot.

Now open the network control panel and change the public to a home network and check that you have the adapter configured to automatically obtain an IP address from the gateway (network control panel, change adapter settings, right click select properties, highlight Internet Protocol Version 4, Properties button). Now if you do not connect, open the command prompt box and type ipconfig /release and then ipconfig /renew.
January 13, 2013 4:33:18 PM


Thanks so muh for the reply
I was unable to change anything by clicking on network icon.
I then typed in the search box as instructed. However i only got a list of web pages up when i typed in local security policy. Is there another way of getting into the newtowrk list manager?
January 13, 2013 5:01:31 PM

Odd that the start button search (run) line does that, but you can also get to it by opening the help and support button in the start button, then search for local security policy, select the first item (Change password policy settings) and it will open to some text that has a link to open the local security policy. Then click on the Network List Manager Policies and the Unidentified Networks on the right. There you make the changes and apply them.
January 13, 2013 5:09:48 PM

Ok
I went into windows help and support
Typed in "local security policy"
Long list
1) How to change behaviour of User account by using group policy
2) Changing intranet securty settings
2) User groups in windows
4) Add a user account
5) Change Internet Exploer Securty settings
etc etc
are any of these the right option.
Thanks again for you guidance
January 13, 2013 5:16:43 PM

LOL, okay instead type secpol.msc in the start button run (search) window. Then click on the program up above called secpol
January 13, 2013 5:34:26 PM

hmmm vexing
I tried that . It could find not find anything on this. I hit enter and got no items matching this search. Curiouly i tried this on another windows 7 and got nothing matching this search term. We are talking about the same search window. Directly above the windows round icon with magnifiying glass in it..
Once again thanks for your paitience
January 13, 2013 5:36:58 PM

. Open the Control Panel (All Items view), and click on the Administrative Tools icon.
A) Close the Control Panel window.

B) Double click on Local Security Policy to open it.

This method did not work for me either local security policy was not listed here either.
January 13, 2013 5:40:22 PM

No -- the Start button search/run window that is the line just above the taskbar, not the Windows Explorer search box.
January 13, 2013 5:43:55 PM

You need to be logged in an administrative level account to run it, but you can also find secpol in Windows/System32 just scan down alphabetically until you reach secpol.
January 13, 2013 5:46:02 PM

By design, Windows 7 Home premier doesn’t support Domain Join && Group Policy controls. Thus you can’t use GPedit.msc and Secpol.msc utility. Based
on my understanding, I assume that you encountered “Unidentified network” in Windows 7 Home Premium.

Oh Dear! What next
January 13, 2013 5:47:43 PM

darn it !
secpol.msc doesnt exist on window 7 home premium ( or not so premium as it is turning out)
they dont make it easy those folk at microsoft
January 13, 2013 6:03:55 PM

Ak, Home Premium. I only use Pro, Ultimate and Enterprise.

You may be able to fix the issue by deleting some registry entries for the unidentified network that you have, not sure of how else to fix it in Home Premium. Use regedit and navigate to this key

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles\<some big hex code>

open the last and look for profiles with the "Description" or "ProfileName" that uses Unidentified network and delete it, then reboot and attempt to setup a new network connection.

January 14, 2013 6:43:32 AM

Thanks. I did not resort to the register thing but was messing about trying to put the hard drive into another PC. I then found it wouldnt work in that and then i bought it back onto the original. It had by that time lost all internet memory ( more by luck than judgemnt) I put a wirelss card in got a connection then went back to old hard wired variety and bingo it has interent connection. Although not net work connection which i can live with. Thansk very much again for your time on this.
May 10, 2013 3:12:22 AM

RealBeast said:
You need to change that to a home or work network to match the others. If the unidentified is the only one, change it to a home network rather than public. If you cannot do that just by clicking on the network icon and change it then you have to change the Windows setting for network security, like this:

In the start button search box type: local security policy and then open the one that shows at the top of the start box, click on network list manager policies, double click unidentified network and change it to Location type: private and User permissions: user can change location, apply, then okay. Reboot.

Now open the network control panel and change the public to a home network and check that you have the adapter configured to automatically obtain an IP address from the gateway (network control panel, change adapter settings, right click select properties, highlight Internet Protocol Version 4, Properties button). Now if you do not connect, open the command prompt box and type ipconfig /release and then ipconfig /renew.


This worked for me for 50%, i did this + if u click on the Local Area Connection where u got unindentified network go to properties-->configure and than power management here you need to disable "allow the computer to turn off this device to save power" dont ask me why buth when i did this + changed it to local insteat of public it worked fine (after 4 days of searching omg... well i hope i help some 1 else with this post

greetzz...
!