Sign in with
Sign up | Sign in
Your question

Cascading router and DHCP conflict?

Last response: in Networking
Share
January 14, 2013 10:43:06 PM

Hi there. Ive been reading all over the Internet looking for a solution to this problem, yet so far its still messing my net setup.

As I see in your Ultimate Guide, Im trying to setup what you called "Cascading router".

I have a router (A) connected directly to Internet (cable ISP), and to my PC via ethernet wire. (A) IP is set to 192.168.1.1

I have a second ethernet wire running from a LAN port from (A) router to a (B) router LAN port located in another place in the house. (B) router set to 192.168.1.2 and both in AP mode. (A) channel is 13, (B) channel is 2. Different SSID (I dont care about roaming at this time)

I disabled the DHCP server in (B) and enabled in (A), making its lease range from 192.168.1.10 to 192.168.1.100

Okay, after all of this I keep Internet in my PC connected via ethernet to (A).

But wireless devices... I enable Wifi on the tablet, connect to (A), voila! get 192.168.1.11 (.10 is set to my PC) and I can access Internet and both routers by browser. Then I move to the (B) signal (different SSID network), get same IP (192.168.1.11), and I yet have access to Internet and both routers via their LAN IPs. So far so good...

Now the wtf part comes when I try to get back to connect wirelessly (PC connection is all good through all process) to the (A) router. It just stands there "Obtainning IP address...".

I can see in the (B) router access control it disconnected from (B).

I see in the (A) router access control its MAC address listed under connected Wireless devices (only MAC and name), but theres no sign in the (A) LAN category, where it list all Ethernet and Wireless Access to (A).

To mention when I connect wirelessly through (B) it shows in that (A) list my Tablet MAC but as an Ethernet connection (guess thats fine as theres a router LAN port from B in the middle).

(A) is a Hiltron CDE-30364 (set as Router Mode)
(B) is a Conceptronic C54BRS (set as AP)
(B) Wireless modes are:
-AP
-AP Bridge Point to Point
-AP Bridge Point to Multi-Point
-AP Bridge WDS
-Ad-hoc Station
-Ad-hoc Infrastructure

I tried with both DHCP servers disabled, made my PC fixed IP and granted access to Internet and total LAN visibility (both routers are accesible).

Wireless devices I tried making fixed aswell. It connects, but I cant access WAN or LAN (no internet, no lan access to routers), grey signal in both devices (Idk it may be something referred to both Android devices, but I tried in the mono-router setup I had previously and I could connect with fixed IP from the Tablet and smartphone).

Well, thats all the precise I could be, please if you need any kind of image of any of the routers setup pages, ask for it so I can upload them all, same for manuals I have the links for both pdfs in some place (yet they are not helpful at all, more like brain-dead Users Guide.

Another question, I guess its fine but... BSSID on (A) wireless network is set to (A) BSSID Primary MAC as it lists in the router config status page (it lists about 4 diff MACS for the (A) only differing in the last number). BSSID on (B) wireless network is set to (A) RF MAC Address. With set I mean theres no option in router (B) as AP to choose the BSSID so I guess it justs auto-set from (A).

Any help would be much appreciated. Thanks in advance.

More about : cascading router dhcp conflict

January 15, 2013 3:52:51 AM

I'm having a bit of a hard time following all of your configuration, but I did notice one issue. Are you located in the USA? If so, it is only legal to use channels 1-11. Channel 13 is likely to cause and encounter interference from other devices. That could be the source of your problems.

802.11g channels are separated by 5 MHz, but are each 20 MHz wide, which means that each channel overlaps with the adjacent 4 channels. So, with your AP (A) on Channel 13, if your tablet device is configured for use in the USA, it would be able to see AP (A) because 13 overlaps with 11, but the signal would be pretty bad.

I'd move AP (A) to channel 11 and see if that helps. Depending on the other devices in your area, there may be better channels available, but it is usually best to stick with 1, 6, and 11. If those channels are really congested in your area, it might be better to use something else, but make sure they are at least 5 channels apart.

If you are outside the USA, make sure you use channels that are licensed for your country. You are likely to run into interference with other channels.

On another note, your DHCP configuration seems fine. You disabled DHCP on one router and changed its IP address to not match the first router. That is all correct. Your second router will just behave like a switch with a wireless radio in it (although the WAN port will be useless).

--Russel

January 15, 2013 9:20:35 AM

First of all, thanks for your response I really appreciate someone spend its time reading that textwall :na: 

Im not located in USA but in Europe. All of the wireless devices are enabled with EU setup in the wireless Android config. I moved the (A) channel to 9 and it keeps doing the same thing.

I just noticed one thing...

(A) finally gives IP to my wireless devices after them being connected to (B), problem is, it takes about 3/4 minutes to do so! (I was always losing hope before)

The first connection of the day to (A) is almost instant (I cant even see the Wire networks after enabling Wifi and its already connected and assigned an IP, same for (B), this one always connects me fast enough, no matter how many times I change network in the Tablet/Smartphone.

So, If I connect to (B) and reconnect to (A), it stays about 3/4/5mins to get an IP. I can confirm its assigned the same IP as the first time connecting to (A), and the same one that I get when connecting to (B).

So, it seems like when a device was assigned to (B) prior to (A), DHCP takes too long to assign IP to (A) connected devices even when the device always get the same IP.

Just to remember, when Im having this problem on my Tablet (4mins to assign IP after being connected to (B)) I can connect in 1/2s and be assigned an IP with the smartphone if I havent connected it to (B) before. If I do it runs into the very same problem.

So, it doesnt seem a problem with the (A) DHCP server because while it hangs assigning IP to the tablet it does "on the fly" for the Smartphone if it hasnt been in (B) before.

Could it be (B) is not disabling the device even when it dissapear from the (B) devices list and so it creates a conflict assigning a new IP to an already existing MAC? Ive been looking for all of the options in (B) that could cause problem and found nothing.

Should I enable Pre-Authenthification in (A)? Im not sure about what this does.

WMM mode is enabled in (A) but disabled in (B), is it all right?

I have NAT/QoS/Firewall all disabled in (B)

The (A) router writes this to the system log whenever I power both of them every morning:

ID: cmstatus
Level: Warning
Text: MIMO Event MIMO: Stored MIMO=1 post cfg file MIMO=-1;CM-MAC=(heres comes A RF MAC);CMTS-MAC=(this MAC Idk);CM-QOS=1.1;CM-VER=3.0;

The first MAC is the (A) RF MAC, the second one Im nt really sure but I think its related to (B). As I said previously, my (B) network signal has the (A)RF MAC assigned as (B) BSSID. Idk why it did so or if its working as intended. Maybe it should use the second one (wich should be its real one) but Its using the (A) RF MAC, and (A) is using (A) BSSID (it has 4 MAC related).

In the (B) Wireless settings I cant see anything related to MAC right now (AP mode), only If I change to any Bridge mode I can see that I set that previously when I tried in AP-Bridge mode, but I doubt thats interferring after changing back to AP (?).
Related resources
January 15, 2013 1:19:08 PM

Ok, I will update the thread hope someone can give me a hand here.

I made a factory reset to (B), and it reverted back its BSSID to its own related MAC, so far so good.

I made all of the process (192.168.1.2, DHCP disabled...) and now I dont get any error message in the (A) log while booting. Anyways I dont think that was a problem as I was getting Internet connectivity from both wireless networks already.

Another thing is I can see the (B) router in the (A) LAN tab of devices, listed as Ethernet self-assigned IP.

In this same LAN tab when I connect with the tablet in any of the 2 wireless networks I get same IP assigned for it (192.168.1.101) but it changes like:

Connected to (A) lists it as Wireless(N)
Connected to (B) lists it as Ethernet

Well this was already happening before, just I couldnt see (B) in that tab before even when it was doing good.

So the thing is, I keep having to wait like 3/4/5 minutes to reconnect to (A) and waiting for IP assignment all that long without it being listed in the LAN (should be Wireless(N), it dissapear as Ethernet so it means knows the device disconnected from (B)).

When it reconnects to (A) after being in (B), I get same IP (...101) and, If I disable wifi connection in Tablet and reconnect again to (A), it connects like a charm in less than 1s. Problem is, If I get back to (B) then (A) will last like 5mins to reassing me the same IP. Just like:

(A) fine --> (B) fine --> (A) 5mins to assign IP.... --> (B) fine --> (A) 5mins again...
(B) fine --> (A) 5mins..
(A) fine --> (B) fine --> (A) 5mins... --> (A) fine...

From (A) to (B) I dont have this problem. Guess what the problem could be? Notice both Wireless networks have differents SSIDs (WLAN_R/WLAN_S) but same Encription protocol and key. I also tried making (A) only B/G (its N compatible) just to make it the same as (B) but that wasnt the problem either.

While Im stuck at IP assignment in the Tablet for the 5 minutes, I cant see it listed in (A) LAN tab as I said, but I can see it under Wireless tab even when its not connected in the Tablet nor accesive to Internet (stuck at IP...).

WTF WITH (A) U ********* ******

Theres any way you can "spoof" or whatever is called, the DHCP process in (A) to determine why in the earth it could take soooo long? Its making totally impossible to roam around the house networks (reason I didnt make them same SSID so it would be worse than a waste).

http://www.hitrontech.com/doc/product/10/Datasheet_CDE-...

Update: If I set my wireless device with Fixed IP it connects in 1s always, but in the same spot as before (B->A) it just stay gray for about 3/4/5 mins before getting Internet connectivity... so, same problem.
January 15, 2013 10:40:10 PM

Nobody? I made factory reset to both of them. Configured from scratch. Same thing:

(A) --> (A) --> (A) connects fine disconnecting wifi and reconnecting to (A) again.

(B) --> (A) keeps making me wait about 4mins to be assigned an IP by A again ( I always end up with the same no matter wich wireless network I use)

DHCP only enabled in first one.

Tried enabling DHCP only in the second one b4 the factory reset, it would assign me IPs on the fly in both wireless connection (no problem from B to A) but I have no Internet access. I guess its obvious why you need Master router to DHCP server, as Slave is not giving me any DNS but itself.

I talked with an ISP tech guy he told me it was well done to do cascade-routering, told me he didnt know wtf could be but the ISP wouldnt send anyone for free as its an added (even when the problem comes from the non-add, sigh...)
January 16, 2013 2:20:49 AM

Hi Toperharrier,

I am almost 100% positive that you have a link-layer problem, and not a network-layer problem. In other words, there is no problem with DHCP. Your problem is with the wireless link instead.

Your troubleshooting has been very good so far, but I think you've been spending some time on the wrong issue. DHCP is not needed at all for any sort of IP networking. It really is just a convenience for automating network configuration. You already confirmed that with static IP addresses you still have the same problem, so DHCP is 100% ruled out.

At this point, I can think of only one likely problem:
There could be an issue with the CAM table in the internal switch on (A). The CAM table in a switch is used to correlate MAC addresses to physical switch ports. When you are connected to (A) over WiFi, the CAM table in the internal switch on (A) will show that your wireless device's MAC address is reachable over the port connected to the wireless radio. When it switches to (B), the CAM table has to be updated to correspond to the switch port that connects (A) to (B). I suspect there could be an issue when you switch back to (A) where the CAM table in (A) never gets updated to reflect that your MAC address is now reachable over the switch port connected to (A)'s internal radio rather than the switch port connected to (B).

The problem here is that I've never seen any consumer-grade wireless router running stock firmware that had any way of displaying the CAM table, so troubleshooting or ruling out #1 will be almost impossible.

One way I can think to validate this theory is to manually set the MAC address on your tablet's wireless radio. I don't think Android permits users to change their wireless MAC address. (Perhaps you would be able to if it were rooted, but I don't know.) If you change the MAC after moving from (B) to (A) and the problem goes away immediately, then this is it.

Another way to validate the theory would be to connect a hub between (A) and (B) and then connect a second PC to the hub. (It would need to be a hub, and not a switch.) You could then use Wireshark in promiscuous mode to capture traffic while your PC connected to (A) pings the tablet. As soon as you disconnect your tablet from (B) and connect it to (A), the PC running wireshark should stop seeing traffic, but my guess is that it will continue to see traffic. I would guess that the PC running Wireshark would continue to see traffic for 3-5 minutes until the tablet starts working on (A).

Most CAM tables have entries expire after 3-5 minutes, so that would fit with the symptoms you are seeing. I've drawn a simple diagram describing the test. It may be more than you want to deal with, but if you can come up with the equipment, PM me your email address and I'll send it to you.

A possible workaround might be to reverse the role of (A) and (B). If (B) can be used as your primary device to connect to the Internet and (A) can serve as your access point, the problem may be completely solved.

--Russel
January 16, 2013 2:43:38 PM

Well, firstlyl thanks you very much for the detailed reply, Im very thankful you took the time to analyze my problem and give me some hints about to work with.

Im working in the MAC address change right now (I have both tablet and Smartphone rooted) in the Tablet but Ive been unable to make the address file in the /sys/class/net/wlan0 keep changes, it reverts everytime so Ill make a bit of research or try to get another wireless device capable of.

Ive researching about the CAM and ARP tables and it makes a lot of sense that the problem could be right there as you appointed, but unfortunately I cant revert the routers direction (B->A) as (A) is a cable-modem-router and (B) is just a neutral router I bought when I had just a cable-modem from the same company (they refused to give me a wireless router or a wireless cable-modem-router as they did later). So (B) lacks the coaxial input where the Internet comes from.

Ive also been trying Wireshark in few situations, firstly connecting to (A) without roaming from (B), the result was a clear DHCP Request and instant DHCP ACK exchanging the IP request and answer with no more of a problem.

Then I tried it connecting to (B), so far so good.

Well, hands to the problematic situation I havent been able to make much of a guess. Tablet makes the DHCP Request (source and destination MAC seems fine, no error packets) but theres no response at all from (A). Then the tablet tries to make some ICMPv6 router solicitations through ICMPv6 multi-cast, which, with the time, end with a Multi-Cast Listener Report Message that tells to exclude such MAC (Tablet) from the Multicast. Theres also some DHCP discover messages (it surprise me they are sent from Tablet MAC), but they look completely normal and theres no response at all.

The DHCP Request and Router Access Petitions thru ICMPv6 are continous from the tablet, but I cant see anything coming out from (A). A curious thing is in this time Im stuck with wireless connect from Tablet, I can also see some Neighbor Solicitations from my PC to the router and the Tablet (both have correct MAC addresses).

Ill do some wider research with Wireshark, but Im curious to know why Id need to use a hub from (A) to (B) (I guess you mean in the same LAN-to-LAN segment?). Maybe it wont work the way Im doing.

Theres anything I could use to see where (A) has set the Tablet in MAC table in that moment? I mean, could I trace the Tablet IP somehow from the PC with Wireshark while it hangs in DHCP request and figure from the response if its related to the Wireless or Ethernet (A) MAC adapter (I guess not?). Maybe Im doing it wrongly and I need to set another PC in a hub as you said, nuff me.
!