Sign in with
Sign up | Sign in
Your question

Kernel panic during install of Mandrake 8.2

Last response: in Linux/Free BSD
Share
March 30, 2002 10:17:58 PM

This is a copy of my message posted to
comp.os.linux.setup

I think the problem may be due to BIOS or
Motherboard Gigabyte GA7-VTXE (Athlon 1700 xp)

-----

Apologies first for the length of this message.

I have a new PC, freshly built no operating system on it.
I cannot get a linux install program past initial loading
into memory stages. The splash screens will appear,
I can choose one of the options but at the next stage
when it tries to load linux from CD rom it goes wrong.

Usually after the bit where it says
RAMDISK: Compressed image found at block 0.
Uncompressing .... crc errordone
Freeing initrd memory:595K freed
Kernel panic: VFS: Unable to mount root fs on 01:03

This happen on Mandrake 8.2, earlier versions like 8.1, 7.2
give less meaningful errors (sometimes just hang).

RedHat 7.2 gives similar messages
RAMDISK: Compressed image found at block 0.
crc error freeing initrf memory: 2046k freed
Ext2_fs: unable to read superblock
cramfs: wrong magic
iofs_read_super: bread failed dev=09:02 iso_blknum=16, block=32
kernel panic: VFS: unable to mount root on 09:02

I have tried different CDrom drives, DVD drive all get same error!
Does anyone think this may be Motherboard/BIOS
incompatibilty?
Would any kernel settings during boot help?
I've already tried idebus=66
idebus=100
ide0=ata66

Note the Mandrake 8.2 CD boots up fine on my old PC.

========================
Now for the longer explanation

PC spec

Motherboard Gigabyte GA-7VTXE (AMIBIOS version Date 01/23/2002)
CPU Athlon XP 1700
512 Mb DDR ram
TDK CDRW drive
Toshiba DVD drive
Western Digital hard drive 80Gb
Jetway ge-force2 AGP graphics

SoundBlaster Live 1024!
Adaptec SCSI card
SMC Ethernet card

On one of the start up screens I saw that the
sound card was on same IRQ as USB controller
and the SCSI card was on same IRQ as graphics card

-------------------

Mandrake 8.2 booting from CD

splash screen appears, press enter, blue loading bar fills then text
messages appear

Linux 2.4.18-5mdkBOOT

Uniform Multi-Platform E-IDE driver Revision: 6.31
VP_IDE: IDE controller on PCI bus 00 dev 89
PCI: Hardcoded IRQ 14 for device 00:11.1
VP_IDE: chipset revision 6
VP_IDE:not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with
idebus=xx
VP_IDE: VIA vt8233 (rev00) IDE UDMA100 controller on pci00:11.1
ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:D MA, hdb:p io
ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:D MA, hdd:D MA
hda: WDC WD800BB-00CAA0, ATA DISK drive
hdc: TDK CDRW241040B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 156301488 sectors (80026MB) w/2048KiB Cache, CHS=9729/256/63,
UDMA(33)
Partition check:
hda: hda1
Floppy drive(s): fd0 is 1.44M
FDC 0 is post-1991 82077
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 32768)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0
RAMDISK: Compressed image found at block 0
Uncompressing .......................<3>crc errordone.
Freeing initrd memory:595k freed
Kernel panic: VFS: Unable to mount root fs on 01:03

----------------

Booting RedHat7.2 different results
...loads of messages ...
hda: WDC WD800BB-00CAA0, ATA DISK drive
hdc: TDK CDRW241040B, ATAPI CD/DVD-ROM drive
Uniform CD-ROM driver Revision: 3.12
Unable to handle kernel paging request at virtual address ffffffb7
printing eip:
... stack dump ...

<0>Kernel panic: Attempted to kill init!

----------------------
off-topic

Windows 98 Second Edition gets as far as doing a scan disk
(in a previous attempt it had managed to format C:) 
then
Please wait while Setup initializes
Scanning system registry
then nothing happens
-------------------

TIA,

Mike
March 31, 2002 1:42:00 AM

I used to have that problem with Mandrake too every once in a while... Alls I did was just re-install the OS. Worked every time. Now I've moved over to SuSE and don't have problems anymore at all...

If my baby don't love me, I know, I know, her sister will.
March 31, 2002 3:15:43 AM

That it doesn't work with 2 distros, and even Win98 has problems suggests to me that it's not a Linux problem but a regular hardware conflict type of problem.

I've run RH7.2 on Athlon XP, but it was using a Gigabyte GA7-DXR+, with AMD 761 chipset. The VIA KT266A your board runs seems to work well enough for others, so the Mobo should be ok. The BIOS is an unknown, but then again, are you using the latest bios (f6 or f8a)?

First thing I'd try is stripping the system down to just HDD, video, 1 cdrom, and see what happens. Also, get a copy of memtest86 and make sure the ram is ok etc.



<i>I used to have a girl, but then I got my CS degree...</i>
Related resources
March 31, 2002 10:33:40 AM

Thanks for the tip about memtest86, I ran that and it
found loads of errors. I checked that the memory
card was seated correctly, so its back to the shop after the Easter break.
April 6, 2002 9:12:56 PM

I've gotten kind of fond of Mandrake over the years for it's ease of installation. I mean, once you've got Linux on your machine, the distribution doesn't really matter so much.

I've also run Debian at school, but find that the upgrades aren't as quick as with Mandrake.

Tell me silverpig, what is SuSE all about? I have a new machine coming in next week (dual AMD, 2GB RAM, ~10 X-terminals hooked up towards it), so I'm considering getting away from Debian and go with Mandrake, unless SuSE is the way to go...?

<font color=blue>gnintsakgnirkskir ksron</font color=blue>
April 7, 2002 7:28:03 PM

The shop replaced the memory and I've installed Mandrake 8.2 on my new PC and it works fine :-)

Note I have SuSE pro 7.1, I installed it once on my
old PC but found it a little more difficult than Mandrake. By default it didn't use CUPS for printing which meant poorer results on my Epson Photo 870.

I'm nit picking here and with some effort I'm sure SuSE could have been reconfigured. Its just that I find Mandrake to be easier to install, and easier to maintain
because of DiskDrake and DrakConf tools.
April 8, 2002 1:55:47 AM

Nice to hear it's working. FWIW, I only use Crucial RAM now - it's about the same price as generic RAM, but the quality is great. I've never had a bad stick from them.

You're right, you could "fix" Suse 7.1, but why bother? Suse 8.0 is about to be released, and Mandrake 8.2 is nice anyway.

<i>I used to have a girl, but then I got my CS degree...</i>
April 8, 2002 7:49:12 PM

I switched to SuSE just for a change of scene really. I've found that it's more difficult to compile source from tar.gz files, and to install rpms by the command line with SuSE (sometimes it just doesn't work...). However, there's the mother of all config programs includes with SuSE called YaST (2 versions come actually, one is menu like, and the other is totally gui). All you have to do is start that up, locate the package to install, and boom, it's done perfectly every time.

YaST also does auto updates sort of like windows. You just start it up, hit check for updates, pick an ftp server from a list, and it downloads and installs everything for you. Of course, if you want to do it all manually, there's that option too.

The only real problem with SuSE is that it's not offered in ISO form over the net. You either have to download a boot floppy and install via ftp, get a friend to send you the iso, or buy the cds in order to install it. Kinda a pain really, but I've had fun with it so far.

If my baby don't love me, I know, I know, her sister will.
!