USB printer/ USB ports not working anymore! HELP!

One night my USB printer worked, the next moring it did not.

Abit KT7A, 2 onboard USBs, 2 extra USBs. 1.4 GHz AMD Athlon. Windows 98. 512 MB Ram.

Printer is USB printer. I also have Palm desktop, will not backup my palm anymore through USB. USB joystick is not recongnized anymore. I can see the usb ports in windows, but cannot recognize my printer at the ports. I tried to reinstall drivers, uninstall drivers, change motherboard settings, etc. It all seems silly, since it worked fine one day, and then just didn't work.

Anyone have some ideas on what I can try?
Please, I need help.
7 answers Last reply
More about printer ports working anymore help
  1. USB is NOT reliable, especially as you go farther back in chipsets. I'd try removing the USB controller from device manager and reinstalling it.

    <font color=blue>You're posting in a forum with class. It may be third class, but it's still class!</font color=blue>
  2. Make sure the USB ports are enabled in the CMOS setup.


    Details, Details, Its all in the Details, If you need help, Don't leave out the Details.
  3. I have tried both of your suggestions. 1. I uninstalled all of my USB drivers, and the system detected the ports after a couple minutes and reinstalled the drivers. 2. I have checked my CMOS and USB is enabled. I tried both enabling/disabling in the BIOS, wondering if the OS was trying to drive them instead of the BIOS...

    I have tried everything I can think of. Thanks for the suggestions. Do you have anything else I could try? (Upgrade to XP? :\ )
  4. USB, as mentioned before, is far from reliable. I had the exact same problem as yourself, it knocked out a webcam and an ISDN modem on my brother's PC.

    I tried all of the above solution with no success. However I did upgrade to Win XP Pro (from Win ME) and it solved the problem.

    :eek: Santa gives good head :eek:
  5. I tried upgrading to XP pro, but it did not solve my problem. (XP looks pretty cool though.) I uninstalled it and am back to where I was.

    My friend told me to try unplugging the two USBs that plug into the motherboard (not PCI), and see if that does anything. Does this seem like a good idea? Any other suggestions?

    Both USB hubs and controllers show up in System Devices, but will not recognize any devices plugged into them.

    Thanks,
    Pauvre
  6. I would suggest you uninstall the USB host controller and reboot. Windows will reinstall the host controller and redetect all the device connect to it.
  7. i know that on my sisters dell, it was a power thing, you might think about a usb hub. it worked for my sister

    YAhhhhhhh!!! Jan 27! Advance geforce fx seeing with Steve Molnar!!!!!!!! -you see, sticking with bou scouts finely paid off -mom
Ask a new question

Read More

USB Printers Components